• Please review our updated Terms and Rules here

Search results

  1. E

    Picked up an incredible Commodore 64c haul yesterday w/ some really fantastic/rare items. However the C64 itself is (mostly?) dead - tips appreciated!

    You mentioned you tried 3 different PSUs but did you test the PSUs first? C64 power supplies have a bad tendency to over volt on the 5v rail, and plugging in a bad one will damage some of the chips on the motherboard. (In my previous experience, I fried the ram chips so wasn't too bad...)...
  2. E

    A2000 won't run certain games like Cannon Fodder (RAM?)

    Talking about disk drives gave me a theory... Falter, what kickstart version does your amiga 2000 have? If its 2.04 or above, are you booting from df0? If you have two disk drives in the system, or if you have an incorrect cable it might be using your disk drive as df1 which some games dont...
  3. E

    Commodore 64 video cable help

    You're correct, you shouldn't need to, but as the wrong connector was used it obviously won't fit. 80186 should either return it to the seller and get an exchange, and hopefully get the correct one, or he can just cut the two top pins as I mentioned. These two pins aren't used, so it's fine to...
  4. E

    Commodore 64 video cable help

    It's the wrong type of DIN used. It should be the horseshoe type. It can still work, but you will need to cut the top two pins off. I've done this with connectors I've bought from my local electronics store because they only stock the round type and it's worked fine.
  5. E

    C64 IN PET S' CASE

    I saw in a previous post that the RF modulator had been removed, and it seems from this point on the video signal is no longer on pin 15 on the VIC? The RF modulator is required to get a signal from the VIC. Maybe resolder the modulator back in and check pin 15 again?
  6. E

    C64 IN PET S' CASE

    Keep us posted @Desperado! I'm keen to see this working!
  7. E

    My first IRQ conflict! Need some help.

    Can you disable the LPT port in the bios? That might help rule out that conflict. It's looking to me like the sound card might be faulty though if it's not detected while trying to configure the sound card with irq 5.
  8. E

    High pitched squeal from C64 when turned on

    Just an update, when I touched C13 the noise went away. I replaced the cap but the noise was still there. I ran a bodge wire from the output of c13 to the audio out on the DIN connector, and it seems to have fixed it! Easy fix!
  9. E

    High pitched squeal from C64 when turned on

    Hi all As the title suggests, I'm getting a high-pitched squeal from a c64 when it's turned on. It's not the monitor/crt, as the same monitor hooked up to a different c64 doesn't make the noise. Suspecting the SID chip, I removed it and the noise goes away. I put a different SID (from the...
  10. E

    USB-C to 1541-ii/1581 PSU

    Chances are if you find someone that sells them complete is that they got them built by jlcpcb/pcbway. If someone can make a CPL file, then I'll order some for myself and then I'll finish making it for you and you can have one at cost price + postage.
  11. E

    USB-C to 1541-ii/1581 PSU

    The gerbers are available on github. You'll be able to send these off to jlcpcb or pcbway (etc) and get them to make the board. If you can make a BOM to go with it, then the pcb maker can do the smd work for you. I'm not sure how to create a BOM for it but I'm sure there are much smarter...
  12. E

    Startup error on Commodore PC40-III

    The DS1287 and DS14287 have a small difference that might cause problems. Pin 1 on the 1287 is a bus selection pin, and the 14287 has ram power output. So going of that, I would think it won't work. The one you linked to ebay should work. The github for that replacement can be found here...
  13. E

    Amiga 1000 Software Error

    I've already swapped them and no difference (post 3). I have a friend who has a retro chip tester so will try and test the memory chips in that and see what happens.
  14. E

    Amiga 1000 Software Error

    Good news and bad news is it's all good so far! I'll let it keep running for a while and see if a fault pops up... Might investigate that timing issue just to make sure that doesn't affect anything. I think CIAa is responsible for the FDD, so a timing issue with that might have something to...
  15. E

    Amiga 1000 Software Error

    I tried MBRTest-2 (edit, oops, 1.3 - I'll see if I can find v2) but when I go to open the disk drawer I get the system request fault! I got the newer ATK 1.19 (was using 1.16) and still have memory passing but the CIAA timer fails (1% error). Second edit - I just read the readme file (using...
  16. E

    Amiga 1000 Software Error

    Do you know where I can download a copy? Edit - think I found a copy...
  17. E

    Amiga 1000 Software Error

    In ATK it passes the memory test (I ran the test for about an hour with no problems). There are some dip switches on the board, but I can't find any documentation so don't know what they do.
  18. E

    Amiga 1000 Software Error

    Thanks Tim, yes I have been using KS1.3 I agree that I don't think the timing error is a problem. I wanted to eliminate this as a possible problem though. I've seen the TODCIA signal comes from either TICK50 or /VSYNC. If it's coming from TICK50 (I'm in australia so 50hz as opposed to 60hz...
  19. E

    Amiga 1000 Software Error

    I will need to have a look at the schematics and bust the oscilloscope and see what it clock is being fed to the cia. I did try and swap the CIAs around but the error remained at CIAA. Thanks Dave, I'll report back with my findings
  20. E

    Amiga 1000 Software Error

    Hi all I've been working on resurrecting an amiga 1000 for a friend, and after diagnosing some chip ram fault I have it to the point where it is mostly working. I've tried various games and while the odd few don't work (possibly bad disk or incompatible with the NTSC machine I have), most of...
Top