• Please review our updated Terms and Rules here

Camputers Lynx

Gary C

Veteran Member
May 26, 2018
Lancashire, UK
Got given two of these machines in a poor state. Cases open, keyboard hanging out and no PSU or video cable.

PSU nocked up from an AT PSU as this machine needs a -5V as well as a +5V and +12V

First machine powered up on UHF and my really old LCD won't take it. RGB nocked up and I get a very faint ghostlike display but at least its working. More investigation and its because I haven't put any power to pin 16 of the scart plug and the TV thinks its composite video being sent to it. Had a spare lead at the museum that has a +5v from the adjacent port to pin 16 and now a nice clear display, yay

Second unit, no such luck. Missing a bank of memory. The working unit has some 4564 and I just happened to have 8 4164's on stock which are equivalent, replaced and away we go. Two beeps and the Lynx logo on the screen.

Also a burning smell ? nothing appears to be hot and its still running ? Humm... However the cursor is happily moving across the screen by itself. Plug a keyboard in and it responds to presses but still with almost but not quite random spaces. Looking at the drawing, the keyboard bus comes through a 74LS244 buffer and touching it, the blanks have gone. Close inspection and the topside of the board, the float solder hasn't sucked up the legs and the top pads on three pins are dry. I have seen this a number of times recently (the ACT Sirius disk interface) and is something to look out for. Seems like poor wetting of the via not allowing good capillary action.

Liberal application of some good rosin flux and reflowed.

Oh, and I found the source of the burning. The machine 'de-modified' itself. It looks as if this unit had a jumper wire from +5V to the RGB socket, probably to make a scart plug work but with a more elegant single plug solution. Must have shorted out with the retrocomputing dual plug :)

So thats two working units.

The disk interface is interesting. It used an interface that just contained a ROM with the disk operating system and an actual interface with a FD1793 on board. Never seen a set for sale but someone has produced Gerbers and the IC's used aren't rare so have ordered the parts :)
Interestingly, the PCB disk drive interface calls for a SN54LS08 rather than a 7408. I know the basic differences but I wouldn't have thought a military grade logic chip would be needed over a standard 74 ? Maybe a 74LS08 might be too slow, but I can't see the extra current draw of a 7408 being significantly problematic ?

One unit is missing its speaker. A 64ohm (!) 2" unit which I have managed to find an equivalent and am currently printing a replacement bracket.

But boy is the screen update slow !

It apparently bank switches separate memory maps for Red, Green & Blue parts of the image !

Yeah it has banks for the 3 primary colours and another for "alt green".
So the 74LS244 was actually a dud, data was passing at variable voltages regardless of the gate voltage and seemed to change with temperature. Replaced and that bit now works fine.

Haven't tested the cassette ports yet but I do have an issue.

One unit when powered on just locks. Turn it off and on and it boots. Leave it long enough and it fails again. When failed, pulling pin 26 down resets it fine. Reset is a RC network through another 74LS244 (these must be one of the most unreliable 74 logic chips ?) acting as a logic switch by being permanently gated. Wonder if the capacitor is a little 'lacking' in farads ? I also notice a very big power up pulse on the 244 output as it powers up.

Will probably swap the capacitor first but feels as if I am missing something :)

Disk interface next

PCB's from here https://oshpark.com/profiles/gruffdba and ROM image from here https://github.com/ukscone/Camputers-Lynx/blob/master/Software/eproms/lynxdosrom.zip

The first board acts as a ROM expansion board carrying a 2764 EPROM with the Lynx disk operating system on board. Built this first and tried the command XROM only to get a Syntax error, how odd.

Looking though at the schematics (https://ibb.co/1RgjbNK & https://ibb.co/6RYxKkd) the chip enable pins are pulled low by the next board which carries the disk interface itself, which is sort of clever in that the DOS won't start up unless the disk interface is plugged in.

So completed the second board but with a couple of substitutions awaiting the specified parts. First is that the circuit wants a 54LS08 rather than a 74LS08. Can't see the reason for this as the specs are so close for the voltages I am using as to not be particularly necessary, but I will keep it in mind if it doesn't work. The second it specs two 120pf capacitors for the timing of the one shot IC CD4538 which is probably more significant.

I have a pile of ceramic 100pf's so just trying them for now.

All plugged in and the Lynx now responds with

Lynx DOS Vers. 1.0 HIMIM=&F51E

Which looks better. Just need to wire up a Gotek now but the PSU hasn't got another floppy supply connector. I have bought new plugs and pins so tomorrow it will be a job of making up a new connector.

PSU though will have to be replaced. An old AT supply is great but its much bigger than the original Lynx unit. RS do the Meanwell RPT-60A which should do the trick if I also print a Lynx lookalike case

Progress !
So connected it all up with a Gotek running flash floppy and an LDF image file. Flashfloppy doesn't know the LDF format and while the Gotek is accessed, its throwing up a 'no directory' error.

From another thread I note that HxC does know what an LDF file is so I might actually pay for the Gotek version as I have always wanted to give it a try.

I also will try an actual 40T SS drive and see what happens as I could also just read it back with the Greaseweazle to get a valid file.
Cant get Gotek working at the moment as I need to sort out the disk format, but connected up a 3.5" floppy and success :)

It creates a 800K disk when it detects an 80 track drive and most of the software is on 200k images, so I probably still need the HxC software as flash floppy doesn't understand the format natively.

Formated a disk, saved and loaded a program so the interface itself is fully operational.

Well chuffed.
As I like flashfloppy, I thought I would try a little harder to get that working with 200k image files, as almost all available disk images are 200k LDF files.

Flashfloppy needs some help to define the geometry of the drive as the Lynx does a head seek to track >40 then steps back until it sees track zero counting as it goes. If it gets to track 0 after 40 steps, it sets up for 200k images, 800k if its still not seen track zero.
So the Gotek needs to be limited to only 40 tracks to work properly with 200k files. As flashfloppy doesn't recognise the xxx.LDF extension, it doesn't configure correctly and steps to >40 tracks and fails the 200k detection.

So looking at a 200k image with the HxC software I can see its a single sided 40T 10 Sector 512 bytes per sector and sectors are skewed by 6 (ie sector 6 follows sector 1 etc), MFM with a data rate of 250k

To make it work it needs a IMG.CFG file creating to define the geometry. This can be set as a default so all image files on the USB drive are taken to have the specified geometry or set for specific file extensions.
I have specified this for LDF files (ie the [*.LDF] bit) but note, the image files need renaming from xxx.LDF to xxx.LDF.IMG). I will also put another list in defined as [*.LDF8] to differentiate 800k images.
Once I have all this working, I will see if Keir will include the LDF/LDF8 file extension into the FF software so that the IMG.CFG file becomes redundant.


cyls = 40
heads = 1
secs = 10
bps = 512
id = 1
mode = mfm
interleave = 6
cskew = 0
hskew = 0
rpm = 300
gap3 = 0
iam = yes
rate = 250
file-layout = sequential

The Lynx needs the ready signal from pin 34 so FF.CFG needs to be correct too.

File used for FF.CFG

interface = shugart
host = unspecified
pin02 = nc
pin34 = RDY

Plus all the other normal Flashfloppy FF.CFG stuff for OLED's etc.

Just booted Jet Set WIlly and it works !
Made a slight change to the IMG.CFG file. Put two geometry definitions that look for the same LDF extension but match to two different file sizes so that it can read 200k and 800k images.

cyls = 40
heads = 1

cyls = 80
heads = 2

All working except FORMAT. Behaviour is really odd. For a 800k file it happily formats 80 tracks and both sides and reports success, but for a 200k file, it formats side 0 only but continues past track 40 to track 80, returns to verify and fails at track 41 (because its overrun the file size)
Not sure whats happening. Obviously it is doing something with the config file because it only tries to format one side. Cant work out whats happening but I think I need to try it with a real 40 track drive.

Any ideas anyone ?

First board installed on the museum machine and working fine.

Built a second unit using an SMC FDC1793 (Rather than the Western Digital FD1793) and it doesn't work. Put the WD chip in and it works fine.

It might be a failed chip but in all other respects it works, heads step, format pulses being written, it just doesn't read.
And to add to the head scratching, made up a PSU using a Meanwell RPT-60A and while one machine boots ok, the other doesn't (they both work fine from an old AT PSU)

I imagine its something to do with the rise time of the various voltages

Scoping time !

First board installed on the museum machine and working fine.

Built a second unit using an SMC FDC1793 (Rather than the Western Digital FDC1793) and it doesn't work. Put the WD chip in and it works fine.

It might be a failed chip but in all other respects it works, heads step, format pulses being written, it just doesn't read.
New WD FD1793PL-02 inserted and it works fine.

Also tried the equivalent MB8877 and that didn't work at all (though I do suspect that one is fake)
Did I say it works fine ?

So I only tested that it could give a directory but when I tried to load something, I get an index not found for most files and some known working images wont even give a directory. Plugged in a 3.5" floppy and that works great so, its either the Gotek or the SD card.

Now the new Gotek is an .AT2 version using the controller with a tiny memory, tried the know working Gotek and the interface works great.

Looking on the flashfloppy website it looks as if the original Goteks are no longer generally available and the new units mainly use a Artery AT32F415 which has problems and can be marginal and apparently depends a lot on USB stick performance.

So, anyone know of a reliable source of the .AT4.35 type Goteks without paying the premium price that people on Ebay are asking ?

New Gotek with the F435 processor made no difference. Plug in an older gotek and it works fine but not with the newer ones :(

No idea whats happening yet.