• Please review our updated Terms and Rules here

Intel Plato motherboard (430nx) PCI VGA woes

purple toupee

Member
Joined
Sep 21, 2023
Messages
10
Location
Seattle, WA, USA
I have a new-to-me Plato motherboard that I'm gradually getting working. Having dealt with the dead RTC, I am now wondering why none of my PCI VGA cards seem to work.

Caveat! I don't know for sure that any of them are functional, so that may be your advice. I only have three to try, and none are really contemporaneous with the motherboard, so maybe that's part of the problem? One is an nVidia Geforce 4 MX4000, missing heatsink; the other two are "new" ATI Rage XLs like this one, which are plentiful on Amazon and ebay for some reason.

So -- what I observe is that, with the "new" cards, the motherboard immediately gives a long-short-short post code, which seems to mean "video card problem." (I get the same code if I try to boot with no video, as well.) With the "old" card, I get no beeps, but I also get no VGA signal.

I am HOPING there's some known quirk or thing to try that is maybe specific to one of these pieces of equipment; failing that, I'm in a tough spot, since I have no other PCI machines, nor any other PCI VGA cards to try.

Anyone have suggestions?
 

Timo W.

Veteran Member
Joined
Nov 25, 2014
Messages
2,006
Location
Germany
PCI 2.0, 5v only. That limits the number of usable cards quite a bit, as PCI 2.1 with 3.3v became the norm already in 1995.

Be careful with just trying what works. Not every manufacturer of much later cards did care about ancient PCI. You can possibly fry the mainboard and/or the card.

I use an ATI Mach64 card from 1994. S3 Trio32/64/ViRGE work as well.

Where are you from, btw? I have tons of e.g. S3 ViRGE cards and could send you one.
 
Last edited:

Makefile

Experienced Member
Joined
Jul 13, 2020
Messages
141
Location
MD, USA
Seconding S3 Trio64V+ or Cirrus Logic CL-GD5436 or 5434. The 5446 is better but I've had a PCI 2.0 board reject it before
Plenty of Trident TGUI9680 out there too
 

purple toupee

Member
Joined
Sep 21, 2023
Messages
10
Location
Seattle, WA, USA
Sadly, I live in the Seattle area, in the Pacific NW region of the USA. (I should add that to my profile.) I'm not going to ask you to send me cards from Germany, but I very much appreciate the offer. Fortunately, as luck would have it, I found and ordered a reasonably priced Diamond-branded S3 ViRGE card, so we'll see how that goes.

PCI 2.0, 5v only. That limits the number of usable cards quite a bit, as PCI 2.1 with 3.3v became the norm already in 1995.

Wow, I need to educate myself more. I don't remember any of this. I definitely don't remember worrying about compatibility for these cards. Then again, I don't think I used PCI for video for long; my hoard contains a single PCI card (probably from a later server) and 3-4 AGP cards. (I sure wish I hadn't given away by Number Nine S3 864 and my Orchid 3dfx card. So much regret.)

Wait, so I did a little digging, and it sounds like the 3.3v and 5v cards are mechanically incompatible. From Wikipedia:
The first version of PCI found in retail desktop computers was a 32-bit bus using a 33 MHz bus clock and 5 V signaling, although the PCI 1.0 standard provided for a 64-bit variant as well. These have one locating notch in the card. Version 2.0 of the PCI standard introduced 3.3 V slots, physically distinguished by a flipped physical connector to prevent accidental insertion of 5 V cards. Universal cards, which can operate on either voltage, have two notches. Version 2.1 of the PCI standard introduced optional 66 MHz operation.

Still I suspect (and hope) you are right -- the PCI spec did change over the years, and it's perfectly reasonable to think that a PCI card that came out 7 years later may not have been compatible with an older standard. We shall see!

Thanks folks.
 

Timo W.

Veteran Member
Joined
Nov 25, 2014
Messages
2,006
Location
Germany
PCI 1.0 is unrelated here. Yes, that one was different. I don't think there were any PC mainboards with PCI 1.0. It was a proposal only afaik.

PCI 2.0 had 5v only. PCI 2.1 added 3.3v, which most cards used. It could do 5v still as well, so older cards were usable. But just like later with AGP, some manufacturers did not care about making sure you could not damage anything when putting a 3.3v card into a 5v-only slot. You will find many PCI cards with both notches, even if they can't run on 5v. But cards up to 1995 are 100% safe to use. Most up to 1997, too. After that, better don't try.
 
Last edited:
Top