• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.

Olivetti Philos 48 color plus Drivers

melo

Member
Joined
Feb 20, 2020
Messages
20
Location
Italy
Hello anyone,

I was able to repair an Olivetti Philos 48 but unfortunately it doesn't have the original hard disk. Finding drivers and original software for these olivetti laptops is "impossible". As far as I know and according on my experience only those with original hard disks works as they should do.
So I'm asking if anyone here has an Olivetti Philos 48 (or 46) with original hard disk and if it is possible to have the drivers or better an image of the hard disk so my laptop can work again.
 

1ST1

Veteran Member
Joined
Oct 21, 2014
Messages
1,267
Location
near frankfurt/m, germany
I can check, I have a working one. But maybe only installed drivers. No idea how to extract them. At least I would be able to tell you which drivers are required that you can get them for example from Vogons driver site.
 

melo

Member
Joined
Feb 20, 2020
Messages
20
Location
Italy
Thank you a lot! I was about to give up with it.

I've a Philos 45 , to make it sound and record the only existing drivers were in an original hard disk I found in a faulty one from ebay. Before that I tried everywhere with no results. The only available on Vogons were the Video drivers. But some programs as a power manager and one called VOICEREC are impossible to find.
If you have Windows 95 installed on your Philos there are some programs that can extract the drivers ( but I would also need Olivetti programs).
 

1ST1

Veteran Member
Joined
Oct 21, 2014
Messages
1,267
Location
near frankfurt/m, germany
There is Windows 3.11 installed, in german language. It should be possible to copy the whole installation from the harddisk into an archive and provide to you.
 

melo

Member
Joined
Feb 20, 2020
Messages
20
Location
Italy
Thanks, would be great! With the whole installation I can solve my problems
 

1ST1

Veteran Member
Joined
Oct 21, 2014
Messages
1,267
Location
near frankfurt/m, germany
Just an update for everyone, I get some steps ahead...

Philos 44 works fine, after letting it run a while it loads the CMOS battery and I can go to setup, save config and start into dos. It also has Win 3.11.
Philos 44 color the same
Philos 33 color has a little trouble with the keyboard switch. So it needs to be touched carefully that the notebook does not think that the keyboard is flapped up and going to sleep mode. Otherwise, after setrting CMOS it boots fine ... into Windows 95! The Philos 33c needs to warmup a bit to display a better (readable!) picture on the LCD.

The nice thing is that on the Philos 33 Color there are some driver and manual folder for Philos. At the moment I make backup, first of the 33, then of the two 44.
 
Last edited:

aotta

New Member
Joined
Sep 20, 2017
Messages
7
Hi, sorry for resuming this thread, but I got a working philos 48, with a sort of fresh w95 installed and, of course, no recording driver and software.. Can you share it from your backups? Thank in advance!
 

1ST1

Veteran Member
Joined
Oct 21, 2014
Messages
1,267
Location
near frankfurt/m, germany
You have a message with a download link. It includes drivers for the Philos series. Unfortuantelly I can't find the harddisk copies, I think I have to redo the backups again.
 

aotta

New Member
Joined
Sep 20, 2017
Messages
7
Thank you very much 1ST1! The manuals, the Olivetti customized organizer and, in particular, the drivers, seemed lost anywhere else!
A last question: in you backups i found a win95, a win3.1 and a win 3.11 ones: do you know if the original OS shipped with Philos was the 3.1 or not?
 

aotta

New Member
Joined
Sep 20, 2017
Messages
7
Well, after a lot of tests.... i couldn't get audio working with olivetti's drivers.
The only backup that had the right voice.drv & others needed files was the Win95 system folder, but even with that driver installed in win 3.1 (and displayed in control panel as "Olivetti voice" or something similar) i had no sound, and voice record showing a "device in use" when tested.
At the moment, i rolled back to the speaker.drv to have sounds in windows, and wait for some new hints.
Thank you again 1ST1 for the support, and happy new year to everybody!
 
Top