• Please review our updated Terms and Rules here

Recent content by Ozzuneoj

  1. O

    NEC Multisync II - Blank white screen?

    Okay, more developments! I built myself a 9pin analog "Multisync" to VGA cable (just lopped the end off a VGA cable and put a DE9 end on it using mR_Slug's pinout) and it seems to do basically the same thing as the CGA\EGA cable, so my cable works! Yay! But, that means the problem is something...
  2. O

    NEC Multisync II - Blank white screen?

    Those do look handy. I have lots of the solder-type connectors on hand so I'll try one of those first.
  3. O

    NEC Multisync II - Blank white screen?

    Thank you! I'll check that. I think I'll need to buy one of these 9 to 15 pin multisync adapters. https://www.amazon.com/D-Sub-15-Pin-9-Pin-Adapter-Cable/dp/B01JDC9RJU Amazon seems to be the best place to get one, but I'm not sure if they're cheaper elsewhere. EDIT: Duh, nevermind, I misread...
  4. O

    NEC Multisync II - Blank white screen?

    It is probably not the cable then. Does anyone know of any other forums or parts of this forum where I might find a bunch of people that have done repairs on these? I was thinking of asking at an Amiga site since people use old Multisyncs for those too. With my level of knowledge I'm more...
  5. O

    NEC Multisync II - Blank white screen?

    Here is a picture of the monitor running Checkit 3.0. I have tried adjust all of the pots on the left side of the monitor and some would change the intensity\saturation of the colors to an extent, but it's like they're just the *wrong* colors, and the *wrong* intensity. It's almost like...
  6. O

    NEC Multisync II - Blank white screen?

    I tried it this way as well as with the switches set to 16(IBM), grey scale and auto, and all were pretty much the same. I have been switching modes on the EGA card as well since it supports many different modes. So far, nothing has really made a noticeable difference. If I get some time...
  7. O

    NEC Multisync II - Blank white screen?

    mR_Slug, your avatar couldn't have come at a better time... Good news everyone! I fiddled with the adjustment pots that were exposed on the left side of the monitor while it was on and eventually saw a blinking cursor! After playing with more adjustments I can now read text at the command...
  8. O

    NEC Multisync II - Blank white screen?

    Okay, when the monitor is connected to my IBM and the PC is off the monitor will show a white screen with a fairly low refresh rate "flicker". As soon as I switch the PC on the monitor will flash once with a horizontal line briefly, then after a few seconds it seems to lock onto a refresh cycle...
  9. O

    NEC Multisync II - Blank white screen?

    This is a "good" thing right? The other two CGA\EGA monitors I have used (IBM 5153 and a "Sysdyne!") have a similar white screen when turned on with no signal. I just reassembled it (surprisingly easy) so I can try to narrow down what it's doing a bit better.
  10. O

    NEC Multisync II - Blank white screen?

    Ah... wish I'd have thought about that before I disassembled it. I will have to put it back together to do some more testing I think. I don't really have a functional scope (just an old Techtronics that hasn't worked in a few years), and I've never really learned how to use one. I was really...
  11. O

    NEC Multisync II - Blank white screen?

    I'll be honest, I've seen a ton of caps in various devices with epoxy on, under or on top of them, and I've seen boards with lots of excess flux, but I've only seen leaked electrolyte that looked like this...
  12. O

    NEC Multisync II - Blank white screen?

    Okay, I was able to get into this thing pretty easily thanks to this video: It doesn't give a lot of detail as far as disassembly goes, but it's pretty straight forward. You just have to take the whole "module" out the right side (looking at the back of the monitor), so there are a couple of...
  13. O

    NEC Multisync II - Blank white screen?

    Thanks. The DE-9 connector seems pretty solid on this one, but I have read about some people having color issues. The PCB it mounts to seems to be pretty well buried in layers of metal shielding, so I'm not sure if I'll be able to get in to look at the solder joints on the connector without a...
  14. O

    NEC Multisync II - Blank white screen?

    It's a Multisync II Model JC-1402HMA, definitely supports CGA, EGA, VGA, etc. Thanks! I already had the manual. I figured whatever was wrong would be something they wouldn't have anticipated 35 years ago, but I'm checking it out now. To be honest, that section is a bit over my head because I...
  15. O

    NEC Multisync II - Blank white screen?

    I drove a couple hours to pick up this Multisync II a few weeks back... I was so happy to find one locally after a bad experience last year where I received a comparable "multisync" capable Sony display which was sadly damaged in shipping. It was advertised as working and would power on, but...
Top