• Please review our updated Terms and Rules here

5170 Memory Error Quadtel BIOS

VintageUsingVintage

New Member
Joined
May 10, 2020
Messages
5
Location
Ontario, Canada
Hello All,

I have a 5170 which has a QuadTel Bios in it. On boot up, using a CGA card output to the 5153, I get a 1C 4000 message on the screen and nothing else. It looks like this is a memory error
From this user manual https://theretroweb.com/motherboard/manual/ht101a-286-user-manual-6467d04d34439310676945.pdf (page 12) there is a QuadTel error code reference for memory

The memory is double stacked, also looks like someone has tried to troubleshoot in the past as the chips are mismatched. Not sure which way to go for identifying which memory chip is bad.

Thanks in advance for any help!

EDIT : So funny enough, as I looked closely I noticed one of the chips looks like it was not seated correctly, I pulled it there was a bent pin, put it back in and now it's a 1C 8000 error. So progress. I'm going to work though re-seating the chips and see if that does anything.
 

Attachments

  • PXL_20240710_123204427.MP.jpg
    PXL_20240710_123204427.MP.jpg
    267.6 KB · Views: 1
Last edited:
And last update. Since Bank 0 was in a known working state, I swapped the suspect chips one at a time into Bank 0. There were 2 that caused the system to fail the POST memory test. Tried them as well in alternate spots in Bank 0, same result. Looks like I have 2 bad chips then I will need to source. I do have the Lo-Tech 1 meg memory card, so for now I can at least get 640k, even if it's only 8 bit for half of it.

Hopefully this troubleshooting helps someone else.
 
Back
Top