• Please review our updated Terms and Rules here

Apple II plus issue

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
I recently acquired an Apple II plus with a few cards.

When I proceeded to power it up, the display was all ?'s and it kept beeping. The pattern of beeping was the typical start up beep, then several beeps very close together (it almost sounded like a continuous tone), and then it would repeat.

I have tried all of the basic troubleshooting: checking voltages from the PSU, removing the cards, and reseating the chips. The PSU voltages checked out fine, but removing the cards and reseating the chips did not help solve the problem. I also swapped around the banks of RAM chips to see if there may have been a bad RAM chip.

I do believe that there must be some activity going on because the computer does respond when I press reset. When I hold it, no sound comes from the speaker, and when I release it the pattern starts up again, so it seems to respond to the reset. Although there is no change on the screen. Pressing any other keys did not have any noticeable effects.

At one point I did manage to get the system to stop beeping. The ROM in slot ROM-F8 was not inserted all the way, but was making contact with the socket. The screen was still filled with ?'s, but the system only beeped when I pressed the reset button. The keyboard would also not respond. It only did this for a little bit, then the problem manifested itself again.

Searching the internet produced very little information to help me solve this issue. What should my next step in troubleshooting be?
 

amauget

Experienced Member
Joined
Mar 9, 2011
Messages
84
Hello Old Computers,

It can be numerous things : bad IC, corrosion, bad motherboard, ...
Hires pictures of the motherboard (front and back) would help.
 

rittwage

Veteran Member
Joined
Mar 6, 2012
Messages
916
Location
Augusta, Georgia, USA
II and II+ are difficult to troubleshoot without a second working computer and a lot of patience and care. There are over 100 chips on it, and they are generally delicate and the legs can get bent and break off. I would post on AppleFritter- some of the guys there can give you an idea of where to start by the symptoms.
 

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
Thank you for the advice guys. I will try to get some good photos of the board taken and post them here. Also if I can I will try to post a recording of the beeping pattern.

As for a second working machine, I don't have another II plus, but I have some IIe's (enhanced and un-enhanced). I doubt that those machines will be of any use since they are electronically different from the II plus.
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,063
Location
Minnesota
Reseat all the roms and verify they are correct part# and in the correct sockets. ?? is uninitialized video memory and should be cleared by reset routine in rom. Beeps from 6502 executing bogus break instructions and incorrect rom routine handling
 
Last edited:

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
I will verify those tonight. I found a listing of the part numbers for the ROMs. Does the number in the name the ROM chip (i.e. Integer BASIC F8 ) correspond with the label on the motherboard?

EDIT:
We must have posted at the same time. So it's appearing that its more of a Memory issue than a motherboard issue?
 

tezza

Veteran Member
Joined
Oct 1, 2007
Messages
4,720
Location
New Zealand
I've found that sometimes the problem has been with the sockets becoming faulty. Those kind of issues are VERY hard to diagnose.

Tez
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,063
Location
Minnesota
Yes, the rom's could be labeled with part# or description. If it was memory, it would be the first row closest to the keyboard. You could try moving a different row into that one.
 

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
I just double checked the ROMs and according to the chart I found, the chips all appear to be in their correct places. There does not appear to be any heavy oxidation on the ROMs' pins.

Here is the order of the ROMs in my system:
F8: 341-0020
F0: 341-0015-00
E8: 341-0014-00
E0: 341-0013-00
D8: 341-0012-00
D0: 341-0011-00

So if the socket is faulty is there any way to test that without changing the socket? I unfortunately don't have an EPROM burner that I know how to use (I have one, but I can't find any info on how to use it) to dump the contents of the chips.

For the pictures I haven't been able to get a good photo of the board tonight, but I am going to try adjusting the lights to get a better picture. I did manage to get a good recording of the beeping pattern. The pattern right after the initial beep repeats itself.

View attachment AppleIIBeeping.zip
 

HoJoPo

Veteran Member
Joined
Feb 4, 2012
Messages
806
Location
Northern Nevada
Yes, you could test the ROMs without replacing the sockets, if you have an Apple II ROM card in slot 0. I don't think it would be worth buying one to troubleshoot with, though....

Or, an Apple II language card in slot 0 would have an autostart ROM on it as well, which may allow you to get into the monitor, at least. Not all 16k clone cards have the ROM (in fact, very few do), but the genuine Apple card would have it.
 

tezza

Veteran Member
Joined
Oct 1, 2007
Messages
4,720
Location
New Zealand
So if the socket is faulty is there any way to test that without changing the socket?

There is no easy way I know of. I've done this by finding a track that originates from a particular pin in a suspect socket, and checking if there is complete connectivity (no resistance at all) between that and the top of the leg of its corresponding IC. It's not foolproof though because even a bit of pressure from the multimeter probe on the top of the IC leg can sometimes complete the faulty circuit and everything looks ok...even though it's not.

Tez
 

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
Thanks for the tips guys.

Unfortunately I do not have a language card or a ROM card. This will be a good opportunity for learning my EPROM burner. If the ROMs check out as good then it might be safe to conclude that the socket is bad. Checking the socket sounds like it might be tedious, but if I need to I will definitely do that.

I have now tried swapping each row of RAM into the row nearest the keyboard and none of them have caused the computer to work. This is probably nothing, but I thought it might merit mentioning: I noticed when I touched the bottom of the circuit board near the joystick connector the pitch of the beeping changed. I don't know if that is of any relevance to determining if something is wrong with the ROM or if something else is up with the computer. I did not get a recording of that, but just imagine the pitch of the recording I posted earlier being a little bit higher pitched.
 

KC9UDX

Space Commander
Joined
Jan 27, 2014
Messages
7,468
Location
Lutenblag
Reseat all the roms and verify they are correct part# and in the correct sockets. ?? is uninitialized video memory and should be cleared by reset routine in rom. Beeps from 6502 executing bogus break instructions and incorrect rom routine handling

That kindof beeping can also be a stuck key. But it probably is mangled code.

The whole thing could be bad RAM
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,063
Location
Minnesota
There are still several possibilities. Try unplugging the keyboard ribbon to eliminate keyboard. What tools do you have - meter, logic probe, scope? Assuming you have a meter, check the 6502 pins 2,4,6,40 for 5V to be sure no interrupt or reset is being continually generated. I think we know the reset is good, though. I assume your slots are empty. Look in the slots to be sure no damage to contacts which would short them together or crud.
 

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
The keyboard has been removed for most of my testing, and it still does the beeping. Removing the expansion cards was the first thing that I did when I noticed that there was an issue with the system.

For troubleshooting tools, I have a multimeter and a scope. I have a frequency counter, but I have yet to get it to work.

I will measure the voltages on those pins and report back after I check them.
 

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
I just checked pins 2,4, 6, and 40. They all read about 5.8-6V. I used the metal base of the computer for the ground, and I also used the ground part of the video connector and the voltages all read the same using both. Is having that high of a voltage something to be concerned of? I also looked at the expansion slots and there appears to be nothing that could be shorting a contact.

Here are the pictures that I took of the board:
back.jpgfront.jpg
 
Last edited:

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,063
Location
Minnesota
That's definitely too high but it could be your meter. Might want to confirm by measuring 5V on your IIe. Did you swap power supplies with your IIe? They are cross compatible. I doubt that's it but good to eliminate the possibility.
How do the other supply voltages measure?
 

Old Computers

Veteran Member
Joined
Aug 30, 2012
Messages
510
Location
USA
The voltages that the II+'s power supply puts out under load are:

+5.17
+12.64
-12.02
-5.21

I did swap power supplies and the problem was still there, but I did measure the voltages, and I was getting closer to the nominal values. I forgot to write down the specific values but this is what I remember:

+4.98
+11.88
-11.87
-5.02

I didn't measure the voltages without a load since its a switching PSU.
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,063
Location
Minnesota
Those voltages look good. I am at a loss where to look next. The beep is a subroutine executed by the processor so it is able to read the reset address from the F8 rom and execute instructions to generate the beep so the address and data lines are active but it never executes the subroutine to write a character to the screen so it must encounter maybe a break instruction but the break handler is messed up and doesn't go to the input prompt. Maybe since it's an autostart rom the soft byte never gets initialized so it constantly reboots to reset. On the other hand, a subroutine requires stack memory so if RAM is unable to be read, it could get stuck in a continuous loop. For lack of a 2nd motherboard for parts, one thing you can do is swap identical IC's to see if your symptom changes. Since you have a scope you could walk around comparing waveforms to the Sams ComputerFact CC1. Page 5 shows the timing generator consisting of IC's B1 and C2 which generate most the clock signals. Maybe start with those.
 
Top