• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.

Computers turns on / starts booting when monitor gets turned off or on

djyuran

Member
Joined
Dec 27, 2017
Messages
41
Location
Seattle, USA
Hi!

I got really weird issue with my 386SX.

For instance sometimes:
1) System box doesn't turn on until I turn on monitor and sometimes doesn't boot after it (nothing is displayed on monitor)
2) Systems stops booting when I turn on monitor and nothing is displayed
3) When I turn off monitor system restarts and starts booting
4) it starts well after some time when issues 1-3 happened without any changes from my end

I have this power supply: https://www.ebay.com/itm/Ilantec-Il...h=item468b4a5c9e:g:YHQAAOSwKBRawmcn:rk:2:pf:0

I use PS/1 2011 monitor which can power PS/1 system box but I connect it to my 386SX system box just by VGA cable.
I tried different power outlet in the same room but behavior is the same.

Does it mean I have a problem with system box power supply or I need to change monitor? I haven't got any problems for several months I own it.
Can someone explain why turning on/off monitor affects system box? I'm really curious what is happening...
 

GiGaBiTe

Veteran Member
Joined
Apr 30, 2015
Messages
2,735
Location
Austin, Texas
According to Wikipedia, that monitor has an internal PSU to power the computer from the monitor cable itself?

I would stop using that monitor immediately and try a different non-proprietary monitor, if you're feeding voltage to somewhere it shouldn't, bad things happen.
 

djyuran

Member
Joined
Dec 27, 2017
Messages
41
Location
Seattle, USA
According to Wikipedia, that monitor has an internal PSU to power the computer from the monitor cable itself?

I would stop using that monitor immediately and try a different non-proprietary monitor, if you're feeding voltage to somewhere it shouldn't, bad things happen.
Yes, this monitor can power my other PS/1 80286 system box but I don't try to power my 80386SX system using this monitor. They are connected just by VGA cable.
Actually it's impossible to power something else except PS/1 system box because of proprietary connection.

Anyway even if I don't connect monitor to 80386SX box (even with VGA cable) 80386SX box still behaves that way and reacts when monitor turns on/off in the way I explained above.
 
Last edited:

KC9UDX

Space Commander
Joined
Jan 27, 2014
Messages
7,468
Location
Lutenblag
Sounds like a fire hazard. If you don't think you can find it, it might be best to hire an electrician.

Are the computer and monitor plugged into a common power strip? Or anything else between the computer and outlet receptacle? Does this happen if you use a different receptacle?
 

djyuran

Member
Joined
Dec 27, 2017
Messages
41
Location
Seattle, USA
Are the computer and monitor plugged into a common power strip? Or anything else between the computer and outlet receptacle? Does this happen if you use a different receptacle?
Behavior doesn't change if I use don't use power strip or plug them into outlets located on different walls.
Do you have any thought what's going on? Is it an issue with monitor power supply, system box power supply, power outlet, power cables, wires in my house, etc?
 
Last edited:

krebizfan

Veteran Member
Joined
May 23, 2009
Messages
5,382
Location
Connecticut
Behavior doesn't change if I use don't use power strip or plug them into outlets located on different walls.
Do you have any thought what's going on? Is it an issue with monitor power supply, system box power supply, power outlet, power cables, wires in my house, etc?

Could be too much power draw so that you can't have both monitor and system case draw peak power at the same time without the voltage falling below a critical level. What is the capacity of that circuit? Many rooms will have most of the outlets on the same circuit and possibly some other rooms as well.

If your circuit breakers are very old, you may want to consider having them checked. I had an intermittent power gremlin that was eventually tracked down to a short in the water heater but the circuit breaker for the water heater would not trip. Bit unnerving when all the flaws were identified.
 

KC9UDX

Space Commander
Joined
Jan 27, 2014
Messages
7,468
Location
Lutenblag
In maybe the worst case scenario, it could be a loose wire in a wire nut or on a screw terminal somewhere. This is a recipe for fire.

I'm not sure what else to guess without seeing it myself.
 

djyuran

Member
Joined
Dec 27, 2017
Messages
41
Location
Seattle, USA
I found root cause!
PSU switch was set to 230V instead of 115V. I was never aware about that switch.

It's weird it mostly works even on 230V setting.
If someone can explain from electrical stand point why I would be more than happy!
 

Dwight Elvey

Veteran Member
Joined
Jun 21, 2003
Messages
4,753
Location
Santa Cruz
You're lucky the supply set at 230V didn't fail, many older supplies didn't have brown-out protection. With the switcher running full out on the reduced input voltage, it just wasn't able to bring the voltage to a working level until assisted by the monitor.
Dwight
 

Dwight Elvey

Veteran Member
Joined
Jun 21, 2003
Messages
4,753
Location
Santa Cruz
I thought I'd add some here. Many switcher supplies work in what is called the flyback mode. This is similar to the coil in your car that fires the spark plug. When the points close, a small voltage is induced on the secondary ( about 300V as I recall ). As the coil remains closed for some time, the current will increase in the primary inducing a magnetic field. The field will increase until the core saturates. At which time the magnetic field will leave the core and fly off into the air. This significantly decreases the inductance of the coil and without some form of current limit will be a short. In the car, the coil has a significant primary resistance, limiting the current. When the points open, the magnetic field collapses. The attempts to induce a current in both the primary and the secondary. Since the secondary has more turns, its voltage is larger and would increase until something gives out, hopefully the spark plug fires. This loads the coil down and maintains the voltage at a constant level until there is not enough current to maintain the spark. ( I hate to see mechanics removing a spark plug wire without a place to dump the spark. In points cars, it often damages the points and or the capacitor on the points ).
So, how this relates to your PC supply. With the flyback, the input switching transistor supplies a current for some time to the coil. How long it does this is related to how much current is needed for the secondary load. There is a voltage feedback from the +5v out to control the duty cycle of the transistor on the primary. If the load goes up, the transistor stays on longer. Since it works off the flyback ( when the transistor turns off ), one can imagine the demand for more voltage having the transistor on for more and more of the cycle. When this on time reaches the point that the flyback time is to short to deliver the needed current, the transistor would be turned on even longer. This would cause a runaway condition if there wasn't something to prevent it. In the case of the 230V switch, the voltage to the transistor is only about 1/2 that needed to supply the needed current to the primary of the coil. Without brownout protection, the case of the turned on transistor could excess that point of no return and quickly blow the transistor and possibly damage the primary coil.
I hope this make some sense.
Dwight
 

onre

Member
Joined
Nov 6, 2018
Messages
30
Location
Finland
Ditto, appreciate the explanation. It cleared some things that I haven't understood before.
 
Top