• Please review our updated Terms and Rules here

Debug flags in Simh

AK6DN

Veteran Member
Joined
Aug 23, 2010
Messages
1,013
Location
Silicon Valley USA
Try:

SET DLI ENABLE
SET DLO ENABLE

SET DLI DEBUG
SET DLO DEBUG


works for secondary DL11 interfaces at 776500++
 

Activmaker

Experienced Member
Joined
Apr 3, 2018
Messages
66
Location
Paris, France
Thanks but Unfortunately it doesn't work .
I can see DLI and DLO are enabled using SHOW DEVICES but DLI DEBUG returns "Command not allowed"
Any other idea ?
 

AK6DN

Veteran Member
Joined
Aug 23, 2010
Messages
1,013
Location
Silicon Valley USA
Thanks but Unfortunately it doesn't work .
I can see DLI and DLO are enabled using SHOW DEVICES but DLI DEBUG returns "Command not allowed"
Any other idea ?

So...

Code:
[B]~[501] pdp11

PDP-11 simulator V4.0-0 Current        git commit id: de6db584

sim> set dli en
sim> set dlo en
sim> set dli lines=1
sim> sho dli debug
Debugging disabled
sim> set dli debug
sim> sho dli
DLI     address=17776500-17776507, vector=300-304*, BR4, lines=1
sim> sho dli debug
Debug=REG;INT;XMT;RCV;RET;MDM;CON;ASY;TRC;EXP;SEND;XMTPKT;RCVPKT
sim>[/B]

Don't know of any valid command DLI DEBUG
 

Activmaker

Experienced Member
Joined
Apr 3, 2018
Messages
66
Location
Paris, France
Hi,
Sorry I made a typo in my last post. I used SET DLI DEBUG , and not DLI DEBUG as I wrote. But your post gave me the answer. I was using Simh 3.9 not 4.0.
With 4.0 , SET DLI DEBUG is working.
But now, as debug works with secondary DL11 , how can I see the DL11 sequences when RT11 is booting ? Should I "connect" with a second computer by serial port to the Simh Host ? ..Or maybe there is a easier solution. Maybe it is not possible.. :confused:
 

AK6DN

Veteran Member
Joined
Aug 23, 2010
Messages
1,013
Location
Silicon Valley USA
Hi,
Sorry I made a typo in my last post. I used SET DLI DEBUG , and not DLI DEBUG as I wrote. But your post gave me the answer. I was using Simh 3.9 not 4.0.
With 4.0 , SET DLI DEBUG is working.
But now, as debug works with secondary DL11 , how can I see the DL11 sequences when RT11 is booting ? Should I "connect" with a second computer by serial port to the Simh Host ? ..Or maybe there is a easier solution. Maybe it is not possible.. :confused:

Yikes. v3.9 is REALLY old now.

From reading the pdp11_stddev.c code, and trying it in simh, SET TTI DEBUG and SHOW TTI DEBUG works.

Unfortunately (do to a coding oversight, I suspect) the equivalent for SET TTO DEBUG and SHOW TTO DEBUG are not implemented, and thus does not work.

So really if you absolutely need debug status on TTO console output, you need to submit a bug report on SIMH that debug mode for PDP11 console terminal output is not implemented.

Or, implement it in pdp11_stddev.c yourself and submit it as an update to the sources. Assuming you are interested/capable of using github to do this.
 

Activmaker

Experienced Member
Joined
Apr 3, 2018
Messages
66
Location
Paris, France
Hi,

Thanks for your comments . I started using SET TTI DEBUG , but looks like that memory is corrupted before RT11 start trying to communicate with DL11 (I am talking here of my system not Simh, I use Simh with debug to compare activities of my system and Simh) . I need first to debug and found the reason of corruption (RT11 use EMT during boot , and I found that the vector 30 used for EMT is lost during the boot ).

So maybe, one day I will need to modif simh to get TTO DEBUG working, but for now , it is a little bit early.
 
Top