• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Facit 4420 problems

SunDown79

Veteran Member
Joined
Sep 8, 2005
Messages
756
Location
Netherlands
I have just dug up a Facit 4420 and it seems to be in ok condition and it does power up but the screen shows a bit of garbage.
Its basically a black square in the left top corner surrounded by inverted "C"'s.

Its a long shot but anyone any idea's ? I have pressed down on all IC's that were socketed and there are some internal jumpers that do seem to do something which gives a different garbeled image but as I dont know what they do its a bit of a shot in the dark.

Thanks!

Stefan.
 

tingo

Veteran Member
Joined
Aug 12, 2009
Messages
1,471
Location
Oslo, Norway
And this isn't the cursor by any chance? (I've never seen a Facit 4420 "live", so I don't know how it is supposed to behave).
 

SunDown79

Veteran Member
Joined
Sep 8, 2005
Messages
756
Location
Netherlands
Hehe, yeah my description could have been couldn't it ;)
But no. I have taken a picture of the screen, works better :
 

Attachments

  • IMG_2432.jpg
    IMG_2432.jpg
    93.8 KB · Views: 1

tingo

Veteran Member
Joined
Aug 12, 2009
Messages
1,471
Location
Oslo, Norway
Hmm, that looks bad. Sorry I can't help - don't know what it could be.
BTW, perhaps you could add some pictures of your terminal to the Terminals wiki: Facit 4420.
 

SunDown79

Veteran Member
Joined
Sep 8, 2005
Messages
756
Location
Netherlands
Ah yes saw that entry, not sure if the text is correct though on the Terminals wiki as mine is a pure Facit 4420, nothing about Norsk Data on it.
 

tingo

Veteran Member
Joined
Aug 12, 2009
Messages
1,471
Location
Oslo, Norway
Feel free to correct it (it was written by me), I wrote it based on a small amount of information available related to ND.
 
Top