• Please review our updated Terms and Rules here

LS120 ATAPI drive with Win98SE

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
43,939
Location
Pacific Northwest, USA
This one has me baffled.

Here's what I've got. An HP Vectra VL6 series 8 minitower with a 1.4GHz Celeron in a Powerleap slocket. Works great. 768 MB memory, Intel 440BX chipset. On the primary IDE, I've got a 40GB hard drive, partitioned between a FAT32 Win98SE (4GB) and a Debian "Woody" Linux (I need the old Linux distro for some tape support), basic LILO boot manager. On the secondary side, I've got a Sony DVD-ROM drive as master and a Matsushita/Imation LS120 ATAPI "Superdrive" as slave. In DOS and Linux modes, everything works a treat.

However, when I start Win98SE, it displays the logo screen and then dies with an IOS error, citing a "Windows Protection Error". Nothing in IOS.LOG. If I disconnect the LS120, Windows loads normally. If I move the LS120 to the primary IDE side, IOS dies. If I disconnect the DVD and set the LS120 to secondary master, IOS dies. If I substitute another floptical drive (a Caleb UHD144) for the LS120, IOS dies.

If I install real-mode DOS drivers for the LS120, IOS dies and indicates that an INT 25H call returned a status of 0000BABE (that's gotta mean something, but I'll be jiggered if I know what it is).

Disabling 32-bit disk access in SYSTEM.INI has no effect.

All Win98SE service packs, including the "unofficial SP3" have been installed. Doesn't make a difference.

Any suggestions? Someone must know how to get this thing working!
 
Last edited:

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
43,939
Location
Pacific Northwest, USA
After a bunch of searching, I found drivers here that solved the problem.

Microsoft claimed that no special drivers were necessary for Windows 98+, but that's a lie. Use the sd_9xe.exe file for drivers and 98SE stands up and salutes. Also includes a formatting program. The dose.exe file works great for real-mode DOS access. Note that there are also files there for the LS240 as well as for NT.

Thank you Wayback machine!
 

Krille

Veteran Member
Joined
Aug 14, 2010
Messages
1,093
Location
Sweden
If I install real-mode DOS drivers for the LS120, IOS dies and indicates that an INT 25H call returned a status of 0000BABE (that's gotta mean something, but I'll be jiggered if I know what it is).

BABEh is a return code from Smartdrive so I'm guessing you're using that?

Also, (from RBIL);
Code:
INT 25 - DOS 3.31+ - ABSOLUTE DISK READ (32M-2047M hard-disk partition)
	CX = FFFFh
	AL = drive number (0=A, 1=B, etc)
	DS:BX -> disk read packet (see #02548)
Return: CF clear if successful
	CF set on error
	    AH = status (see #02547)
	    AL = error code (same as passed to INT 24 in DI)
	    AX = 0207h for FAT32 drive -- use INT 21/AX=7305h
	may destroy all other registers except segment registers; [B]Win9X always
	  sets SI to 0000h due to an apparent coding bug[/B]
Notes:	partition is potentially >32M (and requires this form of the call) if
	  bit 1 of the device attribute word in the device driver is set
	original flags are left on stack, and must be removed by caller
	this call bypasses the DOS filesystem
	for FAT32 drives (which may be up to 2TB in size), use INT 21/AX=7305h
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
43,939
Location
Pacific Northwest, USA
No, I'm not using SMARTDRV, which makes things very strange. This was a setup to an empty hard drive partition, so nothing but empty CONFIG.SYS and AUTOEXEC.BAT files.

As I mentioned, real-mode DOS operation is quite normal. It's only when Windows is started that IOS has big problems and dies with a Windows protection error. I was hoping that if Windows PM couldn't support it in 32-bit mode that the real-mode driver could be supported through RMM. But things never get that far.

Fortunately, the updated Win9x drivers that I linked to work just fine. As a bonus, they even appear to work properly when a Caleb UHD144 drive is used instead of an LS120. (However, the DOS mode LS120 drivers reject the Caleb drive, probably because they check for the drive identity. But there's Caleb software for that). The software that works also makes an IOS.INI entry, but I haven't dug into that one yet.

The most depressing thing, however, is that other than archive.org, any other instances of the driver are now tucked behind the driverguide.com "installers", which are typically full of malware.
 

bjt

Experienced Member
Joined
Jun 18, 2013
Messages
152
Location
UK
This is interesting. I have 2x LS-120 drives running under Win98SE (Unofficial SP3) using the drivers included with Windows. One is a Mitsubishi, the other a faster/quieter Matsushita. The machines are a K6-III 400 on Intel TX and an Athlon 1200 on KT266, and the LS-120 drivers are secondary slave on both.

I can only think this is somehow related to chipset or perhaps to transfer mode? The Mitsubishi LS-120 I have doesn't like DMA transfers being enabled.
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
43,939
Location
Pacific Northwest, USA
Intel 440BX chipset; HP Vectra VL/6 series 8. But I've had a similar thing happen with Win 2K on an Athlon NForce 3 board, so it really must be a matter of chipset.

At any rate, the thing works now.
 

Ksarul

Experienced Member
Joined
Apr 30, 2007
Messages
451
Avast tags the Win98 file as malware, but has no issues with the others. . .
 

cthulhu

Experienced Member
Joined
May 2, 2012
Messages
209
Sounds like you've solved your problem but be aware that Windows 98 can behave strangely with more than 512 MB of RAM. Any reason you aren't running 2000 or XP instead?
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
43,939
Location
Pacific Northwest, USA
Yup, direct I/O port access. Very useful for low-level programs. You can start in or drop to real DOS without shutting down; do your stuff and then return to the GUI.

If you want to write your own PM code utilizing DMA and interrupts, VXDs are simple compared to XP kernel mode drivers.
 

Shadow Lord

Veteran Member
Joined
Jun 16, 2010
Messages
3,217
Location
California
The most depressing thing, however, is that other than archive.org, any other instances of the driver are now tucked behind the driverguide.com "installers", which are typically full of malware.

Yeah Matsushita/Panasonic had them hosted off of their japan (.jp) site until a few years ago and then they did away with them. Thank goodness for the wayback machine!
 

Shadow Lord

Veteran Member
Joined
Jun 16, 2010
Messages
3,217
Location
California
Chuck,

By any chance were you able to get the Mac and/or OS X drivers? The wayback machine errors out for me on those.

EDIT: Never mind - got them off Panasonic's Japan siteb. They also have the other drivers up but apparently in Japanese.
 

Shadow Lord

Veteran Member
Joined
Jun 16, 2010
Messages
3,217
Location
California
If it's a simple device driver, who cares what language it's in? :)

Probably not much for the driver but for the FD32program (if you want to play around with it) then it might be helpful ;). I always liked the appeal of 32MB on a 1.44MB disk. Useless now a days but appealing ;). Of course I would have also loved for the HiFD format to take off. Full compatibility w/ all 3.5" disks plus 150MB on one disk... Too bad it was too little too late.
 

MateKrisz

New Member
Joined
Feb 11, 2024
Messages
2
@Chuck(G)
I saw your old post from 2015 and I have similar issue with my LS120 in 2024. You wrote earlier that you found a modified driver for Mitsubishi LS-120 drive. Where can I download it? I not found the correct one :( Drive model number: MF357G-2111MAL. My motherboard is Intel AN430TX with Pentium P55C 233MHz. Thank you!
 

MateKrisz

New Member
Joined
Feb 11, 2024
Messages
2
Thank you! I tried it, but same issue, black screen. I try to find out, what is the difference, why not working.
What is the bios settings what working well? Auto or manual? HSFLOP.PDR version? Mine is 4.10.2224
 
Top