• Please review our updated Terms and Rules here

MS-DOS tracker sound blaster FM (rather than samples)

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
I'm looking for a tracker for MS-DOS that will sequence sound blaster FM rather than just samples.
 

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
I'm trying adlib tracker II but the sound is broken for some reason. I'm using a Sound Blaster Pro 2.
 

Trixter

Veteran Member
Joined
Aug 31, 2006
Messages
7,413
Location
Chicagoland, Illinois, USA
You need to be more specific. Does other FM/Adlib software work correctly, such as games? Is your Sound Blaster Pro 2 the first revision, or the second revision? (look at the board to determine this). The first revision used two OPL2 chips, the second revision used a single OPL3 chip. If you're trying to play OPL3 on a dual-OPL2 board, that won't work of course.
 

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
The sound and music works in almost every game but a few have issues. It says CT1600. And has a YMF262 on the board. It should work. Could my CPU be too fast at 200mhz? I loaded a 4op instrument editor and it works fine. Sound works perfectly. Something is f-d up with adlib tracker 2.
 
Last edited:

Trixter

Veteran Member
Joined
Aug 31, 2006
Messages
7,413
Location
Chicagoland, Illinois, USA
Card is fine, CPU is fine, but a lot of people have reported Adlib Tracker II also works fine, so maybe your environment is suspect. Are you running DOS, or Windows? Have you tried booting with and without an expanded memory manager (ie. EMM386, QEMM, 386MAX).

You said your card works in "almost every game but a few have issues." Care to elaborate?
 

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
In one game the setup program freezes up my machine so I can't have sound fx but the music works.
 

Trixter

Veteran Member
Joined
Aug 31, 2006
Messages
7,413
Location
Chicagoland, Illinois, USA
That's not related to the FM support though. It just means the game setup program sucks, or you have your IRQ/port/DMA set to non-typical settings. For most applications, you should be using IRQ 5, DMA 1, port 220h. If you can't use IRQ 5 due to a hard drive controller, use IRQ 7 (it's unlikely you'll need to print at the same time you're playing a game).

What happens when you try to run Adlib Tracker II?
 

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
The software runs but all the instrument sounds are messed up. I'm using IRQ7 DMA 1 port 220h. I can try using IRQ 5.
 

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
The problem is that I don't use facebook. Also just tried Irq 5 and it made no difference.
 
Last edited:

TravisHuckins

Experienced Member
Joined
Apr 5, 2017
Messages
322
Location
USA
I got it! If anyone else has this issue you must go into the ini file and set the opl3 latency from 0 to 1. That fixed it!
 
Top