• Please review our updated Terms and Rules here

Ohio Scientific Challenger 4P C4PMF garbage screen

Dokken

Experienced Member
Joined
Feb 27, 2018
Messages
253
Location
TN
I saw a machine I didn't recognize in a local estate sale listing so I picked it up for $80. It's a OSI Challenger 4P with floppy drive unit. the mainboard is revision 505.

I opened it, disconnected power from system board, and verified both outputs are at 5v. I reseated the socketed chips on the top/main board (haven't dug any deeper to the lower boards).

I powered on the CPU unit only and get the attached garbage character screen.

I do have a copy of the SAM's service manual which looks pretty helpful. it mentions turning on caps lock, hitting break key. still garbage screen.

I haven't done any other troubleshooting. does anyone have any experience with this computer and with a similar issue? does the floppy drive also need to be powered? any advice is appreciated.
 

Attachments

  • Screen Shot 2022-07-04 at 1.35.57 PM.png
    Screen Shot 2022-07-04 at 1.35.57 PM.png
    1,008.4 KB · Views: 20
  • Screen Shot 2022-07-04 at 1.36.25 PM.png
    Screen Shot 2022-07-04 at 1.36.25 PM.png
    1 MB · Views: 21
Knowing nothing about the OSI computers, the screen garbage looks like uninitalized RAM. given the vintage, I'd guess that the CPU is responsible for clearing the video RAM when starting up. There appear to be some OSI systems that have multiple CPUs, with software switching abilities. It would seem likely that something is preventing the CPU(s) from running the startup code. That could include the ROM being fried or faded, no clock to the CPU(s), or just bad silicon somewhere affecting the startup. You also might check that the power supply is able to maintain 5V when under load, possibly meaning a failed power supply or things like bad (shorted) tantalum caps on the main board.
 
Make sure you hit RESET, OSIs usually don't automatically do a reset on powerup!

Welcome to the world of OSI! They're interesting machines, and there's a lot of hobbyist interest in them. Check out osiweb.org for more documentation/information. There's also an OSI-specific forum over there, though the VCFed forum is also a great place for OSI.
 
There appear to be some OSI systems that have multiple CPUs
That was the Challenger 3P. I actually got to use one back in the day in 1982. But they only used it for multi-user 6502 BASIC, with a hard drive, and a 48K board for each of two users. I guess that was OS-65, and the BASIC only did data storage on disk by reading and writing numbers as ASCII text.

The real problem with the 3P was that you could only use one of the CPUs at a a time, and the others were just dead weight. As far as I know, I don't even think it could use one as an I/O processor.I would love to see the schematic to that 510 CPU board to see how they did it. Only a hobbyist could love choosing which CPU to run today. A business would have a workflow that depended on apps. And I guess if you had a hard drive, there wasn't really any cross-CPU filesystem to use with it.
 
The schematic is available, and people did use the Z80 to run CP/M! Seems that the 6800 didn't see a lot of use.

The 560Z board does give you true "multiple processors executing code at the same time" multiprocessing. With that board, you can use the 6502 (or whatever CPU is selected, on the 510 board) as an I/O coprocessor. The default options on the 560Z were IM6100 (PDP-8 on a chip) and Z80. We've done reproductions of both the 510 triple CPU board and the 560Z "Processor Lab," so it's possible to build up a system with both using all new-made boards.
 
One other bonus I got with the system is a box of about 25+ floppies. They all look like OSI disks in OSI sleeves with commercial labels. No hand-labeled user data disks I see. lots of games, demos, dealer disks, etc. well organized and indexed.

I opened up the Challenger on my bench and am going through the process of trying to ID the chip layout. I have determined that the garbage screen is identical every boot (same characters, same place). the reset key is physically working and does seem to reset the 6502 (using a probe) but the screen only changes slightly every 5th or 6th press of reset but immediately goes back to the same.
 
That's great that the lot includes original diskettes! Don't put any in that drive until you're 100% sure the machine is functional: the OSI floppy controller is a very early design that does not use a LSI floppy controller chip, and it's easy to have some problem with the controller frag diskettes as soon as you close the door -- whether you're doing drive access or not! I'd see if someone can write you out some copies to test with. I'd offer but I don't have any 5.25" OSI setups going at the moment, only 8".

If you have the original supplies, you almost certainly want to recap or replace. They're a known weak point in these systems.

There's a pretty good chance you have bad RAM, the 505 requires offboard RAM so you should have a RAM board in there, in addition to the video board and CPU board.
 
I pulled the 3 big boards out to get a closer look.

I have a backbit.io chip tester (fantastic device that has gotten plenty of use) and the 6502 tested as bad/failed. that chip tester has been spot on with everything I've used it for, so hopefully it's as simple as a new cpu. the 2114 ram chips are all testing fine, but I'm only about a quarter way through that monster conglomeration of memory.

6502s ordered and they'll be here this week (ordered a few yesterday for spares/projects and in light of the possibility with this machine) .

and I haven't even turned on the disk unit. I disconnected it while I work on the thing.
 
Makes sense, it really looks like it's doing nothing. Dead 6502s certainly aren't unheard of, and with the stock power supplies, a C4P runs hot, which I think makes life a lot harder on especially the RAM.

I designed a new universal RAM board, available as a bare board, kit, or assembled+tested if you end up having RAM troubles. It draws a lot less power, too -- that 2114 monster I believe wants 3A @ 5V depending on the specific 2114s used!
 
thanks!

I installed a 6502 from another computer and I now get a prompt H/D/M? with the bottom half of the screen showing dots (......). keyboard does nothing.

I tested the 2114s on the top (video?) board and two show bad in my tester. might be the reason for the half screen.
 
A couple dead 2114s would make sense, they are a common failure in many things that use them, including OSIs.

H/D/M? is the typical boot prompt for disk systems with no ROM BASIC. You press (with caps) D for disk boot, H for hard disk boot (yes, this is a thing!), and M or anything else will drop you into the rather limited ROM monitor. The ROM monitor is basically a paper tape loader you can try and interact with, but it does at least let you see the machine is working. The monitor will eat characters unless you give it something it likes. You'll have to figure out which version you have. See if you can type `P 0000` without the backticks, everything must be in caps. It should start dumping memory and it'll echo the P.
 
A year has passed, but the OSI C4P MF seems to be fully functional with Gotek/5.25 via floppy separator. Many thanks to glitch and the people on the OSI forum.
 

Attachments

  • osi final Screenshot 2023-09-12 at 3.50.04 PM.png
    osi final Screenshot 2023-09-12 at 3.50.04 PM.png
    3.1 MB · Views: 12
Can you provide more info on the data separator?
I’d like to use a Gotek with my C4PMF.
 
Hi, contact Grant at https://klyball.com/ and see if he has any boards left. I believe it is the D13 data separator.

My issue in the build was finding current info on the latest version, but I think I have all the files saved. the info on here is hard to follow due to different versions. Worst case I can post an image of my final working build with parts placement and jumpers.
 
Ok, got the data separator (YAY!); built & installed it… and after some troubleshooting works find with a 5.25" floppy drive (strapped for 300 RPM). Disconnect (real) floppy; connect Gotek… and… can't find track zero?
Humm… I tried several of the C4P images from osiweb.org… but none of them are booting from the real floppy.
Mark Spankus OSI Floppy Disk Test passes (ran infinite passes for over an hour).
But I notice "Dump Raw Image" doesn't match the file(s) I wrote.
Can you link to the .hfe and .cfg files you used for Gotek?
 
Ok, got the data separator (YAY!); built & installed it… and after some troubleshooting works find with a 5.25" floppy drive (strapped for 300 RPM). Disconnect (real) floppy; connect Gotek… and… can't find track zero?
Humm… I tried several of the C4P images from osiweb.org… but none of them are booting from the real floppy.
Mark Spankus OSI Floppy Disk Test passes (ran infinite passes for over an hour).
But I notice "Dump Raw Image" doesn't match the file(s) I wrote.
Can you link to the .hfe and .cfg files you used for Gotek?
I have these two handy and I know they work with my setup. see if either will work.

there's a program called bootthis.exe that you can drag/drop an image onto and it should make it bootable by the osi. that's how these were made.

let me know and I can dig through my files/notes for more. I got to the point where I could download osi image files, use bootthis, and reliably load from Gotek.
 

Attachments

  • Archive.zip
    117.4 KB · Views: 1
Are you using these with a Gotek? If so can you provide the .CFG files you use?
 
I don't think it's real picky on the cfg. this is what I have. I booted my C4PMF from the Gotek yesterday using about 5 image files I created with the bootthis.exe utility and it is still working!

when I was originally working on the D13 floppy board and trying to set the timing, I would originally see the tracks increased but only to a certain point. Mark on the OSI forum pointed me to the bootthis utility and it worked. something about the ROM needing to load additional info to get past a certain track, hence the bootthis utility.

let me know.
 

Attachments

  • ff.cfg copy.txt
    10.3 KB · Views: 3
SUCCESS! Finally got the real 5.25" floppy booting… turns out that on the KLyball D-13 the /DRIVE READY 1 & /DRIVE READY 2 lines have to be grounded for 5.25" drives…
The photo from the What jumpers worked for me thread showed 11 & 12 shorted… I'm guessing for 8" drives. For 5.25" drives 12 & 13 should be shorted.
It's annoying that floppytest_v1.04u and the OSI Disk Tool never said anything about the drive not being ready… looking thru the sources they never checked those signals from the drive.
Then the disks I made with the OSI Disk Tool didn't report the drive(s) not ready… it just hung without any errors. Gerrrrrr…
Anyway it's working now… so onto the Gotek!!!
 
Update: Got the Gotek working. Turns out it was strapped for DS1… which is usually the case when used with "twisted" (PC) drive cables.
The C4PMF uses non-"twisted" (strait thru) cables so I had to change the drive jumpers for DS0.
Now everything works as expected…
Well, almost… the OSIHFE tool doesn't produce images that I can just copy to the USB memory stick.
Using the OSI Disk Tools to serial transfer (XMODEM) a .65d file and write it to disk works.
When I compare the '*.HFE' files created by the serial transfer with the one produced with the OSIHFE tool they're different.
 
Back
Top