• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.

Questions about Restoring Pair of Old Kaypro II's

Mark_E

New Member
Joined
May 24, 2012
Messages
7
Location
Tempe, Arizona
Greeting All,

I'm new to the forums, and one of the reasons I came here was that I'm in the process of trying to restore a couple of vintage Kaypro II machines, and I knew that the collective brainpower and experience represented here would be a big help with some of the tougher questions and problems I've had with this project. My first question: It appears that, on the mainboard (motherboard) itself, most of the brown, disk-type caps are leaking. (I should say "were leaking". It's been so long now, that they're just dried up & petrified, leaving permanent stains on the board where they were leaking at one time.) This doesn't seem to be affecting the performance of the machines, they both boot up and run CP/M. It's just that I was wondering if I should probably change them out. I know that it's customary when repairing old radios to re-cap them, and I'm pretty handy with a soldering iron. Is this something I should probably do? Is there anything else on the motherboard I might want to consider replacing as part of the restoration of these machines? Thanks very much, Mark E.
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
39,111
Location
Pacific Northwest, USA
If the capacitors that you're talking about look like this:
709032.JPG


They're probably just fine. Depending on the manufacturer, ceramic disc capacitors can have blobs on them (the outer clay coating is usually applied by dipping, hence the appearance). There is nothing inside that can leak--under the brown coating is a disc of white ceramic with a thin layer of silver deposited on each side and leads attached.

In my entire lifetime, I've probably seen fewer than a dozen bad ones--and mostly those have been cracked or otherwise physically damaged. I suspect that the working life of one of these is in excess of a century.

Sometimes, you'll see a notch cut in one, as if a saw has been used. That's exactly what has been done--the idea is to calibrate the value of the capacitor very closely.

I'm going to state categorically that the ceramic disc units are not your problem and should be left alone.
 

barythrin

Veteran Member
Joined
Oct 5, 2005
Messages
6,256
Location
Texas
Out of curiosity Mark, where are you located? The systems sound like they're both in pretty good shape if they're booting already. Are you just in cleaning mode or were they having a problem also?
 

Mark_E

New Member
Joined
May 24, 2012
Messages
7
Location
Tempe, Arizona
Hi Chuck,

Thanks for your reply. You know, I didn't think that those particular capacitors had anything inside that could leak out (as opposed to some other types) I was just wondering if, since there are so many of these caps (over 30!) on the mainboard, if it would have a collective positive impact on system performance to replace them. But I'll just leave them be. This machine actually functions quite well; the drives spin freely, and have no problem reading the CP/M 2.2 boot disks. The machine boots right up, and performs most CP/M functions flawlessly. The other Kaypro, however, is another story. That one seems to be having intermittent drive problems; it fails to read most media, and it's throwing a lot of ddisk error messages. Do you think it would help to clean the drive heads on that one? Thanks, Mark
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
39,111
Location
Pacific Northwest, USA
I'd definitely start by cleaning the heads--what you describe sounds as if dirty heads are the most likely problem. Alignment is another issue, but it's considerably more difficult for a neophyte (on disk drives) to address--it can be very touchy.

So, some isopropyl alcohol and some cotton swabs are in order, unless you have a cleaning disk and fluid. I use perc (perchloroethylene) on mine, but you have to be careful not to touch any plastics with that.
 

Mark_E

New Member
Joined
May 24, 2012
Messages
7
Location
Tempe, Arizona
Restoring Pair of Old Kaypro 2's

Restoring Pair of Old Kaypro 2's

Out of curiosity Mark, where are you located? The systems sound like they're both in pretty good shape if they're booting already. Are you just in cleaning mode or were they having a problem also?

Thanks for the reply. I have (finally) updated my profile, but I'm located in Tempe, Arizona. These machines are both in pretty good condition, I've had them for several years. It's just that one of them seems to be having intermittent disk drive problems, it's throwing CP/M BDOS error messages. I was wondering if it might help to clean the drive heads. Thanks, Mark E.
 

Mark_E

New Member
Joined
May 24, 2012
Messages
7
Location
Tempe, Arizona
Although I have a lot of experience in some areas, when it comes to older 5.25" disk drives, I am in fact a neophyte! And I certainly don't want to damage my machines; I think the best thing I could probably do is use a cleaning disk and fluid. Anybody know where I could find one? (I saw one on eBay recently that was for 5.25" drives, but they wanted $30 for it!) A little steep, or am I just being a cheapskate?
 
Top