• Please review our updated Terms and Rules here

SWTPC 6800 and CT-64 terminal

allmacs

Member
Joined
Dec 17, 2016
Messages
48
Location
South Carolina , United States
Hello I have issues with my CT-64 terminal. It seems that the vertical sync is out for some reason.
https://youtu.be/Q3re47AbHJk
I have replaced all components in the power supply. and several Capacitors and Resistors that seemed out on the CT-64 main board.
So far what I checked on the oscilloscope looks good. Whenever I find a component that seems out I order them new and the project halts until they are installed.
I am trying to find someone who knows these Computers. There is a person named Michael H., who made a SWTPC website , but it seems impossible to get a hold of him.
IMG_0068.jpg
 
Last edited:

g4ugm

Veteran Member
Joined
Feb 22, 2011
Messages
2,837
Location
NorthWest England (East Pondia)
Mine has a distorted display which I don't think is the display, as when I feed the composite out into an external monitor I get the same results. There are also multiple logic faults. I get corrupt characters on the screen. Its on the back burner as I have lots more things to debug...
 

allmacs

Member
Joined
Dec 17, 2016
Messages
48
Location
South Carolina , United States
Mine has a distorted display which I don't think is the display, as when I feed the composite out into an external monitor I get the same results. There are also multiple logic faults. I get corrupt characters on the screen. Its on the back burner as I have lots more things to debug...

What do you think the cause is? Capacitors? Transformer? or bad IC's? Did you work on a computer like this before?
 

g4ugm

Veteran Member
Joined
Feb 22, 2011
Messages
2,837
Location
NorthWest England (East Pondia)
What do you think the cause is? Capacitors? Transformer? or bad IC's? Did you work on a computer like this before?

I suspect all of those, plus possible bad connections between the boards and between the ICs and sockets. I must admit I try and avoid actually messing at the component level, although I have built similar computers from components. In the day I built a 77-68 and the later 6809 system..

https://en.wikipedia.org/wiki/Newbear_77-68

.. and have built several radio receivers and transmitters. Current project is trying to fix a SCSI2SD where the USB socket has been ripped from the board. it was only held with hot melt glue so several bits of track wunt as well... :(:(:(:(
 
Top