• Please review our updated Terms and Rules here

Toshiba T3200SXC Backlight Experimentation

T-Squared

Veteran Member
Joined
May 29, 2011
Messages
549
Location
San Antonio, TX
I decided to try getting this hulk of a beast running. The only problem? I seem to have a problem with the backlights, and I spent all day modifying the connections to accept a more-standardized system (Du-Pont)

I'm trying to use the compatible screen I found with my T-6400DXC back in 2017 (I still hate that computer. Really bad ergonomic design, aesthetic, and size.), but I'm unable to get a stable light.

I've posted a few times about modifying the internals of the lid casing to accept it, but I was hesitant to because I wanted to keep it as stock as possible.
Imagine my luck when I found that a hinge support post had broken off on the inside, so it wasn't exactly mint-quality anymore.
Now this was a somewhat easy repair, after stumbling over the post's plastic that kept breaking under stress when I tried to cement it together. I used a standoff with the same friction bearing, which is now melded into the post a halfway further down (which I did using a soldering iron), and seems to be stronger, since it's closer to the casing: https://imgur.com/RLSRhwq

But i digress, I snipped off the parts of the casing preventing me from placing the screen in neatly. (with a pair of flush cutters), and got to work modifying the connections of the backlights, so I could hopefully use the inverter with the backlights of the compatible LCD module. I keep getting an oddity: The lights pop on for a second, and then switch off.

Worse? The inverter circuit does the same thing with the original backlight too. Then again, the problem may be because I only have one light plugged in, and it may need a certain load to activate and stabilize. I only have been able to find one inverter light cable to use at the moment.

Anyways, in both cases, they turn on and then switch off. But, I get a better, more consistent light with the original backlights, yet they won't stay lit.

I understand that this is all experimentation, so is there anything that I'm doing wrong? Based on what I think is a logical and not-too-far-off assumption, it seems like the inverter circuit should work with what I have, seeing (from newer to older) that the T-6400DXC was a step-up (yeah, right) from the T-6400SXC, which was closest in specifications to the preceding T-3200SXC:

T-3200SXC: Original LQ10D013 monitor + Inverter (foundation)
T-6400SXC: Same Monitor, Different Inverter design (same power specifications?)
T-6400DXC: Different monitor (LTM10C013), but probably same 6400SXC inverter design.
 
Last edited:

mattsoft

New Member
Joined
Jul 7, 2020
Messages
4
Recently picked up a T3200SXC with lots of issues:
  • Leaky caps on the PSU (yuck)
  • Bad CMOS battery (duh)
  • Dead HDD
  • Bad TFT LCD
  • Broken hinge (similar to T-Squared's issue)
I've already replaced the CMOS battery, removed the HDD and put in an XT-IDE, and recapped and cleaned the PSU (works great).

The took apart the LCD and it was a corroded mess. Green forests of electrolytic everywhere. Removed, cleaned, and recapped and the LCD is still dead. The backlight works great, but no image on screen. :( I'm looking at putting in a modern LCD with an analog VGA board and just wiring it into the VGA pins on the underside of the motherboard.

The bigger issue are those damn screen hinges. Mine are broken at the same spot, though they are still there, just cracked. I'm working on making some 3D printed brackets to re-inforce the posts that are there. Hopefully that will solve the problem.
 

T-Squared

Veteran Member
Joined
May 29, 2011
Messages
549
Location
San Antonio, TX
I'm in the middle of repairing the LTM10C013 screen myself. I caught the capacitor leakage on mine JUST in time. (Even being able to test out a new fiberglass brush pencil as well) However, I'm also replacing the right-angle connector header. Several non-connected copper vias on the connector lost their epoxy strength, so I'm gonna replace those. I also have to contend with replacing the FFC headers on the main input board, because 29 years apparently isn't kind to plastic.
 

mattsoft

New Member
Joined
Jul 7, 2020
Messages
4
Well, I was able to fix the crumbling hinges by designing and 3D printing "sleeves" that go over the existing hinge posts. I filled them with JB Weld epoxy and then slid them over the posts. After 24 hours, the new hinge posts are solid. I've gone the solder a cable to the VGA header route and am now looking for a panel panel to put inside and will abandon the original panel for now.Screen Shot 2021-07-10 at 11.01.57 AM.jpg
 

Fastopen

Member
Joined
Feb 17, 2013
Messages
13
Location
Madrid, Spain
I'm in the middle of repairing the LTM10C013 screen myself. I caught the capacitor leakage on mine JUST in time. (Even being able to test out a new fiberglass brush pencil as well) However, I'm also replacing the right-angle connector header. Several non-connected copper vias on the connector lost their epoxy strength, so I'm gonna replace those. I also have to contend with replacing the FFC headers on the main input board, because 29 years apparently isn't kind to plastic.
Hi,

is the LTM10C013 phisically equivalent to the LQ10D013 in order to be fitted on the chassis? Let us know how is your repairment /sustitution

best regards,
 

T-Squared

Veteran Member
Joined
May 29, 2011
Messages
549
Location
San Antonio, TX
Hi,

is the LTM10C013 phisically equivalent to the LQ10D013 in order to be fitted on the chassis? Let us know how is your repairment /sustitution

best regards,
No, it is not, unfortunately. You may have to use some extra tools, clip off the fins on the right side (The thin horizontal parts), and add extra framing to get it to fit.
 
Top