• Please review our updated Terms and Rules here

Tseng4000AX bad colors

vladstamate

Experienced Member
Joined
Dec 2, 2012
Messages
197
Location
Orlando, FL, USA
Hi all,

I have gotten an ISA videocard in my 386 that has a Tseng4000AX chip with 1Mb of video memory. It works well with the exception of the colors being overly saturated and bright. In some games it is unusable as almost everything is white. There is also an yellowish tinge in the white text when I only have the DOS command prompt being displayed.

Is this a know issue with Tseng chips/cards? A simple visual inspection does not show anything damaged and there are no DIP switches other than usual normal ones on the ISA cards at the time. Any idea what could be wrong? I assume there is something wrong with the RAMDAC. Also I am connecting it to a LCD. Would that make a difference?

Regards,
Vlad.
 

jmetal88

Veteran Member
Joined
Jul 23, 2010
Messages
878
Location
Derby, KS
If I were you, I'd see if I could correct the issue by changing the monitor settings. I have a Dell LCD that displayed overly saturated colors on everything, and I had to go in to the color settings and decrease all the color levels.
 

Trixter

Veteran Member
Joined
Aug 31, 2006
Messages
7,262
Location
Chicagoland, Illinois, USA
Is this a know issue with Tseng chips/cards? A simple visual inspection does not show anything damaged and there are no DIP switches other than usual normal ones on the ISA cards at the time. Any idea what could be wrong? I assume there is something wrong with the RAMDAC. Also I am connecting it to a LCD. Would that make a difference?

It shouldn't make a difference. Have you tried the monitor with another card to make sure it is the card that is the problem and not the monitor? If you've verified the monitor's default settings produce proper results on another card, then yes, I'd say your Tseng has a bad RAMDAC.
 

vladstamate

Experienced Member
Joined
Dec 2, 2012
Messages
197
Location
Orlando, FL, USA
It is not the monitor. I've tried a lot of settings and the colors are very bright and washed up. I do have a second ISA VGA card that works perfectly fine in the same monitor. The only reason I wanted the Tseng is because it is way faster and that it has 1Mb of memory (my other one has only 256k). Bad RAMDAC is what I suspect too, I just never seen it fail like that.

I got another 1Mb ISA VGA card that unfortunately arrived damaged and the computer won't boot with it. So I am now waiting for the 4th card....

Regards,
Vlad.
 

vladstamate

Experienced Member
Joined
Dec 2, 2012
Messages
197
Location
Orlando, FL, USA
Oh, and I just got the new videocard, a Trident chipset one with 1Mb memory. Works like a charm. Strange for the RAMDAC to fail in the Tseng4000AX card. I have never heard for that to happen, unless the card was like that from the beginning. I think back in those days RAMDAC was not integrated on the main chip but it was still a solid ship.

Regards,
Vlad.
 

Robin4

Experienced Member
Joined
Sep 25, 2011
Messages
378
If you are technical enough, trying to find a new old stock dac.. And replace the older one..
 
Top