• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

UNIVBE only detecting 1mb?


Experienced Member
Mar 29, 2013
Quebec, Canada
well on most of my DOS computers (486DX4 100Mhz, Pentium 75Mhz and Pentium 100Mhz), when i run UNIVBE with a VESA-compatible card, even if the card have more than 1mb of memory, UNIVBE still detect only 1mb...is that normal?

For example, i tried many PCI cards (S3, Cirrus Logic, ATI, Trident...) that have 4mb or 2mb installed, and it detect either 512kb or 1mb maximum, never 2mb.

And yes it really have more than 1mb installed (2mb or more)


Veteran Member
Jan 4, 2011
If you toss together a quick bit of code to poll the available VESA video modes, does it list any that would take more than a meg of RAM? Can you set those modes? (for example 800x600 in 32 bit should take just under 2 megs)

If the modes are listed and works, UNIVBE is just not reporting the memory properly.

Of course if it's a VESA compatible card, what do you need UNIVBE for?