• Please review our updated Terms and Rules here

A rather strange Commodore C128D

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
I have a plastic 128D that seems to be like any other one I've seen either live or in pictures.
However, on this one, there is no text under/above any of the ports or activity LEDs.
It's not like they were there and someone filed them off for some strange reason, they were just never there.
There is also no sticker on the bottom of the unit with the make, model and serial number, which I could understand as it would be easy to remove.
As well, in the bottom right hand corner of the case front, where the C= logo would be, there is just a square depression.
Has anyone heard of anything like this before?
 

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
Do you have any pictures? Do the internals look any different? Perhaps it's a prototype?

No, no pictures yet, perhaps this afternoon.
I noticed it yesterday down at the shop when someone was doing an initial cleaning, so I had them drop it off at my house and this morning, I fired it up and it seems to work just like a 128D (looks terrible on the rf modulator, I'll have to dig up an A/V cable since ours are still being manufactured).
I'll open it up, hopefully, today and see what the inside looks like.
Prototype is the first thing I thought of too, but just the case, maybe.
 

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
I'll do what I can about the pictures. I'll also be running it though the C128 harness test this weekend.
As for selling, yes, it will be for sale, but someone out in AB has right of first refusal.
I'm more fascinated to find out about the case though, right now.
This is REALLY getting in the way of my pet project of replacing a bunch of 6526s and 6581s in a dozen C64/64c units.
And I just got my new vacuum solder extractor....sigh.
 

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
Some quick pictures...

Some quick pictures...

I just grabbed some pictures earlier and now, here they are...
 

Attachments

  • IMG_20190831_185400.jpg
    IMG_20190831_185400.jpg
    79.8 KB · Views: 18
  • IMG_20190831_185418.jpg
    IMG_20190831_185418.jpg
    77.3 KB · Views: 19
  • IMG_20190831_185454.jpg
    IMG_20190831_185454.jpg
    76.2 KB · Views: 17
  • IMG_20190831_185513.jpg
    IMG_20190831_185513.jpg
    79.6 KB · Views: 18
  • IMG_20190831_185552.jpg
    IMG_20190831_185552.jpg
    74.7 KB · Views: 18
  • IMG_20190831_185706.jpg
    IMG_20190831_185706.jpg
    85.7 KB · Views: 18
  • IMG_20190831_185724.jpg
    IMG_20190831_185724.jpg
    87.3 KB · Views: 18
  • IMG_20190831_185752.jpg
    IMG_20190831_185752.jpg
    96.8 KB · Views: 16
  • IMG_20190831_185826.jpg
    IMG_20190831_185826.jpg
    92.7 KB · Views: 16
  • IMG_20190831_185837.jpg
    IMG_20190831_185837.jpg
    97.4 KB · Views: 15
  • IMG_20190831_185855.jpg
    IMG_20190831_185855.jpg
    95.3 KB · Views: 15
  • IMG_20190831_190341.jpg
    IMG_20190831_190341.jpg
    77.3 KB · Views: 17

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
So, no one has heard of this occurring before, with all the raised text on the case missing?
Anyone know of anyone I can contact about this?
I have to burn the diagnostic ROM for this and make a 128D keyboard loop-back and life keeps getting in the way.....
 

jafir

Veteran Member
Joined
Aug 6, 2018
Messages
963
Location
Arkansas
Following Occam's Razor, could it have been an injection molding issue or manufacturing error?


That would be my guess. The molds had an issue and someone decided to keep pumping them out blank until the text could be repaired. Of course I’m just writing fiction here, I have no evidence in reality, but I’d imagine the text would wear out first on the molds.
 

snuci

Veteran Member
Joined
Nov 22, 2012
Messages
1,308
Location
Richmond Hill, Ontario, Canada

vwestlife

Veteran Member
Joined
May 2, 2008
Messages
5,145
Location
central NJ
It has to be a prototype. The plastic case 128D was never sold in the USA because they could not get FCC approval for it. That's why they had to redesign it in a metal case.
 

KC9UDX

Space Commander
Joined
Jan 27, 2014
Messages
7,468
Location
Lutenblag
Following Occam's Razor, could it have been an injection molding issue or manufacturing error?

Very unlikely. You don't forget to put raised lettering in a plastic injection mold. Once it's there, it's very hard (and expensive) to remove. This would have been done intentionally. Someone decided to make cases without lettering, and then the mold was changed to add it.
 

Eudimorphodon

Veteran Member
Joined
May 9, 2011
Messages
4,807
Location
Upper Triassic
Was the C128 ever sold in any numbers to educational customers? I know Commodore had a reputation for filling those orders with machines that were slapped together from essentially random parts they had lying around. Other possibility is it may have come from one of those big inventory dumps to discount resellers they seemed to do on a regular basis even well before they were actually going out of business; quite a few prototype bits surfaced through those channels over the years.
 

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
All interesting theories, but it begs the question, if you have a viable casting, I doubt it would wear evenly so that all the raised (or even sunken) text would go at the same time. There would, likely, be some evidence of some text or remnants of it.
Why make a mold without the text when it would, obviously, be rejected.
I suppose the lettering in the mold could have been masked, for some reason (although it would probably ruin the mold at the temperatures they work at) and then slap a Commodore 128D label on it.
Then there is the matter of it being a 110V NTSC unit. Could it have been a prototype of the case there were GOING to release in North America that was subsequently shot down by the FCC?
If there were a LOT of them, I could see it as an inventory dump, but, I have never seen or heard of one before and even "slapped together units would have had the text when they were initially molded.
No one theory seems to fit the facts....
 

KC9UDX

Space Commander
Joined
Jan 27, 2014
Messages
7,468
Location
Lutenblag
There's just no way that that mold will make a usable part if the lettering is that far gone. Masking the lettering is not an option. The mold would have to be designed with different inserts for lettering or not lettering; this is no minor issue (or expense!). If the same mold that made this one made parts with lettering, the lettering was added (permanently) after this part was run, I'd bank on it. So most likely, this part was run before Commodore finalised what text would be used for the ports. I.E., this is a very early molded part. Then this C128 is either a pre-production unit, or they just used a leftover pre-production case. Or, there are more of these out there somewhere than we know of. Did all other plastic-cased Commodores have molded English lettering?
 

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
Well, I just spent too much time looking at too many plastic 128Ds and, in every case, where the test was legible, it was English (although I searched on European 128D) and, even in ones where the text wasn't legible, you could see that the number of characters for power and disk were the correct number and that the raised emblem in the bottom right corner square was there.
My case has none of these.
I was also thinking, and I'm not an expert on injection molding forms, that it would be easier to add the text to an existing mold than it would be to remove it.
 

Druid6900

Veteran Member
Joined
May 7, 2006
Messages
3,809
Location
Hamilton, Ontario, Canada
Just an update to this;
I contacted Bil Herd and he said he would like to see some pictures of the unit, so, I sent him to the Google gallery that holds the same pictures I posted here.
I never heard back from him despite sending a couple of emails asking him if he had received the link.
So, this is all back to speculation again......
 
Top