• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Altair 8800 Front Panel PCB Photo

rbgrn

Experienced Member
Joined
Apr 5, 2013
Messages
66
Hi All,

I'm repairing a bunch of cut traces on the front panel PCB of my Altair 8800. I could use the schematics but it would be much easier for me if someone could just post or send me a high resolution photo of the back (wire connecting, not lights/switches) side of the panel. Could anyone spare a moment to take a clear pic of theirs for me or point me to a good one that already exists? I've searched and searched already but haven't found it.

Thanks!

Here are the photos of mine right now. You can see some cuts are very obvious and will be easy to fix but there's a little more activity, cutting and patching already done around 2 of the ICs that are harder for me to figure out. One good photo will go a long way in helping me get this back together.
IMG_20130612_001843.jpgIMG_20130612_001852.jpgIMG_20130612_001900.jpg
 
Last edited:

kingchops

Experienced Member
Joined
Aug 11, 2011
Messages
179
Location
Adelaide, AUSTRALIA
Not sure if this helps, but took a photo of what was visible of mine.

P1050288.jpg

The site has resised the photo, if you need the hi-res version pm me.
 

Corey986

Administrator
Joined
Dec 7, 2011
Messages
821
Location
East Coast USA
Kingchops,

What's with the wire that cuts down the front panel. I have to look but I think my front panel wire bundle is clean and just runs along the top without dropping down a single wire to connect any chips directly.

Cheers,
Corey
 

kingchops

Experienced Member
Joined
Aug 11, 2011
Messages
179
Location
Adelaide, AUSTRALIA
Kingchops,

What's with the wire that cuts down the front panel. I have to look but I think my front panel wire bundle is clean and just runs along the top without dropping down a single wire to connect any chips directly.

Cheers,
Corey

Corey,

I'm not really sure what that is. I've noticed like you, that it only seems to be on my machine, I've never seen it on any other Altairs. That wire is hooked into the run switch but I've never traced it through to see where it goes. I'll take a closer look next time. I think that my cpu board has had the CPU mod done to it, not even sure what that is, but I recall seeing it in an edition of Computer Notes, and it looked very similar to what's been done to my cpu board. So it may have something to do with that but I'm only guessing.
 

rbgrn

Experienced Member
Joined
Apr 5, 2013
Messages
66
Thanks for the photo. Any more would be greatly appreciated as I still don't have mine running 100%

Kingchops, That wire looks like it is connected to the Run pin and will set whatever bus pin it's connected to high when the switch is held down. Your CPU card would need a direct modification to respond to that pin. There are several unused pins on the S100 bus so it could just use one of those without affecting anything else.
 
Top