• Please review our updated Terms and Rules here

Compuadd 386sx with a corruption on screen and ctrl-alt-del doesn't work

Glen M

Experienced Member
Joined
Apr 27, 2020
Messages
55
Location
Belfast, Northern Ireland
So this is something of a strange fault.

The system posts fine, I can enter the bios etc. It will boot to floppy without issue and everything seems fine except for 2 things.

Firstly once its booted a soft reset by use of ctrl-alt-del crashes the system but only once its booted to DOS, at the bios it works fine. When it does hang the screen stays on whatever it was, occasionally the PC speaker will give a single long tone. The only way to resolve this is a hard reset, power on/off.

The other issue then is that text on the command prompt will corrupt the entire screen once it gets to the last line. By that I mean you can fill the screen with text no problem but once you enter anything on the last line and hit enter everything above corrupts, it almost as if it happens only once the screen is asked to scroll.

For testing so far:

- I've changed the system memory, its fine.
- I've tried disabling the onboard graphics and using 2 different ISA cards but no difference (I initially though the onboard vram might be bad)
- I've done some probing around the board and found a floating pin on 1 of the F04 logic chips, replaced that, the signal returned but problem persists.
- I've tried reseating the BIOS (its the only socketed chip)
- also tried another PSU.

Now the fact that one of the logic chips on the board has a failure makes me thing there might be more, but then again if the logic was bad would the system boot and run?

I'd be open to any suggestions.
 

Glen M

Experienced Member
Joined
Apr 27, 2020
Messages
55
Location
Belfast, Northern Ireland
I've made some progress.

Ignoring the reset issue and on the advice of some folk on another vintage computer group I learnt that the CPU addresses the scrolling of the screen. So went looking across the bus and sure enough I found a bad 245, it had a good strong signal in and next to nothing out. Swapped that and sure enough the problem seemed fixed, well fixed for a good 10 minutes anyway but when it surfaced again the corruption isn't anywhere near as bad. Oddly swapping this also fixed the reset issue.

After some more poking I've found a duff looking 244 (in the same manor as the245 was). I'm going to swap that out later and hopefully thats the end of the problems!
 

oldpcguy

Experienced Member
Joined
Sep 23, 2021
Messages
225
It sounds as if the problem appears once the OS is loaded. If it persists after the 244 replacement you may want to consider that the OS installation may have become corrupted and needs to be reinstalled.
 
Top