• Please review our updated Terms and Rules here

Creating IBM Diagnostic Disk

akm513

New Member
Joined
Jun 29, 2021
Messages
6
Earlier this year I took ownership of an IBM AT and guides, but unfortunately the diagnostic disks were not there. No problem, I thought, thinking that I could create my own disks. Months later, I'm no closer than I was. I downloaded the disk image here (http://minuszerodegrees.net/5170/setup/5170_setup.htm) and attempted to write it with my 486, but it isn't working.

I've tried other disk images I've found across the web. I've tried multiple disks. I've tried multiple OSes on my 486. I've tried multiple disk writing programs. Some of the programs don't work or I can't figure out how to work them. Some of the tries have given me errors. When the write does finish, I get unreadable disk errors on the AT.

What am I missing? This ought to be possible, right?
 

seaken

Experienced Member
Joined
Jun 20, 2016
Messages
415
Location
Shokan, New York
I am trying to remember but I can't say for sure. Is it necessary to write the disk from an image file using an disk image utility? Maybe. In that case I probably used LapLink to move the image over to the hard drive and then used a DOS image writer. But I have also had success making disks using my other 286 that also has a 5.25 1.2M drive in it. I was able to make CP/M boot disks using that machine. I may have used that machine to make the IBM Diagnostic Disk. It's been too long and I didn't log my procedures. But I did make a working 1.2M diskette for the Diag and Setup, so I know it can be done. I'll look around again and see if I can track down what I did.

Seaken
 

Makefile

Experienced Member
Joined
Jul 13, 2020
Messages
132
Location
MD, USA
If it's a 360K image, are both the media and drive low-density? If the media part is taken care of, you can always temporarily transplant the drive to the 486 to write the image.
 

seaken

Experienced Member
Joined
Jun 20, 2016
Messages
415
Location
Shokan, New York
Okay, I took a look at my 5162 and the Advanced Diagnostic Setup disk. Yes, the image was a 360K but since I don't have any 360K drives I managed to get it on a 1.2M disk and on a sub-directory on my HD. My memory is spotty so this may not be exactly the correct procedures. But I did get the setup program to run from the sub-directory without booting a 360K disk. I also have it booting off the 1.2M disk.

When I booted the 1.2M disk it shows that it is running Tandy MS-DOS 3.3. This tells me that I did not image the disk. Instead, I formatted the disk on my other 286 was running Tandy MS-DOS 3.3, and then copied the system to make it bootble. Then I used XCOPY to copy all the files over. The key, I think, is to make sure to use the "Command.com" file from the Advanced Diagnostic Disk image. That is what launches the Setup program at boot, or when run off the hard drive. (Be careful to not accidentaly replace your main command.com file. Keep it in a sub-directory or only on the bootable Diag disk).

I probably used an imaging program to write out the files and then copied them over using LapLink to a directory on the HD and then copied them over to a newly formatted 1.2M disk. At any rate, both my 1.2M boot disk and the directory on the HD are working to launch the setup program.

I checked the attributes of the files to make sure there was nothing hidden. It took me a few tries to launch the program correctly butthen I realized it was the command.com file that was loading automatically at boot. When I type "command.com" from the HD directory it also starts.

It may not be the correct way but it works.

Seaken
 
Last edited:

DDS

Veteran Member
Joined
Sep 5, 2013
Messages
643
It is generally a bad idea to mix and match between 360k drives/media and 1.2m drives/media. Done carefully, and after thinking about what you're doing, you can carry it off if everything works just right. If not, you likely will have some interesting problems. The fact that one kind of media will physically fit into the other kind of drive doesn't mean its a good idea to use it that way.

Short version, a 1.2m drive (can) write twice as many tracks, each half as wide, and with higher energy than a 360k drive. You can often format and write a 360k disk in a 360k drive, then read it on a 1.2m drive. Do it the other way round and you will have "half width" tracks written down the middle and in between where the 360 k drive is expecting them to be, and of a strength that the 360k drive can't fully write over or erase.

Save yourself some headaches, mark your 360k and 1.2m drives and media and make an effort to keep them separated and used in the drives they were intended for.

This topic has been discussed often, in depth, and sometimes with an almost religious fervor on this forum, but it still lies in wait to bite the behinds of the unwary or inexperienced. Read up. Get educated. Then proceed as you see fit and at your own risk.

You can always come back and tell us "Its just a flesh wound."


;-)
 

seaken

Experienced Member
Joined
Jun 20, 2016
Messages
415
Location
Shokan, New York
Since we're talking about an IBM AT it's not likely that the OP is dealing with a 360K drive. They haven't said what type of floppy they are attempting to use. But I agree to keep 360K and 1.2M disks seperate. If they are trying to image onto a 1.2M disk it won't work, as has already been hinted at by @Makefile.

In my case, I also do not have a 360K drive. I was able to copy out the files from the 360K image and place them on a 1.2M disk and on my HD. I did not need to "image" a 360K disk to get the Advanced Diagnostics Setup program to work on my 5162 (also an AT).

Love the Monty Python referrence!

Seaken
 

Plasma

Veteran Member
Joined
Nov 7, 2005
Messages
1,800
You can also change floppy disk image formats with WinImage. Just convert the 360K image to whatever format you need. This will also preserve the boot sector if the disk is bootable.
 

Ruud

Veteran Member
Joined
Nov 30, 2009
Messages
1,217
Location
Heerlen, NL
WOW, never knew that! Couldn't you have told us that some twenty years ago? :)
 

akm513

New Member
Joined
Jun 29, 2021
Messages
6
Thanks for all the insights here. I do indeed have a 1.2M drive. Unfortunately I don't have any 360k disks, so I was wondering if that would be my issue. I thought I could somehow force it into that format.

And maybe in WinImage I can? That is one of the utilities I was using. Will have to check again for that setting. Will have to report back.
 

Plasma

Veteran Member
Joined
Nov 7, 2005
Messages
1,800
Image -> Change Format. Version 10 appears to have a weird quirk where you can only shift up one size at a time. So you would need to convert to 720K, then convert that to 1.2M. I'm unsure if earlier versions were also like that.
 

akm513

New Member
Joined
Jun 29, 2021
Messages
6
Image -> Change Format. Version 10 appears to have a weird quirk where you can only shift up one size at a time. So you would need to convert to 720K, then convert that to 1.2M. I'm unsure if earlier versions were also like that.

Thank you, this was super helpful. I am using version 8 since I am using Windows 98 to write the disk, and it had the same quirk. It seemed to write the disk successfully (it completed anyway, which is more than it was doing before), so I was hopeful. But the AT refused to read it, just giving me a "General Failure."

Maybe I do need the 360k disks after all.
 

Plasma

Veteran Member
Joined
Nov 7, 2005
Messages
1,800
I see the disk image has PC-DOS 2.0 which only supports 360K drives so that's probably the issue. You need at least PC-DOS 3.0 for 1.2M drives.

In this case, I would do what others have suggested and make a boot disk in your 486 (format a: /s) and just copy the files to that floppy instead of directly writing the image. Don't overwrite any of the system files already on the floppy.
 

vwestlife

Veteran Member
Joined
May 2, 2008
Messages
5,320
Location
central NJ
IBM Diagnostics doesn't need an exact track-for-track duplicate of the original disk to work. Just format a bootable DOS disk of the desired size and density, and copy the files over to it. Diagnostics includes its own customized COMMAND.COM which will replace the normal one that DOS uses.
 

seaken

Experienced Member
Joined
Jun 20, 2016
Messages
415
Location
Shokan, New York
Is your AT failing to boot from the disk? Or is it not readable if you boot from another disk?

@Plasma , @vwestlife and myself have all said the same thing. You may be best served by NOT trying to write the image file to your disk. Just format a 1.2M diskette in your AT. Then move it to your 486 and COPY all the files over.

Seaken
 

akm513

New Member
Joined
Jun 29, 2021
Messages
6
Thanks for all the advice here. I ended up just breaking down and buying a set of these disks rather than futzing with it myself. I've learned a lot from this thread and subsequent research in the last few days!
 
Top