• Please review our updated Terms and Rules here

DECSystem 5000/240


Veteran Member
May 31, 2011
Sefton, Meresyside, England
I've had a DECSystem 5000/240 for a while and recently decided to check it out. I cleaned it up and tested the PSU offline and it appears OK. I connected the PSU to the system board via the large ground and +5V cables only and no issues, PSU fans turn and some LED's are active. I switched it off and then connected the 12V connector to the system board and after powering back on I got a little flash from by the 12V connector and no fans or LED's. Quickly powered it off and checked around the area by the 12V connector and low and behold I had a short circuit surface mount diode, I photographed and removed it (photos to follow). Oddly when I now plug the 12V connector in I get output on my VT terminal and the self test apart from NVRAM battery all pass. It has 64MB RAM and 1MB NVRAM. The DECSystem has no Turbochannel graphics unlike the DECStation. I plugged an expansion box into the SCSI port and the devices are seen but this expansion box was from a VAX/MicroVAX so I'll have to add a HDD. I have a DEC RRD CD-ROM for the expansion box. I've looked on this forum and Google for Ultrix images to burn to CD (if they existed, tape seems common but I suspect that may be for the MicroVAX Ultrix??) but none of the links or .img downloads seem to work. Does anyone have any pointers to working downloadable images? TIA.
Last edited:
I've got Ultrix MIPS 4.2, 4.3, 4.4, and 4.5 in ISO format, but I've never tested them. (Does SIMH run a MIPs build?) If all else fails, I can drop them someplace for you.


Edit: I think I have an original Ultrix CDROM from the software products distribution, but that would take longer to fish out. No idea on the version.
Last edited:
I've been given an image to trey from a DEC enthusiast in the UK to try (Thanks Rob(y)). I'll give that a try next week. Here are some photographs of the shorted diode in case anyone else has a dead DECStation/DECSystem 5000. I intend to replace the diode.

I have been struggling to burn the Ultrix images to CD-R but after a lot of trial and error and testing I've managed to burn both a 4.3 and a 4.5 iso. I used UltraISO but had to throttle back the write speed of my writer from 24x to 4x. I can now boot both the 4.3 CD and 4.5 CD but after displaying the Ultrixboot banner and then starting at 0x0003000 the DECSystem reboots back to the >>> prompt. So I still have some troubleshooting to complete but at least it is a start. It may be that have and RZ29b installed in the expansion and box this is 4.0GB so I'm going to look for a smaller SCSI HDD to see if that is causing the issue.


  • 20220701_142545.jpg
    1.3 MB · Views: 15
  • 20220701_141150.jpg
    1.3 MB · Views: 14
  • 20220701_143619.jpg
    1.5 MB · Views: 13
Early DEC CD-ROM drives don't really like modern CD-R media. I had to swap the drive in my VAXStation out for a later SCSI CD drive before it would recognize the OpenVMS media I'd burned.
Thanks g4ugm for the offer but I think I've made good progress. I dug out an NEC SCSI CD-ROM drive and while looking in the box I found a DEC RRD43, I've previously only tried known good working RRD42 drives from my VAXstations's.
I connected up the NEC drive and attempted to boot (boot 3/rz4/vmunix) LED on CD-ROM drive flashes and then nothing on terminal. I thought I'd try the RRD43 anyway, connected it up and using the previous command the DECsystem now boots and asks me if I want to 1> Basic Install, 2> Advanced Install, 3> System Utilities (or similar) I selected basic install and picked RZ0 ( RZ29 4.3GB HDD) and install fails after a while with unable to create partition g for /usr. I tried booting again with advanced install this time but after entering the requested info I get failed to create partition g /usr. I swapped out the RZ29 for an RZ28 2.0GB HDD and ran basic install this time it completed the installation.:)

System now boots from RZ0 (RZ29 2.0GB HDD) into Ultrix 4.5, see attached photographs. My plan is to replace the HDD with a SCSI2SD card moving forward. I suspect that 4GB HDD is not supported but I many try again with either OSF/1 or NetBSD if I can source the images.

The DECsystem doesn't have a graphics card unlike the DECstation, but I think may leave i t like this unless I come across a cheap supported TURBOchannel graphics card.

So what I've learned,

set write speed in UltraISO burning software (I tried other ISO software tools) to x4 (slowest) because I was unable to burn a bootable CD-R at default speed of x24.
Try multiple CD-ROM drives. Even if I know the drive works in another machine.
Try multiple HDD's. Even if I know the drive works in another machine.
Ask for advice;)

Next on my list is to go back to trying to fix my PDP-11/24.


  • 20220702_161011.jpg
    218.9 KB · Views: 15
  • 20220702_161237.jpg
    166.1 KB · Views: 16
Hi PG31-
I'm a bit late to the party here. I have a DECsystem 5000/133 with a bunch of Ultrices, happy to share war stories etc. I'm over in Sheffield & Manc so not too far away.

Interested in your efforts to get OSF working. There are kits to build tapes around but I've never gotten it working. The kernel boots but craps out so far through. It's been a while since I looked at it so I forget the exact message.

There is no SIMH MIPS simulator. There's a chap on Twitter who got OSF/1 working on GXemul though. Something else I've not had much luck with!
Found the OSF/1 kernel boot log. Fails with "cm_validate: invalid version".

>>boot 3/rz5/vmunix
Mips boot: memory from 0x605000 to 0x1fff000
Kernel virtual space from 0xc0004000 to 0xffa00000.
DEC OSF/1 X2.0-8 (Rev. 155); Mon Jul 6 23:03:13 EDT 1992
cache sizes: 65536 inst 131072 data
physical memory = 33554432 bytes (32.00 MB).
available memory = 25026560 bytes (23.86 MB).
using 245 buffers containing 1003520 bytes (0.95 MB) of memory
DECstation 5000 Model 120 - system rev 48
64Kb Instruction Cache, 128Kb Data Cache
cpu0 ( version 3.0, implementation 2 )
fpu0 ( version 4.0, implementation 3 )
tc0 at nexus
asc0 at tc0 slot 3
rz0 at asc0 bus 0 target 0 lun 0 (DEC RZ58 (C) DEC 2000)
rz4 at asc0 bus 0 target 4 lun 0 (DEC RRD42 (C) DEC 4.5d)
rz6 at asc0 bus 0 target 6 lun 0 (TOSHIBA XM-4101TASUNSLCD 0064)
tz5 at asc0 bus 0 target 5 lun 0 (ARCHIVE Python 28388-XXX 5.72)
ln0 at tc0 slot 3
ln0: DEC LANCE Ethernet Interface, hardware address: 08:00:2b:37:f0:9e
scc0 at tc0 slot 3
lvm0: configured.
lvm1: configured.
lost battery backup on clock
WARNING: lost battery backup clock -- CHECK AND RESET THE DATE!
vm_swap_init: warning /sbin/swapdefault swap device not found
vm_swap_init: in swap over commitment mode
cm_validate: invalid version

As far as I'm aware, my 5000/133 is a supported platform.
vm_swap_init: warning /sbin/swapdefault swap device not found
vm_swap_init: in swap over commitment mode
cm_validate: invalid version

As far as I'm aware, my 5000/133 is a supported platform.

If memory serves, cm_validate checks kernel mods to insure they are compatible before loading. Do you have any unusual hardware attached? Maybe strip the chassis down to the minimum and see if it will boot then.

It's a bare-bones single motherboard system. Everything is part of the mobo (SCSI, network etc). The only things I have to add are the storage peripherals. There's no frame buffer, serial console only.

The only thing that is raising a question with me is the battery in the Dallas chip failed ages ago. Ultrix doesn't seem to mind... maybe OSF is a bit more finicky?