• Please review our updated Terms and Rules here

Epson Equity LT screen flashing issue

Tox

New Member
Joined
Mar 21, 2012
Messages
2
Hi to all!
I've an issue with my Equity LT screen. When I'm using the laptop,sometimes the screen stops displaying part or entire video
output,usually starting from near the bottom of the screen to a random place... sometimes the entire screen blanks,it's like a
flash.Sometimes a black line appears at random places. The "errors" of display are very fast,they appear and disappear in a
while. The computer runs good,no other issues. I've run epson diagnostics for this laptop,everything looks good.
I've checked the power supply inside the laptop,all voltages are almost good. Only one +12V line is outputting +11.5V
and one +3.3V shows a 1.2V alternating voltage if i check it with voltmeter set in ac voltage mode. No signs of blown or leaking caps (but the 1.2V alternating voltage is suspect D: )
I've cleaned,checked and reseated every plug starting from the motherboard going to the lcd monitor.
I've extensively the web for any info on similar faults,but I found nothing (and I think the problem is hard to explain)
If someone has some info or tips on this problem (not specifically for the epson,even for similar old laptops with similar screens)
please help :)

(PS: It's a CGA black and white lcd with blue electroluminescent backlight,like the DG1 and Zenith Supersport screens)
 
Last edited:

barythrin

Veteran Member
Joined
Oct 5, 2005
Messages
6,256
Location
Texas
Have you tried it with an external monitor if it supports one? Does the problem occur there too or just in the LCD circuitry?
 

Tox

New Member
Joined
Mar 21, 2012
Messages
2
Have you tried it with an external monitor if it supports one? Does the problem occur there too or just in the LCD circuitry?

It has a standard CGA port,but i don't have any CGA-compatible monitor D:
 
Top