• Please review our updated Terms and Rules here

IBM PS/55 note n23sk Can't enter bios and Unable to read hard drive


New Member
Sep 14, 2023
I own an IBM PS/55 note n23sk. After booting, the screen displays 161, 163 and prompts to insert a floppy disk. You can enter DOS using the boot disk, but you cannot jump to the hard disk partition. What should I do in this situatione4560a2438add0ba3d07b909535aab5.jpg08be6ca50d047d4f112d9040fa18cbc.jpg
First off, it's gonna need a recap. The purple-cased caps you see on the board there are fine, but the little silver cans are prone to leaking and will cause problems. The LCD panel may also need those capacitors replaced. Are you familiar with this process?

You said that you can't enter BIOS. I assume you tried F1 & F2? I'm not sure how the BIOS works on this model.
Welcome to these forums.

On an IBM AT (IBM 5170), a 161 error indicates a bad 'CMOS' battery. On an IBM AT, simply fitting a new CMOS battery will not remove the 161 error. After fitting a new battery, one then goes through the CMOS SETUP procedure, and one of the things that does, is clear the 'bad battery' flag (if the battery is no longer 'bad'.)

Your computer could be the similar. Is that a battery in the top-right corner of the second photo ?

At [here], I see the Reference Diskette, which is kind of equivalent to the CMOS SETUP procedure of the IBM AT.
You said that you can't enter BIOS. I assume you tried F1 & F2? I'm not sure how the BIOS works on this model.
The diagram at the screen bottom is indicating that the F1 key needs to be pressed, but I suspect that the Reference Diskette is needed, and F1 boots to that diskette.
Welcome as well, forgot to mention that in my last post!

Well, I am just recommending a recap right now as it is working, but that's a pretty strong recommendation. The photo is a bit low resolution so I can't tell for sure, but I think I can spot cap leakage/corrosion on the two silver cans on the left, and on the plastic-cased one in the upper right. In any case, it's just about a given at this point that those are gonna need to be changed out. It may work right now, but it probably won't stay working for long with the original capacitors fitted. The ones I see are the three I mentioned, then the brown one and the green one near the big cluster on the left side. The purple cased ones are polymer capacitors rather than electrolytics and typically don't need to be replaced. At this point in 2023, the surface mount and plastic cased caps are always bad in a system of this age, and the corrosion from them will cause board damage and instability. This isn't related to your current boot issue (and sorry that was unclear in my first post), but it will become an issue if not addressed.

And yes, I do believe this one does need a setup diskette.
The object in the top right is the battery from the looks - I saw one similar to that in a rusted out Dauphin laptop I got a few months back. Mine was a different brand than yours, but for me that was a 3.6V Lithium. I'll bet that one's similar, it should have markings on it.
After setting up with the reference floppy disk, I successfully entered ms-dos and win3.1. Thank you all!XD