• Please review our updated Terms and Rules here

ISA USB board

rvdbijl

Experienced Member
Joined
May 8, 2017
Messages
112
Location
NH, USA
Based on a very old thread on this forum and some other threads I found online, I thought it might be fun to try to get an old XT going with a ISA USB board based on the CH375 IC. I found one on Taobao in China and managed to wrestle through the Google Translator to actually make the purchase. To my surprise it showed up a couple of days ago in my mailbox!

So I'm trying it out with a multitude of different USB drives (all partitioned with a single partition < 512MB in size, formatted as FAT, not FAT32). I tried the V1.9 and the V2.0A drivers I was able to find online, but none of them seem to be willing to do anything useful beyond throwing errors. It's definitely seeing the board (if no USB is plugged in, it tells me no disk found). If I plug in a USB stick, I get one of three behaviors: a) Bootsector error, b) Data error, c) Freeze.
I tried both the IRQ and the NOINT versions of the CH375DOS.SYS driver, but no luck either way. I also tried 3 different USB sticks (256MB, 1GB, 8GB -- all partitioned and formatted as described).

Long shot -- does anyone have any idea how to make this work?

y4m7KCipMeef2ixcv_S1RgiApqlFx5O-H4ssesxAHZuzm94S3cyKWp0K5nTgO6iVAYz-3MxAfjwe3i4y_lHVZM8DEnKPgkIW8bAXN9vCoAjdWk6wAZPi4CoE8BPVLmK4cVJ7RKirZsMmAtqXHm3p5sHpkJ9VgQaedp4K_Uh9B8bhoz3qdoQXM8Mk4JUzHcvCbVuca_9rhOBhV44zxpP60djkw
 

Malc

Veteran Member
Joined
Jul 16, 2009
Messages
2,163
Location
UK
Try it in a more modern PC, 486 - early pentium, Somebody had one of those working but i can't remember who it was, There are threads on this forum somewhere, I think the flash drive had to be formatted as a zip disk ??, I don't have the chinese card, I have the lo-tech experimental isa-usb card that never went into production sadly.
 

rvdbijl

Experienced Member
Joined
May 8, 2017
Messages
112
Location
NH, USA
I was using DOS 6.22 on a NEC V20 machine. But I’ll give it a go on a 486 I have here as well. Would be too bad if I can’t get it to work on the XT clone I had it destined for though ..
 

sorphin

Experienced Member
Joined
Feb 11, 2014
Messages
215
Not to Necro (except that I got a couple of these a few weeks back).. but I have the above exact card working in my 5150 (as well as booting from it by having the right bios in U28 via an adapter)
 

Timo W.

Veteran Member
Joined
Nov 25, 2014
Messages
1,476
Location
Germany
Maybe share with others *how* you got it working in the 5150 instead of just telling that you did?
 

Malc

Veteran Member
Joined
Jul 16, 2009
Messages
2,163
Location
UK
Yes, please share, What Bios are you using in the Boot ROM socket of the ISA USB board, Are you actually booting from a Flash drive in the 5150 ?
 

Malc

Veteran Member
Joined
Jul 16, 2009
Messages
2,163
Location
UK
There is an old thread on it here https://forum.vcfed.org/index.php?threads/need-help-when-use-isa-to-usb-card-in-ibm-5160.49356/

I don't have the Chinese card so don't know how well it works now, It may have been updated since then, I have the lo-tech experimental isa - usb card which never went into production and uses the same Chinese driver's, The Boot ROM driver was/is pretty much useless but the DOS driver works fine with my card, I can access any of my USB Flash drives and also spinning hard drives with the use of external power and a USB adapter. It's a bit slow in a PC/XT but better in a 286 >.
 

sorphin

Experienced Member
Joined
Feb 11, 2014
Messages
215
i'm using this card: https://www.aliexpress.com/item/1005003850280403.html (basically the same card as OP)

using the bootrom from the CH375X86 zip file mentioned earlier specifically CH375_8K_v15_NoCtrl_final_working_512MB.BIN and as I said, using it in an eeprom (and did an eprom too) in the U28 socket of the 5150.

Yes, it boots to dos 6.22 (in about 28 seconds from showing Starting MS-DOS).. It also works/accesses fine with the driver (when not using the rom) 2.0A from the zipfile.

FYI, I'm using a 2G USB stick w/ a 512M image i created and dumped onto it... the above mentioned bios has the CHS settings correct for a 512M partition.
 
Last edited:

Malc

Veteran Member
Joined
Jul 16, 2009
Messages
2,163
Location
UK
Thanks, I was hoping there was a new Boot bios out, I tried all the one's in the old thread a long time ago and did get one to boot from a 2Gb flash drive after a lot of hassle but too much hassle and problems with it. I just use the DOS driver which works fine though a bit slow on the PC/XT.

Edit: Can you post a link to the Boot Bios you are using please, I can't seem to find that exact one you mentioned.
 
Last edited:

sorphin

Experienced Member
Joined
Feb 11, 2014
Messages
215
Thanks, I was hoping there was a new Boot bios out, I tried all the one's in the old thread a long time ago and did get one to boot from a 2Gb flash drive after a lot of hassle but too much hassle and problems with it. I just use the DOS driver which works fine though a bit slow on the PC/XT.

Edit: Can you post a link to the Boot Bios you are using please, I can't seem to find that exact one you mentioned.

Attached.
 

Attachments

  • CH375_8K_v15_NoCtrl_final_working_512MB.BIN.zip
    2.3 KB · Views: 17

Malc

Veteran Member
Joined
Jul 16, 2009
Messages
2,163
Location
UK
Attached.
Thanks, I set up a 512Mb Industrial CF card with DOS 6.22 in a USB CF adapter, Flashed the ROM in my ISA-USB card with the binary and it works, My 5160 booted into DOS 6.22, It's Slow but it's working, I will do more testing and see how it goes.
 

Malc

Veteran Member
Joined
Jul 16, 2009
Messages
2,163
Location
UK
Will these work with USB keyboards and Mice, What about external cd-roms or DVD-Roms?
No, Mass storage only, USB Flash drive, hard drive, SD / CF in a USB adapter though YMMV with the Chinese driver's. Google for CH375B and CH376S data sheets.
 
Top