• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Killed a STacy?

ClassicHasClass

Veteran Member
Joined
Mar 22, 2013
Messages
1,572
Location
Sunny So Cal
I found my STacy 2 after thinking it had been lost for some time, but while it could read floppies fine the hard disk was bad and wouldn't come up or be seen by the drive configuration utility. So I figured I'd replace it with a SCSI2SD.

I managed to get it apart and got the SCSI2SD in the hard disk slot, but when I powered it back on it wouldn't see any drives, not even the internal floppy.

I disconnected everything and manually reseated all the connections. This time I got a black screen. I couldn't figure out why until I noticed I had shifted the power board one pin up.

I freaked out, powered it off, put the power board back in the right pin configuration, but it still comes up black. I see a brief flash on the 1, 2 and Battery LEDs when I power it on, and that's all.

I checked the voltage entering the board; it was 16.5V as rated. The 12V and 5V rails appear nominal. I've tried reseating everything again. I have all three pin headers and the green ground from the top case connected. The power board is correctly installed. I pulled the drive cage, floppy drive and HD controller entirely to eliminate them as causes. The RAM/keyboard daughterboard pins are correct. What else should I look at? What might I have fried?
 

ClassicHasClass

Veteran Member
Joined
Mar 22, 2013
Messages
1,572
Location
Sunny So Cal
It looks like, in the position I had it in, it got on a 5v line. I guess that means it could have blown anything downstream. Replacing the motherboard would be a first thought but it may have also gotten onto the RAM/TOS daughterboard. I'm hoping anybody knows before it goes in a box and/or I do an expensive search for spares.

I'm actually really unhappy with myself. The connectors aren't keyed; they'll mate in any position and they're not easy to see when the board is plugged in. But I'm usually so careful about that kind of thing, especially power supplies.
 

rittwage

Veteran Member
Joined
Mar 6, 2012
Messages
883
Location
Augusta, Georgia, USA
That's a bummer the machine lasted this long and was "executed" like that. I'm sure we've all done something like that along the way... I know I have. :(
 

ngtwolf

Veteran Member
Joined
Apr 6, 2018
Messages
972
Location
Los Angeles, CA
Yeah, I try not to touch my Atari ST because every time I have to do anything on it, some chip dies in the process. This obviously was caused by you, but in my experience, most Atari's built during the Tramiel years you need to treat with kid gloves.. I would probably agree that Atari-forums or even Atari-age would be a better place to ask around regarding Atari's, as not that many atari hardware folks on here.
 

Eudimorphodon

Veteran Member
Joined
May 9, 2011
Messages
4,403
Location
Upper Triassic
Hopefully some Atari guru will have good news for you, but unfortunately it sounds like there's a good chance you fried it pretty thoroughly. A best-case scenario probably would have been crossing the 12v feed with a ground and blowing up something on the power board. :(
 

1ST1

Veteran Member
Joined
Oct 21, 2014
Messages
1,255
Location
near frankfurt/m, germany
I think, it is repairable, as it is more or less just a portable version iof a Mega ST. Most chipsets are still available, if you are in the US, you are lucky, because there is Best ELectronics in Sunnyvale. I have no experience with the atari-age forum, but I know there are some real cracks in the atari-forum.com, from time to time I am also present there. I also have a STacy, and an STbook, Falcon, TT, 260-1040, STE, Mega, ... In other words, the scene is still very active.
 

ClassicHasClass

Veteran Member
Joined
Mar 22, 2013
Messages
1,572
Location
Sunny So Cal
I actually asked Best about it, but it's possible I nailed both the motherboard *and* the RAM/TOS board, which would make this an expensive repair. And that assumes I didn't kill the top case at the same time, since it was connected.

It's in a box until I decide if I really care enough to try to rebuild it.
 
Top