• Please review our updated Terms and Rules here

Microsolutions Parallel Port External CDROM drive

kc8eyt

Experienced Member
Joined
Aug 7, 2020
Messages
323
I have a couple of 164550 (4x) external parallel port CD-ROM drives made by Microsolutions. These both work fine on my Monotech NuXT V2.0 motherboard ( https://monotech.fwscart.com/NuXT_v...K_XT-IDE_Multi-IO_SVGA/p6083514_19777986.aspx ). However, on my clone 8MHz Magitronic XT after the CDROM driver loads (BPCDDRV.SYS) I completely lose the keyboard?

Has anyone else run into this issue? The driver states it has found the drive and MSCDEX gives it a drive letter of D:.

Nothing out of the ordinary in the XT clone. Oak VGA card, Media Vision Thunderboard sound card, Monotech floppy controller with 9pin COM port, Lo-Tech XTIDE controller, and a standard 8bit parallel port card. The system has 640K and running DOS 6.22.

XTIDE; D800
Floppy: CE00
Sound: 220, IRQ 5, DMA 1
LPT1: IRQ7, 378
COM1: IRQ4, 3F8
 

kc8eyt

Experienced Member
Joined
Aug 7, 2020
Messages
323
I found the reason for the issue I was having. I was using version 2.13 of the backpack cdrom software. I downgraded to the earliest version I could find (2.06) and now all appears to be working well. At first I thought it might be something to do with 8/16bit code but both my Magitronic system and the Monotech system are running V20 CPUs.

Still at a loss as to why version 2.13 runs on the Monotech motherboard but not the XT clone board. And why the weird keyboard malfunction with it? I did notice that version 2.06 only uses 11K of RAM versus the 21K used by version 2.13. Not an issue on the Monotech since I have UMB space to load drivers, but welcome on the XT clone that only has 640K.
 
Top