• Please review our updated Terms and Rules here

Repairing an M8650YA

Mike_Z

Veteran Member
Joined
Dec 1, 2013
Messages
1,620
Location
Near Milwaukee Wisconsin
Over the summer I picked up an M8650YA board. The past week or so I've been attempting to repair it. Last week I found that the delay line was bad. I tried to repair it, but it was beyond repair. I found that Roland Huisman designed an active replacement. I have ordered parts and boards and am currently waiting for them. In the mean time, I decided to study the operation of the M8650YA. I had a general idea of how it works, but thought that with a better understanding, trouble shooting may be easier. I have gotten through the addressing, the clock, the operation decoder and now I'm looking at the I/O buffers. The TTI and TTO both use 2 DEC 8271 chips. They are parallel/serial shift registers. I found a description in my 1973 maintenance manual. Yet there is no description of the R0 pin #1. I believe that it is a reset for the RC FF's? But what does it do? Set each bit to a 1 or a 0? Then I looked at my schematic and traced the R0's back. They are connected to a bunch of 7474 pin #13, which is an async reset. Could the 8271 R0 that also? Thanks Mike
 

intabits

Experienced Member
Joined
Jan 22, 2019
Messages
145
Location
Melbourne, Australia
The 8271 Reset (RD) appears to be an active low input that (almost certainly) clears the flip-flops to make the outputs go low.
In the M8650, it is derived from the Omnibus INITIALIZE-H signal, which goes high for at least 600ns when the Clear key is pressed, and when the POWER-OK-H signal is negated (?!).
This signal is used to clear all peripheral flags. In the M8650 it clears the shift registers, and the 7474's that you referred to.

Have you seen Steve Lafferty's annotated M8650 schematic?
I've added a few more annotations to it here:-
https://www.vcfed.org/forum/forum/g...h-highlighted-omnibus-and-berg-connector-pins
 

Mike_Z

Veteran Member
Joined
Dec 1, 2013
Messages
1,620
Location
Near Milwaukee Wisconsin
I want to thank you guys for the help. My old brain had forgetten that many of these chips were Signetics. AND that schematic is really neat! I have been attempting to do something like that to my schematics, but have not been as thorough as you have been. I need to print it off and compare it with what I have, Mike
 

Mike_Z

Veteran Member
Joined
Dec 1, 2013
Messages
1,620
Location
Near Milwaukee Wisconsin
Started to looking into the receiver end of this card. The start bit is verified as a true start bit. For some reason I can't see the logic. I'm guessing that the spike FF is used for this. While I was looking around I found some differences between my schematic and Steve's. My drawing is a DEC print with the title M8650-0-1 and the newest date of 7-6-71. A difference that I found is on E04 7474 output pins 6 and 8. My drawing shows both 0 and 1 outputs. The 1 output even has a the circle invert sign, yet both are labeled the same and each has individual wires. So if you don't look closely, I didn't, you would think that one wire has an inverted signal. Steve's drawing must be a later one, but it doesn't have the DC title box or border. I checked my boards and Steve's drawing is correct. Thanks for straightening me out.

But, I'm still having trouble seeing the start bit verification. Thanks for the help, Mike
 

Mike_Z

Veteran Member
Joined
Dec 1, 2013
Messages
1,620
Location
Near Milwaukee Wisconsin
Well..... the delay line was definitely bad. I removed it opened it up. Looks like just an inductor. The core was cracked in half and the leads open. I ordered some of Roland's active delay line circuit boards from OshPark. They came today. I made a mistake regarding the solder mask. I put in the comment section no solder mask, but apparently I needed to check a box. Anyway the board showed up and I had to scrape the mask off the pads and on another one I sanded the mask off entirely. This was the 1st time I have ever dealt with surface mount stuff. Not so easy for an old man with bad eyes and big fingers. Besides I dropped the IC's on the floor and lost them for at least 1/2 hour. Once I got past all this and got the active delay line mounted on the M8650, I tried the M8650 in my PDP8E. I used a short program that reads the SR and sends that to the monitor. Nothing happened. So I warmed up my scope to start looking for the trouble and the monitor started to spit out characters, not the correct ones, but some. I thought maybe I had a cold solder joint on the new delay line card, but that was not it. The longer the computer was on the better the character stream got. Shut the computer down for supper and tried again afterward, the same results. Must have a heat issue some where. I'll try some more tomorrow. Stepping the right direction, Mike
 

tradde

Veteran Member
Joined
Apr 30, 2003
Messages
1,262
Location
Katy, Tx
Glad to know I am not the only clumsy person around nor one with sausage fingers. :)
 

Mike_Z

Veteran Member
Joined
Dec 1, 2013
Messages
1,620
Location
Near Milwaukee Wisconsin
I wasn't always as clumsy as I am now, It must be my advanced age. Could also partly be my poor eyesight. Well, given enough time I can generally accomplish tasks. I started to work on the M8650 receiver. It works just as good as the transmitter, not at all.

First I checked the 2^2, 2^1 and 2^0 FF's. I found that E04 7474 was not working and replaced it. Now I can see the correct frequency's when a key is pressed.

Next I used a short program to check the Rec Flag and then transfer the keyboard byte to the AC.
Code:
0000 6031 KSF skip when buffer is full
0001 5000 JMP wait
0002 6036 KRB read buffer
0003 5000 JMP start over
When I ran this code, it never exited the wait loop, so a skip was never generated. Turns out that the receiver flag FF E48, another 7474 failed. The clear was always high, I could see 9 clock pulses on the clock pin 3 and a ~0.8 mSec low pulse per keystroke on the data pin 2. This low pulse is supposed to block the first 8 pulses and then the Rec Flag will click on the 9th, but Qnot pin 6 never changes. Time order a few 7474 D FF's! After E48 was changed the above program would place the proper keystroke code in the AC. Progress, now back to the transmitter, thanks for the help, Mike
 

Mike_Z

Veteran Member
Joined
Dec 1, 2013
Messages
1,620
Location
Near Milwaukee Wisconsin
This morning I fired up the PDP8E and started to investigate the transmitter of the M8650. For some reason there seems to be a heat related issue. Using a short program to just transmit an SR character to the monitor, it starts out sending 177 Octal. Then after maybe 5 minutes or so, the monitor starts to display a few of the correct SR characters. As the machine warms more, more correct characters show up. Some trouble shooting brought me back to the new active delay line. The proper input signal was there, but the output was reduced voltage. Removed the M8650 and looked at the new CB with a magnifying glass. Didn't see anything that looked bad. I redid my continuity test and that seemed OK. My son, the Buick mechanic, dropped by and I had him look at the board. He found that pin 6 of time delay chip (the output pin) was standing proud of the new circuit board. Maybe just a few thousands of an inch, but enough not to make contact. I suspect that as the CB warmed, the board warped enough for the IC leg to make some contact. I believe the reason that the continuity test worked is that my probe pressure pushed the leg down enough to make contact. Anyway, a little more solder and now the M8650 works. I fired up up OS/8 and everything worked. It is a some faster at 9600 baud rather than 110. I will still keep the 110 baud, because I still like the ASR33 once in a while. One thing I did notice is that when I do a DIR the screen fills very fast and runs over the first files. That was not a problem with the teletype, it was still there on paper. I have to look and see if the OS/8 DIR command has a pause or page, like the old DOS command has. Thanks for the help. Now on to the next project. My Model T has a burnt valve that needs attention. Thanks for the help, Mike
 
Top