• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Trs-80 DosPlus and the SDLTRS emulator (Mac)

Audronic

Experienced Member
Joined
May 23, 2013
Messages
429
Location
Williamstown Victoria Australia
Hi All

I am using DosPlus Model 4 Version which works OK BUT if i try to get an Hard Drive working (with a blank VHD in Hard 1)
It Hangs ?? I have tried the Model 3 Version also and same result.

Has anybody tried DosPlus and Hard drive in an emulator Please That worked.

Yours Ray
 

Gazza

Experienced Member
Joined
Jun 27, 2013
Messages
148
Location
Sydney, OZ
G'day Ray, I had the same probs with trying to get DosPlus IV running on the FreHD and Sdltrs , seems the drivers I have are mapped incorrectly.
I gave them a bit of tweak and they now "seem" to be working OK on both.
Give em a go
cheers
Gazza
 

Attachments

  • RFORMAT2.zip
    2.6 KB · Views: 1

Audronic

Experienced Member
Joined
May 23, 2013
Messages
429
Location
Williamstown Victoria Australia
Hi Gazza

Thanks for the files I will give it a go Tuesday 30-07-2013

Had a try tonight with rformat2 & rigid2/dvr No Go I might have a Faulty dosplus/dsk (dmk).

do you have a Model3 or Model 4 Dosplus Working VHD i could try Please They zip up quite small.

Yours Ray
 
Last edited:

Audronic

Experienced Member
Joined
May 23, 2013
Messages
429
Location
Williamstown Victoria Australia
@Gazza
I Have the Model 4 DosPlus Version working with the Version 2 Files Thanks.

Do you Have the Model 3 Versions of RFormat/cmd and Rigid/dvr Please.

I have NOT tried it with FreHD yet.

I have been working with Newdos and the FreHD its all working except for some support files ( Import/Export/Vhdutl. ) I can Mount 2 x 48.96 MEG. as 2 Volumes Hard4-0 and Hard4-1.

and I thought i would explore DosPlus as it has Hard Drive Support.

Yours Ray
 

Gazza

Experienced Member
Joined
Jun 27, 2013
Messages
148
Location
Sydney, OZ
Hi Ray
Attached are the files for the Model 3 version of DosPlus 3.5. I had the same problem with these as I did with the Model 4 version. Same problem, same fix.
I haven't tried them on the FreHD but they "seem" to be working OK with SDLTRS
As with anything I do the usual disclaimers apply :)
cheers
Gazza
 

Attachments

  • Rigid2-M3.zip
    2.7 KB · Views: 1

Audronic

Experienced Member
Joined
May 23, 2013
Messages
429
Location
Williamstown Victoria Australia
@ Gazza
DosPlus Model 3 Version 3.5.0 Works with FreHD, 3 Partitions 15 Meg on HARD4-0.

Import2 Export2 Vhdutl2 also work ( Must remember the -e Flag )

And it mounts from floppy with config setup and becomes Drive 0.

Observation :- The Dos is a bit Clunky sometimes gets lost even from floppy ( Same in Emulator )

Again Thanks again

Yours Ray
 

Gazza

Experienced Member
Joined
Jun 27, 2013
Messages
148
Location
Sydney, OZ
G'day Ray, glad you got it working. I tried DosPlus 3.5 on the FreHD today, all quick and painless - almost.
I had problems making a bootable floppy from a virtual image - somehow I made a mess of it and got the dir on track 10!!
The second attempt worked perfectly.
Also, can't load MODELA/III from floppy with DosPlus but I managed to work a "swifty" and got it going.
cheers
Gazza
 

Audronic

Experienced Member
Joined
May 23, 2013
Messages
429
Location
Williamstown Victoria Australia
@gazza

Good to hear yours worked, I used the basic program rinit/bas and set it 306 Cly,3,3,0
and let it do its stuff. It took about 3 attempts to get it to work But Finally all OK

I don't have a 4P But if you have the details for ModelA/III I would be interested

Yours Ray
 
Top