• Please review our updated Terms and Rules here

Victor 9k / Sirius 1 Software

I've been using 96TPI DSDD disks. I wrote out a disk earlier today and realized it wrote correctly on one drive but not on another. By that I mean the Victor was able to boot from the same image when I wrote it from my Panasonic drive but not when I wrote it from a Ye-Data drive. I think it has to do with the jumper settings and which speed the drive defaults to. I can chase down what I think is working if you run into troubles.
Yes please.
I am having no luck writing disks with the 55-GFR

I 'think' its the media. I can write out the image to a HD 96 TPI disk, but the victor cant read it (or doesnt want to !), If I put it into DSDD (ie none high density, 80 track, 300rpm) I cant write to any of the disks I have.

Could you tell me your drive details, the speed its writing at and what floppies your using ?
Sorry I didn't get around to this yet. I have a 55-GFR and can test with that. I have a feeling my drive might be jumped differently than yours.
Sorry I didn't get around to this yet. I have a 55-GFR and can test with that. I have a feeling my drive might be jumped differently than yours.
So I have 4 PC drives, a Ye-Data 380, two Panasonic JU-475-3 and JU-475-3, and a Teac 55-GFR. The other 3 drives are writing disks fine. The 55-GFR is not. I can definitely reproduce your issue. I wasn't able to figure out a workaround yet. I'll keep playing with it on the weekend. The drive writes a track and then fluxengine double checks that it can read what was written and 30% of the sectors are coming back with an error.
Gary I have bad news to report. I spent an hour and a half playing with various jumper settings on my 55-GFR and I could not get it to write disks correctly. What's strange is it reads them fine. I was able to break reading by messing with the jumper settings, and then get it back to reading again. Unfortunately none of the settings seemed to help with writing, however. The settings I'm using about disk speed and disk density that work on the other drives don't see to work on the 55-GFR. I'm not sure what's up. Any chance you have a different drive to try?
No luck, but I note that my drive isn't specifically covered.

Reading the fluxengine site it does say that some PC drives wont write pulses that are not PC spec with FE.

Think I might be able to try a YD-380B and report back. Just infuriating that I had a drive that worked and now I can't find it. I did remember what it was though. It was a Mitsubishi MF504C so for anyone writing victor disks it 'seems' like YD-380, JU-475 and MF504C work with Fluxengine & greaseweazle.

And I have found a YD-380B. Hopefully it will work.
Last edited:
Hi Paul,
finally I've got the correct hardware setup and started at the command line, as the error message below was stated. I was using 3M 500kB DS DD Disks (reading above, maybe it is a disk issue?), but without luck. I copied the disk image file into the fluxengine folder.
Thanks for any advice!


C:\Program Files (x86)\Cowlark Technologies\FluxEngine>fluxengine write victor9k --612 -d drive:0 -i "MS-DOS MS-BASIC Ver 2.1.img"
OPTION: 612kB 80-track DSHD GCR
IMG: read 80 tracks, 1 sides, 612 kB total from MS-DOS MS-BASIC Ver 2.1.img
Measuring rotational speed...
Using Greaseweazle GWB0B563A55976C01007009705 on COM6
Rotational period is 166.3ms (360.9rpm)
0.0: writing 166 ms in 62100 bytes
0.0: 199 ms in 74207 bytes
44 raw records, 22 raw sectors; 1.49us clock (671kHz)
sectors: 0.0.0 0.0.1! 0.0.2! 0.0.3! 0.0.4! 0.0.5! 0.0.6 0.0.7 0.0.8! 0.0.9! 0.0.10! 0.0.11! 0.0.12! 0.0.13! 0.0.14? 0.0.15 0.0.16 0.0.17 0.0.18
9216 bytes decoded
bad read
retrying; 5 retries remaining
0.0: writing 166 ms in 62100 bytes
0.0: 199 ms in 74213 bytes
44 raw records, 22 raw sectors; 1.49us clock (672kHz)
sectors: 0.0.0! 0.0.1 0.0.2! 0.0.3! 0.0.4! 0.0.5 0.0.6 0.0.7 0.0.8! 0.0.9! 0.0.10 0.0.11! 0.0.12 0.0.13 0.0.14? 0.0.15 0.0.16 0.0.17 0.0.18
9216 bytes decoded
bad read
retrying; 4 retries remaining
Thats exactly what I am getting.

Using a TEAC FD-55GFR, if I use a HD 1.2MB disk, it can write, but not to a 96tpi DD disk.

Now I think its the drive I am using. I did manage to get it working with my Greaseweazle V4 and a Mitsuibish MF-504C (which I have lost, grrrrr), but I know I and Paul have failed to get it to work with a TEAC FD-55GFR.

I know he can write with a YE Data YD-380 drive and a Panasonic JU-475-3 so it seems some drives don't like writing the Sirius format and indeed on the fluxengine site, it does mention that some drives are optimised to write PC format pulse widths so that might be it.

I should have a YD-380 delivered today and will report if this is what solves it.
Ok, so my new YD-380B drive arrived and after confusion (it wont work unless you use it as drive 1 no matter what you do to the drive select jumpers and there seem to be no others !) I have successfully written the MSDOS image to a 96TPI DDSD disk using fluxengine write victor9k --612 -d drive:1 -i "MS-DOS MS-BASIC Ver 2.1.img"

So greaseweazle and fluxengine at least have some issues writing victor disks with certain drives.

You need to have a look about for a compatible drive.
Last edited:
thanks for the reply.
I now have ordered a sealed and NOS Pack of Sony 1.2 MB HD Floppy Disks. Let's see, where these are getting me. Using a Teac FD 55 as well. I think it's worth a try before I am going to search for another floppy drive.
Will keep you updated! :)
Best regards,
I don't think the HD disks will work in the victor. I can write them, but the victor cant read them. HD disks have a very different magnetic property.

I use 96 tracks per inch double sided double density disks.
Ho hum

Disk written but still won't boot.

Could be multiple reasons, the drive alignment maybe out or something has failed on the sirius itself. Damn. Too many things to fix.
Hi Gary,
that's a pity, sorry for that! I am afraid of facing the same problem at a certain pont of time. (?)
I am now waiting for the HD Disks to arrive, but little chance is given that it will work.
As I am having a recent Mac as well, I will start a new try with the GW & DD disks and the Teac with the Mac in the meantime, maybe it works. :)
Will post updates soon.
regarding a non - Working Sirius 1 I found this thread on a German Forum:

It goes really deep into the hardware, but in the end the machine worked again.

Maybe this helps and is translatable.


These disks work well with the Victor 9000:
Glitchworks used to sell them too, looks like they aren't anymore

Or the Easy Button:

NOS disks written with a Victor 9000 Single-sided drive.

I have Universal 3.7 ROMs too.

I don't have any experience with Greaseweazle, I've got an ApplesauceFDC for this stuff.
Hi Gary,

Is the machine a dual drive unit? If so, does it attempt to boot from the 2nd drive. Was thinking of calling into the museum sometime next week while I'm off work. Can bring a good boot disk and my disk imaging setup (Greaseweazle v4 with a Panasonic JU-475-5). I may also have a spare Sirius floppy controller if needed.

Dave has a good point - the Victor will boot from the 2nd drive in a 2-floppy system.
EDIT: At least for MS-DOS - CP/M-86 1.1 throws an error about A: drive when trying to boot from B:

Also to note, "normal" DSDD media (48tpi rated) should work fine (maybe better) than DSQD (96tpi) media, for reasons:
Last edited: