• Please review our updated Terms and Rules here
  • From now on we will require that a prefix is set for any items in the sales area. We have created regions and locations for this. We also require that you select a delivery option before posting your listing. This will hopefully help us streamline the things that get listed for sales here and help local people better advertise their items, especially for local only sales. New sales rules are also coming, so stay tuned.
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • If you attended VCF East, please take a moment and fill out the survey here. This will help us improve the event for next year.

Wandted Black Card Filler Panels and Case Cover for IBM 5150 16kb-64kb Rev. A

Jimmy

Veteran Member
Joined
Feb 19, 2012
Messages
554
Location
Fort Walton Beach, Fl
I picked up an IBM 5150 PC Rev A. on eBay mainly to get the working power supply as a backup, but when I got it here, it booted up fine and everything seems to work other than I get a 131 post error on the cassettee. It was missing the top case over and all the card filler panels. Was hoping someone would have case cover and some of the original black filler panels for sale or trade.

It seems a shame not to restore it since the motherboard works other than the cassettee error (which I have not idea how to correct, but am starting to research).

Jimmy
 

Jimmy

Veteran Member
Joined
Feb 19, 2012
Messages
554
Location
Fort Walton Beach, Fl
Sorry that's probably not the correct name, they fill in the blank card slots, most of later ones are silver or chrome plated, but the 1st 5150 had black ones as well as the power supply was painted black. You take them out to add an expansion card.

Thanks,

Jimmy
 

Jimmy

Veteran Member
Joined
Feb 19, 2012
Messages
554
Location
Fort Walton Beach, Fl
Modem7:

Thanks for the information, the first link you provided is what allowed me to even realize that this unit was an original Rev. A.

Thanks again,

Jimmy
 

Lorne

Veteran Member
Joined
Jul 27, 2008
Messages
1,164
Location
Chandler, AZ, USA
"It was missing the top case over and all the card filler panels."

And what do you mean by "top case over"?
Do you mean the painted metal case that covers the base unit/mobo/drives??
 

modem7

Veteran Member
Joined
May 29, 2006
Messages
7,784
Location
Melbourne, Australia
And in another thread, a loose power connector appears to have been the cause of the 131 error.

However, in that case, I suspect that:
1. the motherboard was a 64K-256K one; and
2. the minus 5 volts was the voltage lost (part of the cassette circtuitry [chip U1] uses minus 5 volts).

If minus 5 volts is lost to a 16K-64K motherboard, such as yours, the motherboard would appear dead because the RAM on those motherboards also uses minus 5 volts.

http://www.vintage-computer.com/vcforum/showthread.php?25124-IBM-5150-8087-and-POST-131
 

Jimmy

Veteran Member
Joined
Feb 19, 2012
Messages
554
Location
Fort Walton Beach, Fl
Sorry, it is missing the case cover, I said top case cover which I guess was confusing. Other than the 131 post error, it boots up and operates fine. It also had FH floppy disk drive, the floppy controller and cable. I added a monochrome card, set the dip switches for the correct memory, drive and display configuration and it booted right up. Have not idea where I am going to find a case cover for a Rev A.

I have not tried it, but I am going to tap with a screwdriver on the relay to see if it is stuck. Thanks for the link for the previous post.
 
Top