• Please review our updated Terms and Rules here

Wang Advanced Professional Computer - Gotek Issue Switching Disks

nzkgb

New Member
Joined
Jul 9, 2024
Messages
3
I'm trying to get a Gotek working properly on my Wang APC

I can boot fine from the Gotek, as long as I have the disk I want, selected at boot.

Issue

When I switch disks on the Gotek while booted into MSDOS, I get a: Not ready error reading drive A,
If I try to switch back to the boot disk I get the same error

Gotek Setup
I've flashed the Gotek with the latest FlashFloppy Release (FlashFloppy 3.42)

FF.CFG I've set:
interface = ibmpc

The drive select jumper is set to DS0 (this seems to be one difference between Wang and IBM Compatibles needing DS1)

Other things I've tried
I've tried both the connectors before and after the twist in the cable, both work but same result switching disks.
Changing the interface in the FF.CFG - e.g shugart - didn't work as expected

Thoughts
My floppy drive configuration knowledge was pretty much 0 before diving into this issue, from reading around, I'm thinking there's some issue around the drive READY or CHANGE DISK signals.
I'm not sure if the ibm interface setting in Flash Floppy provides a disk RDY signal, only a DISK CHNG on pin 34? - maybe the Wang expects a RDY but not getting it, Looking at the shugart settings, this provides a RDY on pin 34 and DSK CHNG on pin 2

Wondering if anyone has any knowledge around Wang Floppy Disk interface nuances, or if anyone might have some ideas around what I could try?

(Some pictures of the setup)
 

Attachments

  • Gotek.jpg
    Gotek.jpg
    96.4 KB · Views: 3
  • GotekError.jpg
    GotekError.jpg
    146.9 KB · Views: 2
  • GotekSetupCrop.png
    GotekSetupCrop.png
    484.3 KB · Views: 2
I've solved my issue by setting pin34 to nrdy in the FF.cfg file, so I assume the Wang must be expecting a low signal on that pin to Signal Ready.

Here's the settings I've changed from default in my working FF.CFG config, in case anyone comes across this issue:

interface = jc (with jumper closed - or just use the ibmpc value)
pin34 = nrdy
 
Back
Top