• Please review our updated Terms and Rules here

5150 networking recommendations

bettablue

Veteran Member
Joined
Feb 21, 2011
Messages
1,647
Location
Eugene, OR
OK, I gave up. After fiddling with this Inatel LAN adapter for who knows how long, I have to say, we've tried everyrhing we can think of, so me friend and I are going to stop, pull the card drom the computer/expansion unit, and try to find a better replacement. At this time, I'n not in a position to purchase anything at all, because my short term disability ran out and my SSA disabiliety hasn't started just yet.

In the meantime though, I would like recommendations for a decent LAN adapter that will allow my 5150 PC to access my home network. I really don't care to connect the 5150 to the Internet, that's not what this machine is for. But I do want to locate a good working LAN adapter so that when the money does start coming in again, I'm ready.

So, what are your recomendations? Are there some cards out there that are much better than others? Should I be looking for any specific make, and model, long/short etc?

Same goes for a modem. As long as they're compatible in the same system.

Thanks again...

Look for updates.
 

ibmapc

Veteran Member
Joined
Apr 5, 2010
Messages
1,036
Location
Albany, OR USA
I use an Intel Etherexpress 8-16 in my 5155. THIS ONE will also work. Although, that EPAY price is not great. If you look around, you can get them much cheaper. These are 16 bit cards, but will work in an 8 bit slot. Drivers are readily available.

Which card have you been "fiddling with"? What problems are you coming up against? Have you tried the card in the main box vs. the expansion unit? Have you tried it in any other machines?
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
40,766
Location
Pacific Northwest, USA
No specific recommendations, but a hint.

When the 5150 was current, network products usually used either AUI (DA15) 10Base2 (coax); 10BaseT was pretty uncommon. I used 10Base2 and don't really mind losing the coax, terminators, T-fittings and all that went with it--including a missing terminator bringing the whole net down.

But you'll find a lot of inexpensive 8 bit cards that use those interfaces. If you've got a network hub that can take those, fine, but those aren't too common anymore. The good news is that media converters to 10baseT are still fairly inexpensive and, together with one of the older cards, perfectly usable without costing you an arm and a leg or sending you scurrying for drivers that may not exist.

Myself, I use Artisoft AE2/T NICs, which, although they're 16 bit cards, work very well in 8 bit mode (they were made to do that). No funny setup software--all done with switches and jumpers.
 

Stone

10k Member
Joined
Nov 3, 2009
Messages
12,814
Location
South Jersey, USA
You could try Lantastic Z which connects 2 computers via the parallel ports or one of the other products, i.e., Laplink or Interserver/Interlink via DOS.

Alternatively I have an Artisoft AE2C/F AUI/10Base2 card if that's of interest.
 

RWallmow

Veteran Member
Joined
Oct 19, 2006
Messages
1,791
Location
Anoka, MN USA
If you can run Coax, or use an AUI>10BaseT converter, here is a 3Com Etherlink II for not a TERRIBLE price. I also found this WD Chipset card for semi reasonable price, it's Still high for a 25 year old ISA NIC, in my opinion, but not the $100 plus some people try to push them for.

If nothing else I have a SMC card with a WD chipset (same as that WD card I linked) I could maybe trade you for something, then money isn't an issue for you. I have it in my PS/2 Model 25 right now, but I don't use it, and I have been thinking about freeing up the slot for my SCSI card instead. Let me know if you would be interested in trading something for it. I was WANTING to use the MSNET stack with it to map a drive to my network server, but I ran into the problem of MSNET needing a 286 or better, then I started trying to get the packet drivers working, but getting files back and forth onto my PS2 became an issue with a failing floppy drive :-/
 

mbbrutman

Associate Cat Herder
Staff member
Joined
May 3, 2003
Messages
6,281
I use a WD 8003 variant on a PCjr, which is about as incompatible as it should get. Why are you saying it does not work?

What a lot of people fail to realize is that RJ-45 does not necessarily mean it will plug into your switch/hub. There were pre-release standards for twisted pair wiring that are not entirely compatible. The AUI port with an external transceiver works just fine in that situation.
 

RWallmow

Veteran Member
Joined
Oct 19, 2006
Messages
1,791
Location
Anoka, MN USA
You can forget the WD Chipset card -- it doesn't work!
I use a WD 8003 variant on a PCjr, which is about as incompatible as it should get. Why are you saying it does not work?

Yeah, what doesn't work for you? I had the packet driver loaded and it looked like it was working on my PS/2 25, I just was never able to get any other utils like ping, telnet, or ftp over to it before the floppy drive failed to actually test it. I also successfully use one of these cards in my Compaq Portable II with a 286 running the MSNET client just fine. It gave me less trouble than the 3Com EtherLink III cards I usually use. My WD card also worked perfect on twisted pair hooked right up to my modern gigabit network, no link issues or negotiation problems.
 

RWallmow

Veteran Member
Joined
Oct 19, 2006
Messages
1,791
Location
Anoka, MN USA
The card being offered on eBay *DOES NOT WORK*. Read the auction -- it's being sold for parts!!!
Am I missing something? All I saw in the auction was "This item has not been fully tested and is being sold as is." Which is typical of 99% of the vintage PC gear sold on ebay.

And my offer to trade him mine, I would actually guarantee it to work since I have used it, and fully know its working ;-)
 

mbbrutman

Associate Cat Herder
Staff member
Joined
May 3, 2003
Messages
6,281
The card being offered on eBay *DOES NOT WORK*. Read the auction -- it's being sold for parts!!!

Thanks for clearing that up, but your initial wording is what caused the confusion. It could have very easily been interpreted as "WD Chipset cards do not work", not "That particular card does not work."

WD chipset cards do work, and are at the upper end of the performance curve for old Ethernet cards.
 

DOS lives on!!

Veteran Member
Joined
Mar 14, 2011
Messages
2,303
Location
East Tennessee
The card being offered on eBay *DOES NOT WORK*. Read the auction -- it's being sold for parts!!!
That's just what it says in the generic item description for this auction. Those descriptions barely even apply to the item. The seller chose that because he assumed the worst possible scenario of this card's working order since the seller didn't bother to test it.
 

Stone

10k Member
Joined
Nov 3, 2009
Messages
12,814
Location
South Jersey, USA
That's just what it says in the generic item description for this auction. Those descriptions barely even apply to the item. The seller chose that because he assumed the worst possible scenario of this card's working order since the seller didn't bother to test it.
I'm glad you learned how to read sellers' minds. :)

Maybe someone should call them and take them up on their offer regarding their statment: 'If you have any questions or specific testing you would like done please email or call us before bidding. (805) 648-3300'

Then we would all know exactly what this is all about, wouldn't we?
 

MikeS

Veteran Member
Joined
Dec 23, 2005
Messages
7,510
Location
Toronto ON Canada
Am I missing something? All I saw in the auction was "This item has not been fully tested and is being sold as is." Which is typical of 99% of the vintage PC gear sold on ebay.
For parts or not working: An item that does not function as intended and is not fully operational.
I don't know about you guys, but Not fully operational kinda sounds like it's not working; maybe you'll get lucky.
 

bettablue

Veteran Member
Joined
Feb 21, 2011
Messages
1,647
Location
Eugene, OR
The card I'm using is the same as the one on E-Bay. http://www.ebay.com/itm/Intel-Ether...142?pt=LH_DefaultDomain_0&hash=item2c5cf3a40e

Personally, I think the card is bad, maybe static shocked or who knows. Ed and I have done everything that has been provided to me by way of instructions, directions, reading materials galore, even Mbrutemans guide to tcpip. We installed the packet drivers which were sent by Jimmy, which looked like a great solution; at first, but for some reason, we can't even get the card to be recognized by the PC. Of course that could mean that the machine isn't set up to recognize the IRQ, but I have the IRQ on this card set to 3.

Outside of that, I have searched and found downloaded driver installation guides. Intel.com has been a seemongly great resource too. I have gone through as much of the documentation as possible, and what pertaines to DOS. I have to admit, Intel has a lot of information from troubleshooting to downloads and drivers.

Now maybe there is something else I missed.
 

Stone

10k Member
Joined
Nov 3, 2009
Messages
12,814
Location
South Jersey, USA
You didn't get it from the same source as the link you provided, did you? Because the operative message in that sale is:

This piece of history is rare and will be a fine addition to your vintage computer collection. Due to age sold As-Is.

... and we know what that means.









 

RWallmow

Veteran Member
Joined
Oct 19, 2006
Messages
1,791
Location
Anoka, MN USA
The card I'm using is the same as the one on E-Bay. http://www.ebay.com/itm/Intel-Ether...142?pt=LH_DefaultDomain_0&hash=item2c5cf3a40e

Personally, I think the card is bad, maybe static shocked or who knows. Ed and I have done everything that has been provided to me by way of instructions, directions, reading materials galore, even Mbrutemans guide to tcpip. We installed the packet drivers which were sent by Jimmy, which looked like a great solution; at first, but for some reason, we can't even get the card to be recognized by the PC. Of course that could mean that the machine isn't set up to recognize the IRQ, but I have the IRQ on this card set to 3.

Outside of that, I have searched and found downloaded driver installation guides. Intel.com has been a seemongly great resource too. I have gone through as much of the documentation as possible, and what pertaines to DOS. I have to admit, Intel has a lot of information from troubleshooting to downloads and drivers.

Now maybe there is something else I missed.

That card you linked, I don't see jumpers on it, Is there a separate config program that you need to run first to set the card to IRQ3? I have a similar vintage jumper-less 3com EL-III card that MUST be software configured before you can install its drivers (for DOS anyways, it has a PNP windows mode, but that's not applicable to DOS).

EDIT: Also are you sure that card will work in an 8-bit slot? Many people have claimed my EL-III card should work in an 8-bit slot, but I could never get it to install (or detect with its config util), which is why I got the WD cards I use now.

EDIT2: I see reference to a "softset" utility to configure the card, have you done this step?
 

bettablue

Veteran Member
Joined
Feb 21, 2011
Messages
1,647
Location
Eugene, OR
Oh, no... The card I have is the same model, but definitely not from the same source. Mine came from a questionable PS1 that was given to me through posts I make in Craigslist in Vegas. It was eventually stripped and sold/scrappred for parts. When the previous owner gave it to me, he had no clue of the network adapter worked or not. I know the sound card and another card in the system worked, but there was a least one other card that didn't. I don't remember which. I do remember that I recycled the system because too much of it didn't work. So, I will be perfectly OK with the assumption that with this and all of the work we tried and were still not able to get to work, then I'm pretty safe in thinking that the card is bad.

I agree with all of you here though. Why would anyone sell a piece like that if it's not working?? Am I also to assume that there are those out there who will assemble a complete system out of bad parts just for display? It wouldn't surprise me. But then again why would one buy a card like this knowing it was bad?



You didn't get it from the same source as the link you provided, did you? Because the operative message in that sale is:

This piece of history is rare and will be a fine addition to your vintage computer collection. Due to age sold As-Is.

... and we know what that means.









 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
40,766
Location
Pacific Northwest, USA
Thomas, I've seen pulls of bipolar PROMs sold on eBay. Maybe they figure that you want to paint it metallic green and hang it on the wall?

Seriously, I think it's just the appropriate weasel words making it clear that they couldn't test it and therefore warrant its operation. You pays your money and you takes your chances.

How about this one? Cheap, jumpered and NE2000 compatible. The docs claim it's 8-bit or 16-bit.
 
Last edited:

Stone

10k Member
Joined
Nov 3, 2009
Messages
12,814
Location
South Jersey, USA
I agree with all of you here though. Why would anyone sell a piece like that if it's not working?? Am I also to assume that there are those out there who will assemble a complete system out of bad parts just for display? It wouldn't surprise me. But then again why would one buy a card like this knowing it was bad?
I don't know if anyone assembles complete systems made of bad parts but there are definately those who display individual components and these are solely for display purposes so functionality is not relevent to them. I'm getting ready to sell some of my prize 'doorstops' to collectors of this ilk.
 
Top