• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Apple Lisa power supply / PSU whine

mikerofone

Member
Joined
Aug 9, 2020
Messages
42
Location
Switzerland
Hi all,

I've recently managed to get hold of an Apple Lisa 2 in pretty nice condition, including an external 5MB Profile in working condition. I have one issue with it though: The Lisa power supply emits some whine or buzz that seems to modulate based on load. Changing the screen brightness or contrast changes the frequency, as does system activity like starting programs. I've taken some videos that include the sound, and pictures of the PSU in this album: https://photos.app.goo.gl/j34Jd5DA2rBbWwR66

The seller said that all Lisa PSUs are noisy these days, which I can believe given that the age of the units these days. But I am concerned that this might be indicate of an upcoming, preventable failure. The seller is offering to swap the PSU for a different, quieter one, but I'd like to understand the problem better before stepping into action here.
  • Could this be a side effect of aging caps? While the unit was offered as recapped, the capacitors on the PSU seem original (including cracked RIFAs).
  • Since I cannot run the Lisa off the PSU without having it fully inserted in the case, I cannot exactly make out where the noise is coming from. Could it be the marked component in this picture (not mine, forgot to take a good picture when I had mine open)? Is that some sort of regulator?
  • Lisa PSU (not mine) with suspect component marked - Lisa PSU (not mine) with suspect component marked
  • Do you think it's safe to operate the Lisa with that issue present? I see that the pixels on the screen are "dancing" slightly (visible in the video, scanlines are not in perfect horizontal alignment).
  • It's a 120V 1.2Amp PSU running on a 230V->120V step-down converter (product link). Could that be creating line noise that the Lisa amplifies? (Converting the PSU to 230V would rule that out, but that might be a topic for a different thread. ;) )
Thanks for any advice you can give. Happy to provide any additional information that might be helpful!

Cheers
mikerofone
 

NeXT

Veteran Member
Joined
Oct 22, 2008
Messages
6,746
Location
Kamloops, BC, Canada
I would always be suspect if you are saying it was sold recapped and it wasn't when it arrived. I might want to raise a case on that with the seller before digging into the PSU.
It could be coil whine...it could be a dirty PWM for chopping on the main transistor.
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
I have a Lisa 1.2A power supply like yours that is also noisy. I haven't investigated why this is so, but changes to the sound that depend on computer activity are typical. The PSU has worked for hours inside the computer without trouble, but all of the noise makes it a backup for my other PSUs, which are quieter (although my other 1.2A PSU is not 100% silent, either). One day I will investigate what's going on.

Having used my "loud" PSU in a 120V 60Hz country and now in a 240V 50Hz country, I can say with confidence that the audible noise in my PSU has nothing to do with the local line frequency. Additionally, recapping the PSU didn't affect the noise in my case.

The part you've identified is the main switching transistor, which is what pumps a high-frequency alternating current into the adjacent transformer. In a certain sense that's more poetic than precise, it's the "beating heart" of the PSU. It's what's doing the "switching" in a "switching power supply" like this one. Unlike a real heart, though, it's probably not making any noise.

What I've assumed is the problem with my power supply, and what I might assume is wrong with yours, is that the wires or the metal plates within the transformer are buzzing at some frequency relating to that switching current. Transformers work by trading electrical and magnetic energy against each other, and all of that magnetism can wiggle transformer parts that are loose. This is what NeXT meant by "coil whine". If this is what's going on with your device, it's probably not a all that big deal from a safety perspective, but it's probably also somewhat difficult to fix.

Your PSU does not look at all recapped. In my Lisas, recapping does help with "dancing" scan lines, but you may also want your Lisa's video card serviced instead of / in addition to the PSU. I know it's less fashionable these days to recommend a recapping, but I have found recapping the video board to be specifically helpful.
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
PS: You've noticed in your photos that the Lisa has two transformers. The smaller one is for the +5V standby voltage and is not responsible for the sound. We know this because this power supply always operates when the Lisa is plugged in to power, and we don't hear any buzzing until you turn the Lisa on. So the problem must be in the "main" power supply.
 

Hugo Holden

Veteran Member
Joined
Dec 23, 2015
Messages
2,273
Location
Australia
It is a really interesting and not often talked about area, the cause of whine or noises that are emitted from the components in switching supplies.

There are the obvious causes for it as mentioned magnetic materials under the influence of varying magnetic fields and vibrating the adjacent air molecules and acting like a speaker, or even coil turns which have magnetic forces on them when they carry a current and generate a magnetic field interacting with an external field to put forces on the wires.

However, there is another cause for the noises:

It is the Piezo electric effect, of an object changing its physical geometry with applied voltage (this includes capacitors and semiconductor crystals). This physical movement also generates sound and is the Electrostatic version of the Magnetic problem. How common is it ?

Well much more than you might think. Some years ago I built a switching supply devoid of inductors. The mosfets switched a square wave into a bank of capacitors. The mosfets themselves generated noise. The effect is much better observed with a vintage TO-3 transistor. If you set one up as a 100Hz switching supply, with fast rise and fall switching, you can hear the transistors "singing", yes that is right, they generate sound. It is damped a little when they are screwed to a heatsink, but it is still there. Also when film capacitors are rapidly charged and discharged the effect is possible too. I found that epoxy cased transistors were a little quieter than TO-3 types, presumably due to the additional damping from the epoxy. Possibly with large pulsatile track voltage, even a pcb could act like a piezo-electric speaker.

Recently I have been working on a pwm motor speed controller for a lathe, it has a 1kHz pwm rate and it switches full wave pulsed 100Hz DC across the DC brush motor with a large power mosfet. The motor itself of course makes an excellent "speaker" but the board sounds like a small orchestra with a number of the board's components generating sound.
 
Last edited:

mikerofone

Member
Joined
Aug 9, 2020
Messages
42
Location
Switzerland
Thanks for the detailed replies, everyone; I've learned a lot!

I'm glad to hear that the noise likely is only that, noise. While it's a bit annoying, I can well live with it knowing that it's not some component that's screaming in agony. ;)

I will still raise the issue of the PSU not being recapped with the seller. From peeking inside, the video board looked better to me. I've added a picture to the album: https://photos.app.goo.gl/nWnayypo41Gkxfx37 I have recapped some 80s PCs power supplies in the past which had completely failed, so I'm not out of luck if the conversation with the seller doesn't go well (so far, I don't have any reason to believe that's going to happen). But let's hope it doesn't come to that, as my craftsmanship certainly still has room for improvement.

stepleton, since you mentioned using your 120V PSUs in a 230V country now: did you convert the PSUs themselves, or are you using external converters? What I found in the Lisa hardware manual suggests that I only need to change a single jumper wire near the rectifying diodes, but I'm sure that I'd need to use a different fuse and possibly line filter caps for a higher voltage. I'd like to get rid of the external converter once I got the recapping sorted out with the seller.

Again, thanks for all your help! :) I'm already feeling much better about using the Lisa in its current state.

Cheers
mikerofone
 

GiGaBiTe

Veteran Member
Joined
Apr 30, 2015
Messages
2,721
Location
Austin, Texas
If the seller replaced caps, I'm not seeing where. Did the new caps come pre-dusted with vintage dust to keep the vintage look and feel?

Every cap I see looks old. Nichicon doesn't even make the SE series anymore, and hasn't for a very long time. Most of their modern caps have three letter series names like UZW, UPG, etc. Same with Nippon Chemi-Con, the SL series is ancient and I don't think they've had orange sheathed capacitors for decades. The only time I ever see those is in 25+ year old equipment. If you want proof, just look at the solder joints, you'll see some evidence of them being removed and replaced if the seller did anything. But the dust is more than enough to know nothing was done, any competent repair tech is going to clean the PCB and components if they have them out of the machine, and new capacitors don't come pre-dusted.

If you bought the machine from a marketplace with buyer protection, I'd make a stink about it. A cap kit for that machine will easily set you back $40-50, and potentially more if you have to substitute out EOL caps for something else. The seller could have lied about recapping it to sell it for more money, because most people know if old gear like a Lisa isn't recapped, it's going to have issues.
 

NeXT

Veteran Member
Joined
Oct 22, 2008
Messages
6,746
Location
Kamloops, BC, Canada
If you bought the machine from a marketplace with buyer protection, I'd make a stink about it. A cap kit for that machine will easily set you back $40-50, and potentially more if you have to substitute out EOL caps for something else.

Whaaaa? From where?? When I recapped my 1.8A it was less than $20.
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
stepleton, since you mentioned using your 120V PSUs in a 230V country now: did you convert the PSUs themselves, or are you using external converters? What I found in the Lisa hardware manual suggests that I only need to change a single jumper wire near the rectifying diodes, but I'm sure that I'd need to use a different fuse and possibly line filter caps for a higher voltage. I'd like to get rid of the external converter once I got the recapping sorted out with the seller.

I use an external step-down autotransformer. My Lisa stuff includes some printers and some ProFile hard drives that are all 120VAC, and rather than change everything to be at the local line voltage, it's easier to keep the entire ensemble as a tiny bit of North America here in London.

Beware that there are two kinds of Lisa power supplies: the 1.2A Apple PSU from your Lisa 2/5 and the 1.8A DataPower PSU ordinarily found in Lisa 2/10 systems. The process for converting either between 120VAC and 230VAC is different. I haven't attempted it on either kind, so I don't know the specifics, but do make certain that your instructions are for the correct device!
 

mikerofone

Member
Joined
Aug 9, 2020
Messages
42
Location
Switzerland
Thanks for the warning about the different PSU types! I will double check that I have the service manual for the correct PSU before attempting anything.

The seller admitted that they didn't recap, and claim that they "forgot to update the description" from a previous Lisa they sold. Since they are a serial seller of Lisas and have tons of videos of other pristine vintage gear on YouTube, it could be true. I would have haggled more though, if I had known...

That aside, aside from the slightly wobbly image, everything is working pretty well. Should I replace all caps right away as they could start leaking and damaging things? Or is that not a common issue since the caps are old, but super high quality? I think I know the answer, but maybe.... ;)

Cheers mikerofone
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
Well, you certainly should not delay with the RIFAs, particularly since with this design of power supply they could pop off anytime the computer is plugged in. And as long as you have the thing open and on the bench...

It's now been a few years since I recapped my PSUs and I think I do remember one or two of the caps having a little smudge of sauce underneath when I did a shotgun recap, which was the style at the time. It wasn't all of them, but one or two.

At some point your video experience is likely to degrade further --- from my perspective this seems to be a fact of Lisa life. When it does, and assuming it's just more of the wobbles and not a dramatic failure (e.g. complete vertical collapse), the most likely suspects in my experience will be (a) PSU caps (b) video board caps (c) the video board potentiometers (which you can try hitting with some contact cleaner; it might help). You may decide that you'd like to replace the PSU caps now just to spare yourself some hassle isolating the problem later on.

But that is the kind of thing that a mediocre diagnostician like me would say. Talented folks who start off sentences with "if you really want to learn electronics" might advise you to leave the caps alone so that you can try dealing with the whole challenge later. After all, there is no school for learning this stuff quite like an open PSU with hundreds of volts of post-rectifier DC just inches away from your fingertips.
 
Last edited:

GiGaBiTe

Veteran Member
Joined
Apr 30, 2015
Messages
2,721
Location
Austin, Texas
Whaaaa? From where?? When I recapped my 1.8A it was less than $20.

Hah, maybe 10 years ago.

Capacitor prices have skyrocketed, plus shipping, online sales tax and customs import fees if you order from Digikey from the states. I remember the good old days where recapping a power supply was $20, those were good times.

The only way I'm getting $20 recaps these days is ordering sketchy caps from China on Ali Express that were probably dumpster dived in Huaqiangbei or Shenzhen.
 

mikerofone

Member
Joined
Aug 9, 2020
Messages
42
Location
Switzerland
Hey folks,

I appreciate all the input. I've spoken to the seller and they are sending another 1.2A board which they say is quieter, and which has had at least one "RIFA" replaced (they mean the white capacitor right next to the cracked orangey one in this picture). I didn't even notice that this is a capacitor - do these blow up as well? They will include a new orange RIFA and the potentiometers mentioned in stepleton's comment #12, so I can change them myself. I was surprised to hear that the potentiometers could be an issue. I'm familiar with scratchy pots, but I'd have thought that wiggling them and applying some contact-cleaner should fix whatever corrosion might have built over time. It's not as if these were regularly adjusted and thus worn out, I would think. Can you elaborate on what makes them degrade over time?

In speaking to the seller I learned that the two of us have a different philosophy on changing the caps. They only change them when they notice signs of failure, but for something valuable like the Lisa, I'd consider doing a preventative full recap to avoid any corrosive gooey surprises. At the same time, I'm not too convinced of my own desoldering skills that I'd be sure that I'd fix more than I'd break. ;)
The seller did do some long-term testing though, i.e. started the Lisa many times over the course of weeks and let it run for hours to ensure that nothing blows up. So it makes sense that they wouldn't simply go through the ordeal of changing all the caps since they were going to sell it anyways. To their credit, they offered to take it back and refund me, but I declined. :) Even if not recapped, the price seemed OK for a fully working (at least for now) unit with all peripherals and a working ProFile. (Side note: I noticed people rarely mentioning the prices for expensive retro stuff they bought. I'm happy to disclose what I paid, but I wonder whether not documenting these prices permanently in forums like this one is a way to not give people a reason to ask for too much? In the end, it was the most money I every spent on a single computer, be it retro or modern...)

In the end, I'm still happy with my purchase, and I'm happy to have learned that the noise is not a reason to worry. :) I'm hoping that the new PSU will be quieter, and I'll inspect and probably change the caps there as a preventative measure. Thanks again for all your valuable advice!

If I attempt the 120V->230V conversion of my PSU, I'll create a new thread to share how it went.

Cheers
mikerofone
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
The white capacitor is indeed a mains filter capacitor (note X2 class designation on the package; here's what those designations mean) and it accomplishes the same thing as the RIFA caps that you may also find in those locations. I have only known RIFA mains filter capacitors to fail in the manner and frequency that RIFA caps do.

Note that the potentiometers I was referring to were not the ones on the power supply; instead, I mean the six trimmers you find at the top of the video board inside the computer --- so, not in the power supply at all. Here's a thread where someone ran into exactly the sort of problem I was thinking of, although that same bank of trimpots can cause other problems, too, depending on which ones are misbehaving.

Back on the power supply --- it's interesting (maybe) that the two potentiometers there have nothing to do with the rest of the power supply at all: if you look at top right of the schematic, you can see that the bit of circuit connected to pins 1, 3, 2, B, A, and D isn't connected to anything else. The Lisa design just places CRT focus and brightness adjustment there for user convenience and probably safety as well (note that there is a 400V potential between pins 1 and B, and the PSU is already a part of the Lisa designed to contain high voltages). It's a completely separate system.

As you will basically be receiving a replacement power supply, this could be a good opportunity for you to determine whether the video problems you've observed are more likely the fault of the video board or the fault of the power supply. If you notice a substantial change, then the power supply may have been responsible. If you don't notice any change, then the video board could be the main culprit.
 

d5aa96

Experienced Member
Joined
Aug 2, 2016
Messages
52
Location
Chicago
"The seller said that all Lisa PSUs are noisy these days"

This is wrong! The 1.2A Lisa PS was always noisy, and it has nothing to do with the age of the components. Back in the day, the only real fix was to upgrade to the 1.8A "DataPower" power supply that was used in Lisa's with internal widget HD drive. See page 9 of the SUN DYI guide here:
https://www.apple.asimov.net/documentation/applelisa/Lisa_Do-It-Yourself_Guide.pdf

Normally the Profile HD drive is so loud you never hear this PS ringing! ;)

If you want a quiet Lisa get the 1.8A PS, it's better all around.
 

mikerofone

Member
Joined
Aug 9, 2020
Messages
42
Location
Switzerland
I hope y'all had some enjoyable holidays! I realize that a (final?) update to my story here is missing, so here goes.

The seller followed through with sending me a replacement PSU and replacement potentiometers for the video board. I have to give them credit, they have been very pleasant to deal with for the entire transaction including sharing tips and advice after the initial purchase. I'm very happy with how everything went, and I'd hope that so are they. :)
  • The replacement PSU is also a 1.2 amp one, and it is a little quieter. The ringing, as I've learned is to be expected, is still quite audible, but I'm no longer spooked by it. I'm a little surprised that the "Do It Yourself guide" (thanks for linking, d5aa96) mentions that the ringing should only occur if using a 1.2A supply with an internal widget drive, yet I get it too. I only have an external ProFile, so I wouldn't expect the PSU to be too loaded. But I can live with it.
  • The screen no longer wiggles! \o/ Well, it still does it ever so slightly but it's only noticeable if you look for it. I've done back-and-forth tests while I had both PSUs, and there was a clear difference. There is still per-line distortion based on the amount of bright and dark pixels on the line, but it's stable. I assume that's a sign of aged caps somewhere on the video board. Not a big bother, but probably tells me I should do something about it before the caps degrade further and maybe start leaking. So in my case, dancing lines were caused by the PSU. I have added some comparison videos and pictures to the end of https://photos.app.goo.gl/j34Jd5DA2rBbWwR66.
  • Thanks for the thread you linked about the bad potentiometers, stepleton! Now I know what to look for if I ever run into that failure mode with my Lisa. I experienced a stuck-open pot on an NEC MultiSync screen I recently rescued from e-waste, which caused the picture to be way off-center. Just wiggling the pot fixed everything - feel free to watch my boring 1h YouTube video of me trying many wrong things before figuring it out. ;)
  • I have not bothered with attempting the 110V -> 230V conversion, and I'm happy I didn't. The same page in the DIY guide mentions that only the 1.8A supply is multi-voltage, so I'd likely only have ruined something.
Thanks again for your input, everyone! :) Now that everything's working, I'll need to figure out what to do next with the Lisa. I've connected it to my Imagine Writer II and printed some phony report, like an overpaid exec (or, rather, their secretary) would have done in the early 80's. Oh boy, is this thing SLOW! o_O

If you have any suggestions for Lisa Office System software besides Write, Draw etc and Terminal, I'm all ears!

Cheers, and a happy new year!
mikerofone
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
There is not a great deal of archived third-party software for the Lisa Office System.

I wrote a Mandelbrot set viewer that you can use if you're not in a hurry.

Probably the most elaborate third-party Office System application I've seen is the Compugraphic typesetting system (or try here), which you can probably use to print things even more slowly. Here's a manual you can use; I recommend checking out the installation instructions before you try to install the software.

There are a few smaller third-party applications here. They mostly do boring things, like address book and calendar stuff.

But I think the real frontier is in writing your own Office System apps using the Lisa ToolKit, which is something I'd love to take the time to try someday and something I haven't known any Lisa retro enthusiast to have done yet. I'll explain what I understand:

Like the early iPhone, for a good part of the Lisa's life, it wasn't really possible to make software for the Office System. Eventually you could kind-of do it, but only using a library-ish thing called QuickPort. What QuickPort let you do is take a program that was written for running under the Workshop development environment --- so, like a traditional full-screen console application, with total control over screen, keyboard, and mouse --- and run it in a window in the Office System. QuickPort applications (like my Mandelbrot program) don't feel like "real" Lisa applications: the closest analogy in a modern system I can think of is that it seems a bit like running a program in DOSBox.

Anyway, Apple promised one day that they'd offer a framework that would allow you to make "real", fully-integrated Office System applications. Late in the Lisa's lifetime as a distinct product (as opposed to a strangely-shaped Macintosh), they finally did it, releasing the ToolKit. Happily, everything you need to develop ToolKit applications has been archived: we have
And if you'd like to whet your appetite first, you can visit this page to find a DC42 disk image I made after compiling all of the ToolKit example applications. I even made cute custom icons for them :) The page also presents the Clascal (yep, custom OOP Pascal) source code for everything.

SO. That's my suggestion for Office System Software. Write your own!
Will you be the first since maybe 1990 or so to do it?
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
I forgot to add a finding in all of that documentation that characterises the situation around the ToolKit in the waning days of Lisa. Page 23 of the Dialog Building Block documentation (a facility for programming dialogue boxes) is in the format of a memorandum, and the recipient specified in the "To:" field is... "Whoever still cares".

There are several other signs in that document of a facility that was designed with optimism and high hopes, but that then confronted the fading fortunes of the Lisa project. Plans for a resource file format for dialogues had to be shelved, for example; so did various other features.
 

stepleton

Experienced Member
Joined
Jan 1, 2020
Messages
187
Location
London, UK
Oh, and one more PS (and that's it, I promise):

Do check your new PSU for RIFAs. I remember you mentioned that at least one of the RIFAs had been replaced, but if any remain, they are not likely to be long for this world.

Thinking of waiting on it for a while? :)

If one of your RIFAs lets go, which could happen tomorrow or in five years' time, then the capacitor will likely have plenty of time to undergo additional heating as you scramble for a way to power down the machine (since the Lisa has no power switch in the sense of the word that matters here). You will probably wind up yanking out the mains cord, which will take you a little while to accomplish, since you will be surprised by the failure.

The failing RIFA probably won't catch fire (it's designed and certified not to do that, after all), but in addition to emitting noxious smoke, the capacitor will also cook up a hot, foul, tarry liquor in its interior, which I hypothesise forms through the pyrolysis of the materials inside the component. As you're scrambling to yank your Lisa's power cord, this substance will eventually liberate itself from the capacitor's distressed housing and dribble down the power supply's circuit board, working its way into all kinds of nooks and crannies amidst and underneath components. As this material cools, it will dry into a sticky residue that you won't ever be able to clean up entirely.

You will have noticed that your Lisa 2/5 lacks any kind of cooling fan. This means that the power supply gets nice and warm in the course of ordinary operation, and when it does, the residue will also warm and begin to diffuse into the air. This phenomenon is the same operating mechanic behind plug-in air fresheners, and your Lisa will do a fine job of perfuming your room with Essence of RIFA for the following year or so. The smell won't ever quite go away, but eventually it becomes less objectionable.

Remember, the Lisa power supply connects the AC mains to (most? all?) of these capacitors even when the computer is off.

The good news is that the rest of your Lisa probably won't be harmed by the RIFAs failing in this way. But I still wouldn't put off replacing them...
 
Top