• Please review our updated Terms and Rules here

CF to IDE on my Tandy 1000HD

The Lo-Tech XT CF ISA adapter came a couple of days ago. I removed the MFM hard drive and the controller from the Tandy 1000HD. I put in the new XT CF adapter and booted. The XUB came on screen and it looked for the master and slave drives and didn't find anything and then booted from the A: floppy drive into DOS 3.3.

So far so good. I didn't have the CF cards yet so I tried hooking up a few old IDE drives. They were not recognized. I'm going to assume this adapter and EPROM are not setup to use regular hard drives. Have to wait to CF cards to arrive.

The CF cards arrived this morning - 2 Sandisk 1GB cards. I put in one of the cards (not knowing if I had it in 180 degrees backwards or not, there are no markings on the CF slot to tell me which way to place the card) and rebooted. The CF card was identified as the master. Slave was empty. Then it stalled at loading from C>C.

I had read up on this and knew I would have to reformat the drive on this Tandy 1000HD and fix the MBR. I had also read that my DOS 3.3 floppy would not work to fix the MBR. So, I powered up my Gateway 486 with DOS 5.0 and formatted a new 720K disk with a basic DOS 5 system and copied over FDISK.EXE. Then I booted the Tandy 1000HD with this newly created DOS 5.0 disk and ran FDISK /MBR. It finished and I then took out the disk and put in my 3.3 disk and ran FDISK from that DOS 3.3 disk. I wanted to use DOS 3.3 to create partitions and format. But it would not recognize the non-DOS partitioning and I could not delete the partitions or create a new one.

I put the DOS 5.0 disk back in and ran FDISK again. Now I could see the partitions correctly (there was one FAT16 DOS partition). I was able to delete the partition and left the card with no partitions. Then I rebooted into DOS 3.3 and ran FDISK again. I was able to create a primary DOS partition and then it asked to reboot. I rebooted the DOS 3.3 diskette and ran FDISK again. It showed a single DOS partition of 32MB as active. I quit FDISK and ran "format c: /s". It formatted the newly partitioned CF card, after which I created a \DOS partition and coipied over all the files from the DOS 3.3 floppy. I got a directory of the C: drive to verify. Then I shutdown.

I powered on the Tandy 1000HD without a floppy in drive A: It found the new CF card and booted into DOS 3.3. Yeah! I did it. I now have a working DOS 3.3 "hard drive" again.

Next, I will use FDISK to create an Extended Partition and use up as much of the CF card as I can for Logical Partitions from D: to Z: I won't get the full 1GB but about 720MB.

Thank you to everyone who gave me tips on getting this CF card for the Tandy 1000HD. I'll miss the noisey MFM drive but this is a good solution - and a hell of a lot of space for early DOS games and applicatons.

I did a YouTube video a while back on using a teeny tiny little boot manager from BTTR software to multi-boot my Tandy 1000; if you have any interest in being able to switch between different DOS versions it's worth a look. I use it to switch between Tandy 3.3 and PC-DOS 7 on my machine and it works well; I set it up so the two versions have their own C: drives (3.3's is the normal 30MB, PC-DOS'es is huge), they can both reach a 32MB D: drive in the extended partition to share data, and the rest is cut up into big partitions just for PC-DOS 7. (I hardly ever boot DOS 3, it's just there in case I want to test something.)
Thank you @Eudimorphodon , I will check that out. I think I will probably keep this Tandy 1000HD with DOS 3.3. But I may play with other DOS versions on one of my other PC's. I do multi-booting all the time on my Linux boxes. Might be fun to do it with different DOS versions. I also have System Commander on a couple of my 486's, multi-booting DOS, Win95 and OS/2.

I have this Leading Edge Model D that I have never been able to run with a MFM Hard Drive, and the 5.25" floppy's also don't work. I decided to try this Lo-Tech XT CF adapter to see if it would also work on this Model D. I plugged it in and it did come on screen but it did not find the CF card and it crashed.

I read that the RTC on this computer uses the same address as the XTIDE and that it could be disabled to allow the XTIDE to work. I looked up the motherboard diagram and changed the pins for the RTC to disable it. Then I tried it again. It worked! The CF was recognized this time. I put in a 3.5" floppy drive I recently picked up and booted a DOS 5.0 floppy. Then I ran fdisk and removed the partitions and setup a new DOS partition. Then I ran "fdisk /MBR" and then I formatted it and added DOS 5. Then I took out the floppy disk and rebooted. It worked! The CF card booted DOS 5.0.

But this is the only XTIDE adapter I have so I will need to pick up another one before I can finish setting up this Model D. One mistake I made with the Tandy 1000HD is that I ordered the seperate bracket that is supposed to fit into a second port next to the ISA card slot. I had forgot that I previously put in a Serial/Par card and the Tandy 1000HD only has three slots. Now they are all full (RAM card, Serial/Par card, and XT CF card). I have nowhere to put the bracket for the CF card. So, I will purchase a card that has the CF port integrated with the XTIDE interface so I can use only the one slot in the Tandy 1000HD. Then I'll take this two slot version and install it in the Model D. I will then have two PC/XT clones working with CF "hard drives".

I was successful with the Tandy 1000HD with the newly arrived "XT-CF-lite rev.2". I removed the XT-CF card with the seperate bracket and placed the same CF card from that adapter into the new XT-CF-lite card and put it in the same slot. Then I booted and it works fine. I now have this 1000HD with the CF Hard Drive and it only takes up the single slot and I don't have to hang the CF card attached to the ribbon out of the back. This is exactly what I wanted. So, success.

Unfortunately I had some issues with the ISA XT CF adapter rev.3 plus CF Bracket Adapter I removed from the Tandy 1000HD and put into the Model D. More on that in another thread, in a few minutes.

Here: https://forum.vcfed.org/index.php?threads/burned-traces-and-label-on-isa-xt-cf-adapter.1240178/

Last edited: