• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Imsai 8080 power supply problem

valley8080

New Member
Joined
Dec 15, 2010
Messages
1
I received a working IMSAI 8080 recently but after unpacking it found it did not work. Checked main board voltages, even removed all boards, including front panel, and found voltages on the main board were +3v, +12v, and -23v. Power supply is a PS28 with both 95K caps in place. Nothing visually wrong in the PS section. Scope traces at the transformer secondary may show some clipping. Looks like there is a DC bias of around -7v (add this to each voltage and they are close to the published spec). House wiring is grounded (checked this). Scope traces at MB looks smooth (just off). Any ideas?
 

MikeS

Veteran Member
Joined
Dec 23, 2005
Messages
7,478
Location
Toronto ON Canada
I received a working IMSAI 8080 recently but after unpacking it found it did not work. Checked main board voltages, even removed all boards, including front panel, and found voltages on the main board were +3v, +12v, and -23v. Power supply is a PS28 with both 95K caps in place. Nothing visually wrong in the PS section. Scope traces at the transformer secondary may show some clipping. Looks like there is a DC bias of around -7v (add this to each voltage and they are close to the published spec). House wiring is grounded (checked this). Scope traces at MB looks smooth (just off). Any ideas?
House wiring ground shouldn't be relevant but I'd sure check the ground connections within the PS; what do you measure across each of the caps?
 

Dwight Elvey

Veteran Member
Joined
Jun 21, 2003
Messages
4,736
Location
Santa Cruz
Hi
Sounds like you do not have a ground connection in the right
place. I suspect that the power supplies ground is not connected
to the point you were using as ground.
Dwight
 

Erik

Site Administrator
Staff member
Joined
Apr 27, 2003
Messages
3,592
Location
San Jose, CA
Is there an update to the status of this box? Have you made any progress?
 
Top