• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Looking for Franklin Ace 1000 ROM images

misterblack

Experienced Member
Joined
Jul 20, 2017
Messages
225
Location
Portland, Oregon, USA
So I was working on my (Working) ACE 1000 and I decided to clean the mouse poop off the motherboard. In the process, I removed the ROMs and went to read them all in.... Sadly, in the process, I accidentally wrote to the ROM in G7 before reading it out. One would think it wouldn't do anything, right? Well I did a test with the G8 ROM where I loaded a different ROM and hit write -- it errored out. But then when I loaded the correct ROM into the buffer, I did a verify and the first byte was changed! So I am assuming the first byte of the G7 ROM was changed as well..... and this happened before I read it out and saved it, so I just don't know what it should be.

It is labelled "G7 v2.0 1331404" and is the ROM for E000h.

Does anyone have a copy of the ROM images (specifically of the E0xx v2.0 ROM) I'll need to replace this PROM with a EPROM ......

Also if you have an Ace 1000 with the 2.0 ROM in that socket and you go into machine language monitor, can you show me first few bytes of E000 holds? I can probably hex edit the file I made to make it correct again.

At this point, my machine no longer boots -- just stops at the garbage screen at power-up. It may not be related to the ROMs as the mouse poop has caused some corrosion on some of the other chips and me disturbing those chips might have screwed things up. I may end up trying new chips in those sockets just to see if that helps as they are all normal 74LS logic stuff.

Confirming what E000 ROM has it in would be the best -- but also if you pull the E000 and D800 ROM from the machine I'm curious what that does to the boot sequence. Total stoppage or a crash?

Thanks!
 

misterblack

Experienced Member
Joined
Jul 20, 2017
Messages
225
Location
Portland, Oregon, USA
Hey there all -- so update. I figured out that just the first byte has been changed on the PROMs -- as even after programming it's normal for 1 bits to be able to changed to 0 bits. I booted up an Apple II+ emulator (in MAME) and noticed that the E0 and D8 ROM looked identical between the ACE 1000 and the II+. (Sneaky, I guess they copied pretty much everything!)

So I fixed the first byte and yep, the ROMs are good now!

So I've uploaded the Franklin ACE ROM files to Internet Archive since it seems not one out there has ever done this:

https://archive.org/details/franklinace1000roms

These are the files in the ZIP file:

D0 G10 v2.0.bin
D8 G8 v2.0 1331405.bin
E0 G7 v2.0 1331404.bin
E8 G5 v2.0 1331403.bin
F0 G3 v2.0 1331402.bin
F8 G2 v2.2.bin

Unlike the real II+ the ACE uses 2716 EPROMS. Excellent as I was easily able to flash a new one once I fixed the bytes.

I did not rip the character ROM yet as it's a 2532 EPROM and the reader I had handy can't read it .. but I'll do that once I get my vintage programmer up and running. It's different than the II+ character ROM (double the size) since the Franklin Ace 1000 has lower case.

Anyway hopefully someone might find the ROM files useful if they are ever working on a Franklin ACE 1000. Oh --- I also got them working in MAME -- if anyone is interested in that. Just the lowercase part is missing.
 

cryu

New Member
Joined
Apr 13, 2021
Messages
7
Hello Adrian,

Thanks for dumping the ACE 1000 EPROMs. F8 on my 1000 was replaced with a modified ][+ image, so your dump came in very handy.

I did not rip the character ROM yet as it's a 2532 EPROM and the reader I had handy can't read it .. but I'll do that once I get my vintage programmer up and running. It's different than the II+ character ROM (double the size) since the Franklin Ace 1000 has lower case.

I have a 2532-2732 adapter, and dumped the ROM. It's attached.

Thanks again!
 

Attachments

  • ace1000-color-2532.zip
    1.7 KB · Views: 1

animekenji

Experienced Member
Joined
Nov 10, 2005
Messages
169
Didn't Franklin get into trouble for directly ripping Apple's ROMs? The Ace 1000 was a II+ clone. Shouldn't they be the same?
 
Last edited:

cryu

New Member
Joined
Apr 13, 2021
Messages
7
The ROMs are a bit different:

Code:
f6244f9f0dd7771ad6c838945ece0df7 D0 G10 v2.0.bin
638fdf34a9ab40ea1fa62635cc2ac255 D8 G8 v2.0 1331405.bin
6a024faa13e6fb7abd6d7d733036bac5 E0 G7 v2.0 1331404.bin
56d9bb6730735a3b2bbcc75d1da7a8de E8 G5 v2.0 1331403.bin
cb63c41c5e72b5fda54feb5490efdefb F0 G3 v2.0 1331402.bin
e7683a268b56dbf6e39642329aac05b4 F8 G2 v2.2.bin

... versus:

Code:
89ca5cd551ffad9a557652a97dcb6627 341-0011 - D000 - 2716.bin
42333f24cd6e70696b212b042f3166aa 341-0012 - D800 - 2716.bin
5de50bebc41e59ae4eb27be4c24b6814 341-0013 - E000 - 2716.bin
56d9bb6730735a3b2bbcc75d1da7a8de 341-0014 - E800 - 2716.bin
cb63c41c5e72b5fda54feb5490efdefb 341-0015 - F000 - 2716.bin
8925b695ae0177dd3919dbea2f2f202b 341-0020 - F800 - 2716.bin

... as well as the character ROM having lower-case characters.

The hardware is 98% identical to the ][+ (the main difference being the colorburst generator), and ][+ ROMs work fine in the ACE1000. It was apparently common to replace F8 with its Apple counterpart to placate software that looked for the Apple boot text.
 

BobApplegate

Experienced Member
Joined
Feb 23, 2004
Messages
117
Location
Medford, NJ
FWIW I was a software engineer at Franklin from 1982-1984 and worked on the ACE-100, 1X00, etc. The EPROM contents changed fairly often so what is the "right" image can vary a lot, and there were different kinds of motherboards that used totally different EPROMs. Most of the ROM images should be fine, but if you've got a "softboot" board then you need a softboot EPROM.

Bob
 

cryu

New Member
Joined
Apr 13, 2021
Messages
7
Hello Bob,

Wow, I have a *lot* of questions about the 1000 and various boards. There doesn't seem to be much documentation around anymore, so it's wonderful to find someone that was at Franklin back then.

Both of my machines are non-softboot boards, serial numbers in the low five digits. One has the color board, the other has the capacitor/resistor/choke wired in with a few traces cut.

Do you remember anything about hardware design decisions? I'm particularly interested in understanding why the Franklin FDC has so much more TTL on the board than the Apple FDC, and why the Apple FDC fails in exciting ways in a 1000.

Cheers,

-- Chris
 

BobApplegate

Experienced Member
Joined
Feb 23, 2004
Messages
117
Location
Medford, NJ
Two replies in one....

There were several versions of the keyboard and different layouts of the keyboard so there were at least two variations in the keyboard EPROM. This weekend I can look to see what working keyboards I have and see about grabbing an image.

As to the disk controller, the hardware guys were probably trying to work around Apple designs in different ways. Franklin really did try to make compatible machines that were designed differently. I can ask the guy who handled the disk design issues to see if he has a better explanation. I'm not aware of the Apple disk controller not working in a Franklin. I seem to remember using one in one of my Franklins about a year ago so I could use the drives with the DB connectors on them.
 

BobApplegate

Experienced Member
Joined
Feb 23, 2004
Messages
117
Location
Medford, NJ
The keyboard layout are basically the same, but some had WordStar keys. A few of the keyboards I tested both with and without those keys on the keycaps still had the functionality. There are at least two different circuit boards but I don't know if there are differences in the key mapping. Never got into reverse engineering the the keyboard controller.

Bob
 

VERAULT

Veteran Member
Joined
Jan 30, 2012
Messages
5,093
Location
Connecticut, USA
Understood, let me know if you need info from my board , or vice versa. Id be curious which keyboards we both have. I have very little experience with the Franklin Ace 1000, But I have worked on a few dozen Apple II plus machines.
 

BobApplegate

Experienced Member
Joined
Feb 23, 2004
Messages
117
Location
Medford, NJ
I've got at least seven Franklin keyboards in the basement but only two in a place where I can see the boards themselves. The older style has edge connector pins that Franklin made an adapter for that plugs into the edge connector, then has a standard Apple 16 pin DIP connector which goes to the mobo. This board has two 40 pin sockets on it, one populated with an embedded processsor. There is an EPROM with the code. I suspect this was the first round of a generic keyboard with Franklin specific code.

The other one has a completely different layout and has a 16 pin DIP socket for connection to the mobo, one processor, no other 40 pin socket, and an EPROM.

I pull one keyboard out at a time to wash down, replace the foam, test, and then either put into a waiting machine or put into the "good" pile. I ended up building an Arduino based test tool to help test keyboards after a rebuild.

Bob
 

BobApplegate

Experienced Member
Joined
Feb 23, 2004
Messages
117
Location
Medford, NJ
I looked at 6 of the 7 keyboards in my possession and found two different circuit boards, but variations in how the common ones were populated.

Two have two 40 pin IC sockets, only one populated with the 8048 processor. The 8048 can run with either internal or external ROM. Both of the external ROMs have the ID "191" on them. I forgot to look at the chip type.

The other four fall into two population types:

Three do not have an external EPROM so they are running code in the 8048.

One, which is like yours, has an external EPROM. Unfortunately the EPROM is soldered in and my note on the board says it is non-functional. Who knows, maybe replacing a few chips will fix it. Since the EPROM is soldered I would have to extract it first before reading the code. I'm about to leave on vacation so this won't happen for a few weeks.

BTW can you read the label on the EPROM?

Another BTW. As far as I know, Franklin bought the keyboards ready to insert into our cases. Nobody from Engineering was ever involved with the code nor hardware design. I suspect the VP of Engineering (Dave McWherter) advised our contracts people about exactly what keycodes should be returned for each key but nothing beyond that.

Bob
 
Last edited:

VERAULT

Veteran Member
Joined
Jan 30, 2012
Messages
5,093
Location
Connecticut, USA
Yes while testing the kb i desoldered and socketed everything on the kb. I will take a look at the label when i can.

edit: The sticker says "348"
 
Last edited:

VERAULT

Veteran Member
Joined
Jan 30, 2012
Messages
5,093
Location
Connecticut, USA
I just tried replacing the P8035L controller on the pcb and now The only difference is the caps lock light stays on. Pressing keys does nothing.
The long and short is the owner of this machine put the keyboard ribbon cable in backwards and fried a couple passives(that's all we saw originally) I have replaced a couple bad TTL logic chip and I still cant get the board going. Everything seems fine, only thing left is the Eprom.
 

cryu

New Member
Joined
Apr 13, 2021
Messages
7
One of my ACE1000s has a keyboard with an EPROM. I've desoldered it and read it in; the image is attached.

Note: the original EPROM is an Intel 2758. It appears to be a single-voltage 2708, with a pinout matching the 2716 minus A10 (pin 19). I grounded pin 19 and read it as a 2716, so the resulting ROM dump is doubled. You should be able to burn it to a 2716 as-is, as pin 19 is grounded on the keyboard PCB.
 

Attachments

  • keyboard-ace1000-231-2758.zip
    911 bytes · Views: 1

cryu

New Member
Joined
Apr 13, 2021
Messages
7
Addendum: as the filename implies, the label on the EPROM says "231". I burned the image onto a 27C32 (quadrupling the image to account for the larger size), put it into the keyboard, and it works fine.
 
Top