• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

Televideo Personal Terminal

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
I had received a Televideo Personal Terminal which was dead. With an ohmmeter, it measured no continuity across the AC line but the fuse was good. I thought I had an open power transformer but then I was looking at other Televideo schematics and see it has a switch for 110/220 which puts the two primary windings in series for 220v or parallel for 110v. I verified it was set for 110v. I then realized both windings would have to be open which was highly unlikely. I traced the
primary circuit and found the open was in the 110/220 switch. What had happened was the screws mounting the switch were loose which allowed the switch to slide. When I tightened the screws, power was restored !! I'm a noob when it comes to using this forum but I think I've attached a picture of my Compupro system running Wordstar on this terminal. It has a very slight 60hz crawl travelling down the screen. In normal NTSC television displays, if there is a crawl it normally moves up the screen because the vertical scan rate is 59.94hz. This vertical rate must be higher than 60? Sorry, it's late and my brain likes to wander. A picture "might" be attached. Fun stuff !!

Larry G

televideo.jpg
 

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
38,877
Location
Pacific Northwest, USA
Unlike NTSC TV receivers, the vertical (and horizontal) scan frequencies aren't locked to anything in particular. I wonder if you're simply not seeing 60 Hz "hum bars".
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
> Unlike NTSC TV receivers, the vertical (and horizontal) scan frequencies aren't locked to anything in particular.

Yes, that would explain since it's un-synchronized, the travel could be random up or down. Another thought occurred, if the problem was the power supply, because of full-wave rectification the hum would be two bars per screen (120hz) but I only see one so it's not the power supply but an AC leakage like bad grounding of signal, etc. I wonder if my serial cable to the terminal needs more ground pins connected? It's a home-wired cable (not by me) that lists the cables that are connected: 2,3,4,5,7,8.

Aha !!! The ground shells show no continuity to each other. That's the culprit !! My brain is keeping me awake, now I'm very late for bed ...

PS - this screen is much smaller than my laptop terminal but it sure looks authentic !!

Larry G
 

g4ugm

Veteran Member
Joined
Feb 22, 2011
Messages
2,719
Location
NorthWest England (East Pondia)
I have one of these as well. I used to use it to talk to Hercules but the SUN box I was using as a terminal server has died... I must say they look nice but the keyboard is virgeing on "Horrid". I think I also have some scans of manuals pages some one sent me ages ago, if you need any info.,
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
After a good nights sleep, I realized I'm still thinking in terms of analog audio/video when
it comes to floating hum bars in the display. A serial terminal cable is digital so would not
create such. If you notice in my picture, the terminal was sitting on top of the CompuPro cpu.
Simply moving the terminal off to the side removed the hum bar. The CompuPro cpu power supply
creates a monster 60hz magnetic field. The external 8" floppy drive has a short cable so is
designed to sit on top of the cpu. I have it off to the rear so I can access the cards.
No wonder those are both encased in metal !! I suppose I
shouldn't have my floppy disks close to the beast? It takes a high frequency bias to erase media
so maybe doesn't matter unless left on for a long time? I also have my hard drive in an external
case off to the side for the same reason. Eventually I'll assemble and organize it for a nice photo shoot.
Kind of like a family picture :)

>Perhaps you could consider augmenting the information on the Terminals wiki:
>http://terminals.classiccmp.org/wiki...sonal_Terminal with a few pictures?

I'll check into it.


>I must say they look nice but the keyboard is virgeing on "Horrid". I think I also have some
>scans of manuals pages some one sent me ages ago, if you need any info.,

G4UGM, I would be interested in the manual, I couldn't find anything online. Gmail me at larrygr510.
Yes, my laptop as a terminal is much easier to use and I can also use a full usb keyboard.
Laptop keyboards are just as 'horrid' :)

Larry G
 

NeXT

Veteran Member
Joined
Oct 22, 2008
Messages
6,748
Location
Kamloops, BC, Canada
I got one of these as well and it's mentioned in my blog. You can switch the screen between 50 and 60hz through the menus. By chance, what terminal mode are you running in? I can't seem to get proper formatting in the standard ANSI/VT100/Televideo configurations.
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
I'll let you know the settings I'm using when I get home tonight. I barely got a chance to use the thing so far. I read your blog, informative. I didn't even know one 25 pin port was terminal and the other printer. I discovered the one closest to the back worked so must be the terminal :). They aren't even labeled !! Maybe we have a lead on a manual now.
One of your pix shows the 110/220 slide switch I was talking about in this thread that came loose. You mentioned in your blog the print function. My question would be what does this print FROM?
Is it sending character output to the printer like a teletype? Anything sent to the crt just gets routed to the printer port? Dang, I also have a serial/parallel converter I can use to send it to a parallel dot matrix printer. I still have one !! Actually I also have an Apple ImageWriter printer that is serial IIRC. All kinds of possibilities ...

Larry G
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
>By chance, what terminal mode are you running in?

under COMM:
The communications itself is set to the standard 9600 8N1,
MODE=FDX ;is this what you're looking for?
PROTCL=DIR

under MISC:
EDIT=LOCAL
RETURN=CR ;I changed to this to prevent double-spaced lines
SCROLL=ON
EXIT=START ;whatever that means?

WordStar is set to Televideo 912/920

Hope this helps,

Larry G
 

new_castle_j

Experienced Member
Joined
Dec 3, 2011
Messages
269
Location
Texas, USA
Well now, that's some gorgeous green phosphor! I agree that the keyboard is awkward for a programmer or secretary to use, but this one is the plaything of business executives. Tiny and compact, looks nice on the corner of your desk, after the programmers put together a nice database with menu system, all the executive has to do is peck a few keys with his pistol finger and dazzle his friends before heading off to the golf course.
 

g4ugm

Veteran Member
Joined
Feb 22, 2011
Messages
2,719
Location
NorthWest England (East Pondia)
There are two models of Tele Video that look (almost) exactly the same. The Personal Terminal (PT) and I think the Personal Terminal VT. (PTvt).

The PT does a very cut down version of the TeleVideo 900 codes. I ended up producing a very cut down Curses Config file for it which is probably lost as it was on my SUN box and its disk has died. The PTvt is ANSI compatible.

I have the Personal Terminal but sadly it came with paper manual for the PTvt but I haven't scanned it. I have some scans of some pages for the PT manual some one sent me that cover the escape codes.. I will see if I can fish them out and make them into a PDF file.
 

NeXT

Veteran Member
Joined
Oct 22, 2008
Messages
6,748
Location
Kamloops, BC, Canada
You mentioned in your blog the print function. My question would be what does this print FROM?
Is it sending character output to the printer like a teletype? Anything sent to the crt just gets routed to the printer port?
I have no idea. Like a lot of the features on the terminal I couldn't get it to work.
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
>My question would be what does this print FROM?

>If you look in the escape codes I posted there ones to turn printing on and off and also print the screen.

So I was investigating the print function and got the idea to connect the printer port (port closer to the front) to my laptop serial running ProComm
as a pseudo printer. Sure enough, pressing CTRL PRINT printed the screen !! I realized the print function was associated to the CTRL key by the triangle symbol. I've
attached a better picture showing the keyboard. CTRL CLEAR clears the screen. The other CTRL functions just print some ascii chars or locks up.

Larry G

televideo.jpg
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
>Sure enough, pressing CTRL PRINT printed the screen !!

I'm trying to go to bed but my brain keeps thinking. This means it has some internal buffer memory ...

Larry G
 

NeXT

Veteran Member
Joined
Oct 22, 2008
Messages
6,748
Location
Kamloops, BC, Canada
Would you be able to do me a favor?
Open your terminal up again and look at the main PCB. Does yours have a giant space left of the two keyboard connectors taking up a quarter of the board that is unpopulated? Should be surrounded by a white square.
 

retrogear

Veteran Member
Joined
Jan 29, 2014
Messages
1,012
Location
Minnesota
>Would you be able to do me a favor?
>Open your terminal up again and look at the main PCB. Does yours have a giant space left of the two keyboard connectors taking up a quarter of the board that is unpopulated? Should be surrounded by a white square.

That section is empty on mine. Pictures attached. What are you looking for?

Larry G

Televideo_crt.jpgTelevideo_board.jpg
 

NeXT

Veteran Member
Joined
Oct 22, 2008
Messages
6,748
Location
Kamloops, BC, Canada
Thanks for checking. How very interesting.

I noticed the terminals had various modem-like controls and features like a phonebook, RJ11 jacks and a dialing control but I've never figured out how that worked. pressing DIAL, entering a number and pressing enter did nothing. I was curious if there was actually a modem inside it at all and the unpopulated area raised my suspicions when I was inside my terminal cleaning it.
Then again, among the missing components are two crystals. I don't seem to recall a modem needing THAT much quartz.
 
Last edited:
Top