• Please review our updated Terms and Rules here

WANTED: Software for Unimation Puma 560 robot.

NoMoreSleep

Member
Joined
Feb 23, 2010
Messages
21
Location
Chicago, Illinois
@Ariel:

Hi,

when I look at your pictures, it looks like you have a mk1 controller.
Just for your info: since these units are pretty old, you might want to check all lytic caps for the proper values since these tend to fade over time (10 years). Another issue is the status of the pot / encoders. Usually the pots wear over time so that the 'ready position' changes.
 

NoMoreSleep

Member
Joined
Feb 23, 2010
Messages
21
Location
Chicago, Illinois
@Electrodude:

Hi! If the batteries on the memory card are actual 1.5V batteries, you have a problem. As far as I remember, the buffer batteries are either lithium or mercury cells. If you have access to the schematics, you should see what kind they are. The memory card will not work, if these are missing / dead.
 

NoMoreSleep

Member
Joined
Feb 23, 2010
Messages
21
Location
Chicago, Illinois
Can you make a picture (good quality) of the card(s)? There were different memory boards, some with AAA-size batteries, some with button shaped batteries. You need to know the exact part no. Do you have any kind of documentation or software for your system?

I am currently trying to get user manual, schematics and software for 56x and 76x systems.
 

Electrodude

Member
Joined
Dec 13, 2009
Messages
17
OK, I will try to get some pictures and the number on the board as soon as I can. As far as software, I was given several disk but I think they are just programs that was written for the robot, not any software. I will look at the disk again and see if anything jumps out as something other than a user program.

Thanks
 

NoMoreSleep

Member
Joined
Feb 23, 2010
Messages
21
Location
Chicago, Illinois
Something like 'VALI.I.560C' or 'VAL2POT.56X' would indicate that you have a system disk. Stuff like 'test.pg', 'test.lc' or 'test.v2' are user programs / locations / combination of both.
 

PICKERMAN

New Member
Joined
Mar 26, 2010
Messages
2
I just purchased a complete puma 762mark lll robot. I have no idea why I bought it. I want to turn it, right away. Any info on what it is worth or what I could sell it for other then scrap. Thing is huge. If anything can you give me a value, It will be on ebay soon, Thanks if interested call Dave (810) 560-0296. I would appreciate any help.
 

PICKERMAN

New Member
Joined
Mar 26, 2010
Messages
2
I just purchased a complete puma 762mark lll robot. I have no idea why I bought it. I want to turn it, right away. Any info on what it is worth or what I could sell it for other then scrap. Thing is huge. If anything can you give me a value, It will be on ebay soon, Thanks if interested call Dave (810) 560-0296. I would appreciate any help.
 

Electrodude

Member
Joined
Dec 13, 2009
Messages
17
Memory Board

Memory Board

I finally got a chance to look at the cmos memory board, and its a 1816CMOS D4-10399 Rev 1. It looks like it originally had a couple AAA batteries mounted on the board, but it has been modified with two 1.2V Nicad batteries attached remotely. They are dead!
 

NoMoreSleep

Member
Joined
Feb 23, 2010
Messages
21
Location
Chicago, Illinois
I have a 1822CMOS in my 761 MkIII and it uses two AAA NiCad batteries. The data retention voltage of the RAM chips is lower than the 2.4V. I have to check the exact value if you want me to. As I said, a picture would help.
 

ulihuber

New Member
Joined
Sep 7, 2010
Messages
8
Hi PUMA folks,

since a few days I am a proud owner of some NOKIA Pumas.
I live in Germany, but I looking for this old stuff, the world isn't big enough...

As my robots only have Russian translations of the VAL Manual, I am in a desparate search for other documentation.

Is anybody willing to share / sell documentation?

Thanks and best regards
Uli
 

ulihuber

New Member
Joined
Sep 7, 2010
Messages
8
Hi all,

so far, I managed to get one controller to a sign of life. Not very much more, but attached is what I got.

Maybe someone has an idea to what I could look further.

@NoMoreSleep: Thanks for your kind offer, I'll send you a PM.

Thanks and best regards
Uli
 

Attachments

  • Puma sauber.jpg
    Puma sauber.jpg
    59.4 KB · Views: 1
  • Puma Error.jpg
    Puma Error.jpg
    56.2 KB · Views: 1

ulihuber

New Member
Joined
Sep 7, 2010
Messages
8
Hi all,

no good news...

After fixing a PSU the controller came up, but shows 'Error Prom Bank 8" and bank 9.

Any idea how to get these PROMs ?

Uli
 

GRodesch

New Member
Joined
Dec 22, 2010
Messages
1
Hello All.

I am the owner of a PUMA 762 Mk III with a ton of spare parts and manuals. I have pictures of it in action, and I have used it with plasma cutters and routers to make many parts.

I have now outgrown it and I am looking for a good home for it.

The spares include extra CPU board, memory boards (battery backed 512k word), drivers cards, amplifiers, PSU, and many other parts.

I have a cable to allow it to connect to a PC, and all of the VAL program disks and POTCAL calibrations to make it run.

If you are interested please contact Greg. My email is at rodesch@pacbell.net.

I am looking for $2500 for the lot, OBO.
 

TCOA

New Member
Joined
Jul 11, 2011
Messages
1
I have several boards/parts that may interest you...

I have several boards/parts that may interest you...

Just came across the following boards/parts that seem to match up for this thread;

- D4-10399 Rev 1
- PROMS for Digital LSI Micro-Computer (various - about 20 of them)
- Digital LSI Micro-Computer BLANK boards (3)
- MRVII-C M8048
- KDii-HA M7270
- DLVII-J M8043

If interested, contact me!
 

JonathanUK

New Member
Joined
Jul 17, 2011
Messages
1
Hi all. I hope I've posted this in the right place...

I have a Puma 560 arm, but no controller. It's been changed slightly by the University that was throwing it out. The original sin/cos encoders have been replaced with digital A/B ones. Each joint works ok - I've tested it using a Servo-sc card contolled from a pc.

Does anyone know where I go from here? I'm looking for control cards and servo amplifiers (currently looking at Servo-SC from JerryKerr and OSMC from RobotPower) but the biggest problem is software to run all 6 joints at once in coordinated 'world' motion.

Any help greatly appriciated. Thanks (London, UK)
 

Askjerry

Member
Joined
Nov 13, 2011
Messages
10
Location
Kyle, TX, USA
PUMA 560 and trying to help others too

PUMA 560 and trying to help others too

I have a PUMA 560, it is currently operational and has VAL loaded.

I am trying to help a friend who has a 200 series and is getting the the LOAD FROM FLOPPY message. Any help appreciated. I suppose too that I need to consider installing new batteries in my unit... if it looses VAL I'm pretty much screwed. Again... any help... much appreciated.

Here is where I may be able to help you... I had access to a high speed scanner... so I made a PDF from my VAL programming language manual... I put it on my page...

http://rutherford-robotics.com/PUMA

I hope that helps.

Jerry
(My first post here too.)
 

Askjerry

Member
Joined
Nov 13, 2011
Messages
10
Location
Kyle, TX, USA
Hi PUMA folks,

since a few days I am a proud owner of some NOKIA Pumas.
I live in Germany, but I looking for this old stuff, the world isn't big enough...

As my robots only have Russian translations of the VAL Manual, I am in a desparate search for other documentation.

Is anybody willing to share / sell documentation?

Thanks and best regards
Uli

I uploaded my copy: http://rutherford-robotics.com/PUMA
 
Top