• Please review our updated Terms and Rules here

Diagnosing KIM-1 short

billdeg

Technician
Joined
Nov 18, 2003
Messages
3,872
Location
Landenberg, PA USA
I posted earlier about a KIM I picked up, wondering about the rev history. It's a rev D sold I believe as an OEM by Rockwell. Anyway, I pretty much have that issue solved, but now I find it does not work. The seller showed pics that it worked, but when I got it, it was dead. Well actually not dead, there is a short someplace. When I apply power (Application connector pin A +5v and pin 1 to ground) I immediately get a short and have to pull to avoid damage. I can't leave plugged in. It's as if I connected the +5 and ground wires together, same effect. I have disconnected the first resistor in the chain and replaced the first 1u50v cap, but it's going to be hit or miss. There are no socketed chips on the board, I can't remove the 6502 or RAM easily. The 5V I am feeding is regulated 5V at 1.5A

Pin A is the lower pin of the front of the application connector, and pin 1 is the top pin just above pin A, correct? Seems like it to me, but just to be sure....

I also have a non-working KIM that does not short out using the same power supply, the problem with the other one is physical board damage, but electrically it's more or less OK, no major short like this new one.

My question - Any guesses as to what might be a smart way to test? I will have to try looking for shorts by probing with the power off and looking for continuity when there is not supposed to be any, but ug...Any ideas are welcome. I can also compare and contrast the two systems with the power off to look for differences.

Thanks in advance.

Bill
 
Last edited:

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
There's a couple of things you want to check. I'll have to unbox mine in the morning to verify a few things. Basically, you want to measure the resistance between the +5v pin and the Ground pin. If you have some very low resistance, say less than approx 20ohms[have to verify on mine], then it's a sure indication there a shorted component on that board.

You also want to check the power supply voltage while unloaded[not connected to any device], and then loaded with a simple load resistor, to see that it can regulates properly. Old power supplies can go bad too. About 22ohms should be enough, since that's a 1.5A. But you really need to parallel several many of these to add up to 22ohms, to get enough wattage so you don't burn up the resistors. Just use the parallel resistance calculator online. A quick simple way is to take 12x 1/4w resistors of 470 ohms and connected them all in parallel. If you don't have that, another simple way to make a test load is using a lamp from an old flashlight. That typically runs on 3v, so you would need about a 120 ohm resistor in series. That wouldn't be such a heavy test load, but it should be enough to check the power supply is regulating properly.

Now if there is a short on the mainboard, after checking the resistance. We all know how difficult it can be to narrow down the problem. I don't recall this late at night if those had tantalum cap's. As we all know, those are notorious for shorting out - even to this day. I avoid them like the plague in any design - there are better alternatives. After that, even some old ceramic disc cap's have been know to short. Those are the noise decoupling caps found near the end of the various logic chips. There aren't too many of those on that board, so it's practical to lift one leg of a disc cap at a time to check if it was shorted.

Another old-school method that I use in this case, is to use a power supply with a higher capacity. I use this method to find any shorted component. It's good old Ohm's Law. High Current creates Heat. Any component which is shorted has a low resistance, current always seeks the least resistance in the path to ground. You still want 5v, but a lot more current. Today's ATX power supplies gives you at least 15A at 5V. These can handle the lower resistance, they won't hiss, or crowbar. The more current that flows through the shorted component, the more heat it creates. If you had an Thermal camera, you'll see what I mean, the one chip which is shorted will be start to turn bright on the thermal imager. But you'll have to use another old school method, your finger :)

Dan
 

ldkraemer

Veteran Member
Joined
Mar 14, 2013
Messages
2,180
Location
Chaffee, MO
In your case, take a look at the LeakSeeker 89: http://eds-inc.com/product/leakseeker-89/

I know it expensive, but it shows you how it works. I wish I had one to play with, it did get me to thinking about cheaper solutions.

http://electronics.stackexchange.com/questions/16398/find-short-location-on-pcb
http://www.edaboard.com/thread31322.html
http://www.hobbyprojects.com/test_gears_circuits/connection_tester.html
http://www.electroniq.net/other-pro...-tester-circuit-diagram-using-741-op-amp.html (If you want to make this one,
I've found a better schematic of the 741 and associated circuit on the internet. PM me and I'll email you the better image.)

One other choice is to convert your Multimeter to a MilliOHM Meter and chase the Shorted condition, as the LeakSeeker would.
http://users.tpg.com.au/pschamb/lom.html

While, I've not tried the millOHM adapter, it does make sense, and I've got parts ordered to fabricate one.

Good Luck.

Larry
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
There is always a warning that goes along with this - on any equipment. In my setup, I actually use a Variac [I use a linear power supply - not a smps], voltmeter to monitor the output voltage, a current meter to monitor the current drain on the power supply and there's a mosfet switch to pulse the current if I need to minimize problems. Again when working with any equipment, you're expected to be aware of the situation. eg: be prepared to shut it off. And there are always a series of steps in the process.

It also depends on what kind of short is present. As I mentioned in my steps, you like to check for shorted tantalums first, since they are normally a dead short, practically zero ohms. You never want to use that old school method on that - where you apply the larger power supply. Besides even a larger power supply will crowbar [or blow a fuse] with zero ohms. So you have to painstakingly remove and check each tantalum cap.

When a component is shorted across the rails, ie: Vcc[or Vdd] to Gnd[or Vee, Vss], it is typically a couple of ohms -- that's the primary indication - as any silicon chip always has some residual resistance after a failure. If it were zero ohms, then I suggest you look much closer, because I guarantee you there will be a burned hole in the component - and so your repair is solved. So the effective current would be well within safe boundaries - since the power traces are thicker than the signal traces -- there again, if they followed proper PCB design guidelines. At 5V, with a shorted component of a few ohms, you facing less than 5A peak current.

What I didn't mention, since the power rails were shorted here, in case of shorted signal, you never want to use that old school method. Because of the fact that signal traces are normally thin and are prone to damage. Here again, there's a tried and true old school method of finding those type of shorts - using a simple ohm meter. Now on a old piece of equipment you like to stop and think, how can two completely different signals can be shorted together. If it were a brand new circuit board which came out of a production facility, well, it's obvious, there's a solder short somewhere on it - the most typical problem. Well, maybe here on your old equipment, someone was working on it before you got your hands on it. So it could be that they created a new problem when trying to fix the last problem - a inconspicuous solder short. There is also another common problem, the same chip can have an internal short between two different signals on the same chip. So you always check all the pins on that chip first.

Now, this other method is done using a metal brush as wide as a broom connected to one end of your meter probe - depending on the size of your board of course. When you're working on boards which plug into a mainframe, then you can realize how big they get - bigger than my butt - which is where the broom becomes handy. One can be made from a nice piece of 30A power cord - stripe the ends at least 6in and unbraid each conductor into a wide broom shape, with all three wires [or 4] connected at the end to your meter probe. With the other meter probe connected to the first signal pin, you simply wipe across the bottom of the circuit board to find the section with the shorted signal. Thereafter, you can narrow the search area with a smaller brush until you find the shorted signal pin.

For those types of shorts, there is also a more elaborate method of using a milli-ohm meter, *if* you have one. And there's even a much more elaborate method using a different setup with the millivolt method by injecting a small current into the trace.

If the signal pin is shorted to Ground[or Vcc] then you don't need this broom method, most often it will be a shorted output signal pin or even a shorted input signal pin [that happens]. Lifting one of the pins at a time will isolate that problem. Now in case of the processor bus signal which is connected to multiple tristate signals across several chips, eg: a databus signal, requires different steps. As it becomes an arduous task to lift that many pins. You like to have an another piece of test equipment in this case. A Current probe, sized for components - not the large variety used for motors - one such kind is the HP547A. A newer type is the AIM/TTI I-Prober 520. They even make SMT sized current probes these days[$$$]. Again it's ohm's law, the tristate signal pin on the processor bus which is shorted will drain the most current. The current probe will detect this, the probe tip is small enough to place near the signal pin of the chip to get a readout. Checking each pin on the tristate processor bus you will eventually come across the shorted signal draining the most current.

Dan
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
ok, on my KIM-1 board
With the power supply disconnected,
On the +5v power rail, I get approx 550ohms
On the +12V power rail, I have approx 10Mohms
You would like to compare this on yours Bill, and let us know what you get
Not all DMM's are exactly the same when it comes to in-circuit resistance, but it should still be within +/-10%

I have a K-1000 power supply from Micro Technology, not sure which one you have
Basically there shouldn't be any low resistance on that either.
again while disconnected,
On the +5v output, I have approx 2.5K
And on the +12v output, I have approx 12Kohm

If there doesn't appear to be any shorts[or Low Resistance] on the power rails of the KIM-1, you still want to test the power supply separately.
First check it while disconnected from the KIM-1, see that the voltage is good, and within tolerance (+4.9v to +5.3v).
And then using a test load as I mentioned before, check the output voltages to make sure it regulates properly.
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
In your case, take a look at the LeakSeeker 89: http://eds-inc.com/product/leakseeker-89/

I know it expensive, but it shows you how it works. I wish I had one to play with, it did get me to thinking about cheaper solutions.

Hey, that one looks very interesting !
And it's way cheaper than the I-Prober 520
It does says it's only for dead-shorts, and not when it's a few ohms.
But it wouldn't hurt to add this on the bench.

I found a homebrew fluxgate current probe, similar to the I-Prober 520.
I'll have to look up the bookmark again. I think it was in the internet archive.

There are also some very helpful articles on EDN and EETimes about this subject
http://edn.com/design/test-and-meas...c-board-shorts-with-low-cost-tracer-technique
http://www.eetimes.com/author.asp?section_id=30&doc_id=1284424


Now these homebrew testers look very interesting too, I'm gonna add this to my list - thanks for sharing !


One other choice is to convert your Multimeter to a MilliOHM Meter and chase the Shorted condition, as the LeakSeeker would.
http://users.tpg.com.au/pschamb/lom.html
I like this homebrew version too
I came across another one, but I have to check my bookmarks again and I'll post it
This was a standalone version, using a panel meter, so you don't have to tie up your DMM
 

billdeg

Technician
Joined
Nov 18, 2003
Messages
3,872
Location
Landenberg, PA USA
There is no resistance at all! I have a Peak ESR70+ cap tester. That will help a lot. I have printed out your suggestions and I will report back. I have spare caps, hopefully that's the cause and not something else.

I should add I am using a new regulated power supply that I use for many other things. I will test the resistance of that too.
b
 

daver2

Veteran Member
Joined
Jun 19, 2012
Messages
7,823
Location
UK - Worcester
Bill,

I think you have connected +5 and GND to the correct pins. There is an image at http://gc.org/rc2011sc/et-3300_and_kim-1.jpg which seems to identify the power supply connections to the application connector. GND appears to be on the 'component' side of the PCB. If you hold the PCB with the keypad to the lower right; then the application connector is to the lower left. GND should be the 'top most' pin of the connector. +5V should be on the solder side of the GND connector (just below it depth wise). I think this confirms what you have done.

C1 is also directly across the 5V supply - so you should be able to follow the + end of C1 to find the +5V connector pad and the other end to find the ground connector pad as a triple check.

I would also be inclined to replace CR7 (6.2V Zener diode) as that is also directly across the power supply.

The other thing to check would be the pads of the application connector (PCB side) themselves. As +5 is on one side and GND on the other; it is just possible (but unlikely) that a bridge could have occurred across them.

After that - I would be inclined to put the KIM on a variable voltage DC supply and increase the voltage (whilst monitoring the current) to a point where the current is 'normal' for a KIM (i.e. you are not stressing the PCB power tracks) and then go around the chips with a thermometer or your finger looking for the hot one! There doesn't seem to be many decoupling capacitors on the KIM so I would be inclined to replace the odd one or two that are there on the off chance.

Sorry, this is the worst type of fault to diagnose...

Dave
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
Bill,

Not sure where you placed the meter probes for the measurement
But you want to measure with a Digital Multi Meter [DMM] first, not with the ESR meter, on the +5V power rail.
You like to check the in-circuit resistance of the entire board first.

but I attached a pic showing a very easy place to measure the resistance for +5v power
KIM-1_+5V-crop.jpg

and this shows an easy place to check the resistance for +12v
KIM-1_+12v.jpg

There aren't that many Cap's connected across the +5v power
I can whip up another diagram for that too
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
Here's a diagram showing the +5v Caps - there's very little.
There's also a Zener wired across +5v in there as a protection for when the incorrect power supply voltage is connected.
This can be suspect too - just lift one leg and measure the resistance.
KIM-1_+5v_Caps.jpg
 

billdeg

Technician
Joined
Nov 18, 2003
Messages
3,872
Location
Landenberg, PA USA
The 10pF tant cap at the top of the board was blown, the ESR tester registered nothing/cracked inside. Not sure if this is the only problem, but I am off to RadioShack to get a new one, and I guess a 6.2v zener if I don't already have one.
thanks all.
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
I may have missed you and you're probably on your to RS already.
That little Cap up at the top above the 6502 is the Oscillator Cap
That wouldn't short out the entire board and cause the power supply to hiss.
You really don't want to skip steps here.
Cause it'll make you go in circles and spend more time than necessary
 

billdeg

Technician
Joined
Nov 18, 2003
Messages
3,872
Location
Landenberg, PA USA
zener is bad reading .3 ohms (not m ohms).

I don't believe the 10pF cap in earlier post was actually bad, too low to be measured by my ESR meter.
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
ok good job.
My guess the last owner plugged the wrong voltage, something much higher than 5v [maybe he had the 5v and 12v swapped], into that KIM-1 and the zener sacrificed itself.
All in the name of rock 'n roll :)
Because they must have left it on with the higher voltage just a little too long for that zener to dissipate all that extra power.

The oscillator cap has such a low ESR that it can be disregarded. Your ESR meter probably couldn't register any reading on such a low capacitance. That meter must have a specific range, in general for electrolytic caps.
 

billdeg

Technician
Joined
Nov 18, 2003
Messages
3,872
Location
Landenberg, PA USA
Radioshack has no 6.3v so I ordered a few. What would happen if I used a 3.8v (too low) or 11v (too high) instead (just curious)?

In the meantime when I first ran a power on test I had a clip lead on the circuit to measure the 5V and it melted it within a split second. The Zener might have sacrificed itself, but more damage down the line is expected.
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
Radioshack has no 6.3v so I ordered a few. What would happen if I used a 3.8v (too low) or 11v (too high) instead (just curious)?

ok, don't use anything lower than a 5v zener. It will start to conduct and overheat because there isn't any current limiting resistor in series with that.
Just leave that spot empty until you get the new parts in. No sense in putting the 11v volt, it won't protect the 5v parts since it's a higher voltage rating.
You can still power up the board without this part. Just watch that the power connections don't get swapped around by mistake.

In the meantime when I first ran a power on test I had a clip lead on the circuit to measure the 5V and it melted it within a split second. The Zener might have sacrificed itself, but more damage down the line is expected.

oh wait, did you check the in-circuit resistance on the 5v power and 12v power yet ? [remove power supply]
See my earlier post for the in-circuit resistance values.
 

billdeg

Technician
Joined
Nov 18, 2003
Messages
3,872
Location
Landenberg, PA USA
+5v .478 k ohm
+12v 2.9 m ohm

The power supply itself is very solid. It is a newer one, seems to maintain exactly 5.0 with a number of resistors are in line. I do have questions about how to measure the caps in circuit if possible by comparing a known-working unit rather than removing one leg to test out of circuit, but if need be I will remove each. Same goes with the resistors, but I suspect a cap is more likely to have gone bad.

There is no 6.2v Zener diode in circuit (removed the bad one). I have seen +5.0v readings (exactly) throughout the board indicating a steady regulation. After removing the zener there is no complaint from the power supply.

Next I plan to work through the board/schematic, but if you have any test points to confirm let me know. I have an oscilloscope, logic probe, etc ready to go.

b
 

Ragooman

Experienced Member
Joined
Apr 27, 2005
Messages
162
Location
Pittsburgh,PA
+5v .478 k ohm
+12v 2.9 m ohm

ok ,looks good
It doesn't appear then to be any major shorts on the mainboard.
On the +5v you like to type 0.478Kohm, since it's viewed like that on the DMM, and it's easier to read on here :)

The power supply itself is very solid. It is a newer one, seems to maintain exactly 5.0 with a number of resistors are in line.

That's good news. Considering what stress it might have gone thru if it had been wired incorrectly to the mainboard and damaged that zener

I do have questions about how to measure the caps in circuit if possible by comparing a known-working unit rather than removing one leg to test out of circuit, but if need be I will remove each. Same goes with the resistors, but I suspect a cap is more likely to have gone bad.

I guess you mean measuring the ESR and if you have a "In-Circuit" ESR meter. Not all of them are the same type. Some are only "out-of-circuit". Your ESR70+ meter can check Caps "in-Circuit", so you can go ahead and take the ESR measurements of the Electrolytics.

There is no 6.2v Zener diode in circuit (removed the bad one). I have seen +5.0v readings (exactly) throughout the board indicating a steady regulation. After removing the zener there is no complaint from the power supply.

Sounds like it's looking good so far.


Next I plan to work through the board/schematic, but if you have any test points to confirm let me know. I have an oscilloscope, logic probe, etc ready to go.

b

The basic thing to verify is the CPU oscillator is working fine, on pin.39. Just use the scope for the that, with the Horiz set to about 5us/div and the Vert set to about 2v/div to view enough cycles on the screen.

One thing I noticed is it hard to find the original schematics for the KIM-1. All I ever see online are copies which are not exactly the same as the original KIM-1. So finding the signals on chips and their pin numbers are a chore still.

You should try to run some of the examples in the user manual
If you don't have the manual, there a copy online here
http://users.telenet.be/kim1-6502/6502/usrman.html
 
Top