• Please review our updated Terms and Rules here

Help Vectrex with sound but no display.


Feb 5, 2023
Ohio - US
Hello everyone,

I'm new to the forum and I'm hoping to find some help. I have tried other places without any luck.. Some background about myself that may help anyone willing to help me. I would consider myself a beginner when it comes to electronic fault finding. I can solder and have a digital voltmeter. Unfortunately I do not own an oscilloscope (which will probably be an issue for troubleshooting) and I have never used one before. I am a beginner when it comes to reading schematics. I know the basics switches, diodes, capacitors, resistors etc. I have fixed other retro game consoles but it usually simple things like replacing capacitors or fixing broken traces. Now on to the problem. I purchased a used Vectrex a few weeks ago. When I received it the Vectrex was working properly and I was really enjoying playing Mine Storm. One day I went to play a game and the display did not come on. The machine booted up and the game began to play but no display. The controller inputs worked and you can hear the game playing just no display. There is not even a white dot on the screen that I have read about in a lot of other forums. I started doing some simple voltage reading around the power board and on the logic board and everything looked correct but being a beginner I could have over looked something. There is a feint glow on the neck of the monitor and when you discharge the monitor there is a blue spark so I believe it is receiving high voltage. I ordered a replacement capacitor kit from console 5 and replaced all of them over the past couple days. While replacing the power board caps I discovered capacitor C513 had been leaking and badly corroded the negative trace. I cleaned the corrosion and continuity between it and T503 on the schematics was restored. I thought I had found the problem. I finished changing out the rest of the capacitors and reassembled the Vectrex. when I turned the machine on nothing had changed. I still had no display and the game continued to play through the speakers. At least I didn't make it worse! I did not replace the styrene capacitors but I have replacements on the way. I'm hoping some one see's this post with more knowledge then myself that would be willing to help a beginner out. If you made it this far thank you for reading my post.
Last edited:
Some additional information if some one is able to help. I did some voltage probing around the CRT board last night. Pin 2 on the CRT electrodes was getting 46V, Pin 5 - 13V, But I was getting 0V on pin 6 and 7. I believe this is the high voltage that runs the vectors. From information that I found on the internet there is a protection circuit designed to blank the screen if the vertical deflection signal is missing. Unfortunately I dont have a scope to check the X and Y signals coming into the board. But what I read with the beam cutoff protection circuit take a sample of the waveform, turns it into DC voltage and uses it to keep the protection cutoff transistor Q503 turned on for as long as there is activity on the Y Axis output. because of this I should be able to see DC voltage if I measure across capacitor C410 in the protection circuit. And I am getting voltage there, It fluctuates around the 7V range.

Links to schematics.
Power Board: https://wiki.console5.com/tw/index....chematic.png&mobileaction=toggle_view_desktop
Logic Board: https://wiki.console5.com/tw/index....Schematic.png&mobileaction=toggle_view_mobile
Last edited:
After doing some more following of the voltage. It appears the flyback is getting the -30V. But when I checked Capacitor C516 it does not appear to be getting any voltage and the Diode 504 that feeds it test's okay. I'm assuming this points to a bad flyback transformer? If so I fear this is DOA unless I can find a replacement board from a parts machine as there does not appear to be a suitable replacement.
Can part of the transformer go bad? because it still appears to be sending some kind of voltage to the CRT as there is a spark when it is discharged and there is a glow coming from neck.
Last edited:
Years ago I read someone purchased a non-functioning Vectrex and they reseated all the socketed (non-soldered) rom chips on the motherboard and the thing came back to life. Not saying this is your issue, but have you tried reseating these? I know absolutely nothing technical about this console other than I wanted one pretty bad as a kid in the 1980s.
Well you have neck glow so the cathode filament is running. A way I've checked for high voltage on larger displays is to see if a piece of paper the size of a post-it will attract itself to or stick itself to the face of the tube when you bring it close.
Welcome to VCFED.

There are a couple of threads on repairing a Vectrex on here. Probably worth a read.

The first thing is to get out of being moderated, otherwise your posts could be delayed and it will be difficult to do much.

The other thing is to identify exactly which version of the Vectrex board you have.

There are the XY deflection circuits, but also the Z (brightness). If you have checked out the voltage rails (especially the EHT) then it is likely to be one of those circuits. Especially the Z, if there is no dot, line or funny 'squiggles'!

A multimeter is a must, but an oscilloscope would help (especially for a Vectrex) where the screen is a vector display rather than a raster one.

Don't bother with those oscilloscopes. They are pretty useless. But, if it is all you can afford, it is better than nothing...

Last edited:
Is there a way to check the Z.Axis without an oscilloscope? The Capacitor c508 appears to be getting voltage so I assumed the protection circuit was working properly.
Just because you are seeing 32.5V across C508 doesn't really tell us whether the Z drive is working or not. In fact, isn't this supposed to be a -30V DC supply rail (approximately) and nothing to do with the Z drive itself?

I would prefer to 'see' the Z drive signal as it moves from source to the CRT to know whether the chain is working correctly. For that, you really require an oscilloscope.

We can infer whether digital signal are working or not by measuring the voltage on them and inferring what the mark/space ratio is - but this is a very inexact science. You can't beat an oscilloscope though...

Last edited:
your correct it is a -30V rail. I was just measuring what voltage was in the capacitor. Is there a reasonably prices oscilloscope you would recommend? My volt meter does measure frequency but I dont think that would be of much help.
Can you update your profile with your location (if you are able to do).

There are a few oscilloscopes that we can recommend, but it would be easier to have a look at what was available where you live.

I can post something tomorrow when I get back home. I am on a business trip at the moment with limited access.

No hurry, Dont feel obligated to answer I understand people have work and family that comes first and I am just grateful for any help people can give in their spare time. I will update my profile but I live in Ohio over in the US.
I have an analogue Hitachi V212 at home. This is a fairly compact 2 channel 20 MHz bandwidth unit with an input voltage capability (on the Y inputs) up to 300V - but I would hesitate to use them up to that voltage myself...

Have a look around and see what you can find...

These are analogue - and I would recommend you start with an analogue oscilloscope and migrate to a digital oscilloscope if you think necessary in the future if you think repairing vintage technology appeals to you...

My ten cents...

Sounds like a plan.

I see you are out of moderation now... Freedom 😀!

I do have one of those cheap 'toy' oscilloscopes as well...

I used to borrow a decent Tektronix digital oscilloscope and logic analyser combination from work when I wanted to do any 'serious' work. We have since moved into new offices and the equipment has been put into storage. I managed to acquire some equipment that was being disposed of, but all of the oscilloscopes and logic analysers were not being disposed of (yet...).

Last edited:
finding an oscilloscope may be harder then fixing the vectrex lol.. Looking for an analogue model it appears used is my only option and who know's what you will actually get on eBay.