• Please review our updated Terms and Rules here
  • Exhibitor application for VCF West 2022 is now open! If you are interested in exhibiting, please fill out the form here.
  • Here are the results of the VCF East 2022 Post Event Survey: Survey Results

ITT Satellite navigation system 6000 (PDP8/L)

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
So finally I got enough money to buy a second hand satellite navigation system. Somehow I'm
a bit worried about map updates... ;) But also the satellite is probably not working any more.

PDP8L - 01.jpg PDP8L - 02.jpg PDP8L - 03.jpg PDP8L - 04.jpg PDP8L - 05.jpg

I got this PDP8/L system from a man who installed and maintained these kind of systems.
When the system became obsolete he took one of these systems home. The idea was
to use it for his miniature trains. That never happened so it was waiting for 40 years in the attic.
So after navigating for the last time it was never turned on any more.

He told me that is was used on the first Satellite navigation system Transit.
https://youtu.be/yzUH5w9-O5M So I guess this is also a kind of history on its own...

I got some spare parts with it but the most modules don't seem to belong to the 8/L.

PDP8L - 07.jpg PDP8L - 06.jpg

And some documents. But the PDP8/A manual clearly doesn't belong to the system.
A few data sheets on the modules are quite fun to have...

PDP8L - 08.jpg PDP8L - 09.jpg

And I think these cables were used in the original ITT equipment which
belonged to the system. Unfortunately there is nothing left from the
rest of the system...

PDP8L - 10.jpg PDP8L - 11.jpg

So another winter project...
Regards, Roland
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
Add an ASR33 Teletype and you have a complete system.
You can read about the RICM 8/L restoration here.

Yes I have two Teletype 33 ASR machines, both need some work...
My 8/L has also the single power transformer like you pointed out in your PDP8/L story.

PDP8L - 13.jpg

But what a mess before you have that power out of the system!
The key switch was loose from the power supply. But also the fans were
not connected. So I think there was a problem with this system back then already...

PDP8L - 12.jpg

And again, I don't have a power connector that fits into the machine.
The outside diameter is just a fraction too big. Does anyone have two plugs
which fit into these machines for sale? I have the same problem with my PC04.

PDP8L - 15.jpg PDP8L - 14.jpg

Regards, Roland
 

m_thompson

Veteran Member
Joined
Jul 8, 2014
Messages
1,627
Location
Rhode Island, USA
>And again, I don't have a power connector that fits into the machine.

Is there enough plastic in the yellow power plug so that you could put it in a lathe and reduce the diameter so it would fit?
 

jackrubin

Veteran Member
Joined
Mar 12, 2004
Messages
830
Location
Chicago, IL and Buchanan, MI
The "easy" way to power your 8/L (or PC04, etc.) is to get an extension cord similar to the one shown here. The blocking nub on the female end can be cut off with a sharp knife and the modified receptacle will mate with the smaller DEC connector.

Of course, "easy" is relative - no problem here in the states, maybe not so much in Europe, but you can probably find something on Amazon or AliExpress.

71BWyB+tr+L._SL1500_.jpg
 

DECtechGuy

Experienced Member
Joined
Jun 22, 2017
Messages
157
Location
Florida
Super cool find! Pitty it's just the PDP8, you didn't get any software or manuals for the complete setup?
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
Is there enough plastic in the yellow power plug so that you
could put it in a lathe and reduce the diameter so it would fit?

I hope so, tomorrow I will ask if someone can do that for me at my work on a lathe.
And if not, no problem, I could not use them anyway now...

The "easy" way to power your 8/L (or PC04, etc.) is to get an extension cord similar to the one shown here. The blocking nub on the female end can be cut off with a sharp knife and the modified receptacle will mate with the smaller DEC connector. Of course, "easy" is relative - no problem here in the states, maybe not so much in Europe, but you can probably find something on Amazon or AliExpress.

Yes that would be much easier. But the ones I found on
Epay, which would actually ship to Europe, had quite short cables.
I will check out Amazon or Ali if there are better ones.

Super cool find! Pitty it's just the PDP8, you didn't get any software or manuals for the complete setup?

The only software with it is probably in core... But I'm afraid that I can's save that.
This machine will definitely need a lot of fault finding and testing which would
wipe the core contents...

Regards, Roland
 

anders_bzn

Experienced Member
Joined
Jan 27, 2016
Messages
232
Location
Sweden
The "easy" way to power your 8/L (or PC04, etc.) is to get an extension cord similar to the one shown here. The blocking nub on the female end can be cut off with a sharp knife and the modified receptacle will mate with the smaller DEC connector.

Of course, "easy" is relative - no problem here in the states, maybe not so much in Europe, but you can probably find something on Amazon or AliExpress.

View attachment 57566

I found one of those locally here in Sweden. And I did just that, cut it down with a knife! I used it on my on an RM503 Tektronix oscilloscope, my 8/L has a different connector.

I started to restore my 8/L back in 2010 (time flies) and documented it pretty well on a Swedish forum in Swedish (https://www.elektronikforumet.com/forum/viewtopic.php?f=3&t=46611).

When you come to loading software and using a terminal it might be handy to connect it to a PC instead of an ASR33. It is possible to increase the baudrate clock above 110 Baud and to use a RS232 interface instead of the current loop interface. Vince Slyndstad has made some boards for doing this.

Nice find and good luck!
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
The connectors had enough plastic to remove indeed. So thanks! Now I can use these.

PDP8L - 18.jpg PDP8L - 19.jpg

I started to restore my 8/L back in 2010 (time flies) and documented it pretty well on a Swedish forum in Swedish (https://www.elektronikforumet.com/forum/viewtopic.php?f=3&t=46611).
When you come to loading software and using a terminal it might be handy to connect it to a PC instead of an ASR33. It is possible to increase the baudrate clock above 110 Baud and to use a RS232 interface instead of the current loop interface. Vince Slyndstad has made some boards for doing this.

I will check your repair story. Always fun to see. I hope Google translate can make something out of it.
And I've already spoken to Vince about boards for the 8/L. I wonder if he has any bare boards left.
Otherwise I have to order them myself. He was converting the files to the newer eagle version now...

Nice find and good luck!

Thanks! I'm afraid that this will be a longer story... But that is the hobby...



What a nice overview for the boards and revisions! Thanks, I didn't see that earlier.

Did your machine suffer from moisture? I see many white spots on the metal surface and rusty IC pins.....
I've seen the same in my machine. Those old chips don't seem to like moisture...
So I think I have to replace a lot of these chips as well...

Regards, Roland
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
I've been slowly powering the power supply and saw the 5V line go to 6.3V and then drop back to 5.1V.
That is quite an ugly behaviour to say the least! Then I was searching for the schematic of the regulator
PCB which is not in the DEC documents. With a bit of searching on the web I found schematics from
Mattis and Anders which seem to run into the same problems.

So I'm going to modify this board as well... But I don't like the crowbar using the same voltage reference as the
power itself does. So I think I will make a little circuit next to the board with a crowbar and his own voltage reference...
 

anders_bzn

Experienced Member
Joined
Jan 27, 2016
Messages
232
Location
Sweden
I've been slowly powering the power supply and saw the 5V line go to 6.3V and then drop back to 5.1V.
That is quite an ugly behaviour to say the least! Then I was searching for the schematic of the regulator
PCB which is not in the DEC documents. With a bit of searching on the web I found schematics from
Mattis and Anders which seem to run into the same problems.

So I'm going to modify this board as well... But I don't like the crowbar using the same voltage reference as the
power itself does. So I think I will make a little circuit next to the board with a crowbar and his own voltage reference...

The regulator board (drawn by me): https://www.pdp-9.net/docs/pdp-8-l/pdp-8l-5V-regulator-board.pdf
 

anders_bzn

Experienced Member
Joined
Jan 27, 2016
Messages
232
Location
Sweden
Did your machine suffer from moisture? I see many white spots on the metal surface and rusty IC pins.....
I've seen the same in my machine. Those old chips don't seem to like moisture...
So I think I have to replace a lot of these chips as well...

Regards, Roland

My machine was stored in a cold garage with a leaking roof for many years, many of the IC's had rusted legs. The chassis where rusted and I re-plated it. Some of the transistors just fell of the boards when I touched them since the legs where so rusty... It was in very poor condition.
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
The regulator board (drawn by me)

Hi Anders, thanks that saved me some work! :D I've changed the zener diode to 4.3V
and made a voltage divider of 1K and 180 Ohm to get the 4.3V onto the differential amplifier.
There is no overshoot any more at powering on the power. It gives 5.15V now which is great
because there will be some losses in the backplane as well...
PDP8L - 31.jpg PDP8L - 32.jpg

The tripping point of the crowbar is also lowered to 6V because of the changed zener diode.
I've tested the crowbar by putting a 6.8 Ohm 10W resistor in series with the 8V line to the power.
On the 5V output I've connected a Hameg Laboratory supply set at 4V. When turning on the PDP8/L power
it lifts the Hameg voltage to 5.2V. And while slowly raising the voltage on the Hameg the crowbar trips at 6V.
This short circuits the Hameg power (which is curent limited) and it shorts the power in the PDP8/L circuit
which I also limited in current with that 6.8 Ohm resistor. So everything is working fine...
PDP8L - 33.jpg PDP8L - 34.jpg

BUT... In my opinion this circuit has one huge flaw... When the zener diode goes open circuit the 5V will go to 8V.
And the crowbar will never trip because of that defective zener diode. I don't like all my TTL chips being protected
by the same component as which is also regulating the voltage.

So I've designed a little extra crowbar to put into the machine. Just in parallel of my 5V line.
When the power fails for whatever reason it will protect the few hundred TTL chips.
PDP8L - 35.jpg

My machine did also suffer from moisture... Especially the fans were quite ugly corroded. One of them
even touched the corrosion and you could not rotate the blades... But I didn't want to replace the
original fans by some modern plastic China things... So there was only one option. Take them apart.

After sand blasting them the corrosion was gone and I could spray some new black paint on them.
And because they were open I could clean the bearing as well. The filt pad in the front of the fans
are actually oil reservoirs to lubricate the fans over the years. Off course they were completely dried out.
So I soaked them into motor oil and I put a bit of the oil on the motor shaft. They run as new now, very smooth...
I think I'm going to do the same with the fans in my PDP8/M.

PDP8L - 20.jpg PDP8L - 21.jpg PDP8L - 22.jpg PDP8L - 23.jpg
PDP8L - 24.jpg PDP8L - 25.jpg PDP8L - 26.jpg PDP8L - 27.jpg

This is my first PDP which has his original light bulbs. My 8/M is a LED machine and my 8/E was upgraded to LEDs.
So I really liked to see those light bulbs. But after checking them more then 20% was end of life. I could not find these
original bulbs but the CM7371 seems to be a close match. To keep the same light output I've replaced them all...
I keep the original bulbs, maybe I find a machine in the future which have also these OL2 bulbs. Then I can fix
that machine with these originals... I've tested all the data lines and all bulbs work in dim and full brightness.

PDP8L - 28.jpg PDP8L - 29.jpg PDP8L - 30.jpg

So, baby steps... I've ordered the flip chip tester board which Vince made out of Warrens original.
I'm very curious, I still have to order the components for it, but I expect the boards here next week...

To be continued...

Regards, Roland
 

m_thompson

Veteran Member
Joined
Jul 8, 2014
Messages
1,627
Location
Rhode Island, USA
I've ordered the flip chip tester board which Vince made out of Warrens original.
I'm very curious, I still have to order the components for it, but I expect the boards here next week...

The C source code for the tester software for the parallel port version of Warren's tester is on Vince's SVN site. Since parallel ports are getting rare I modified mine to use a USB-SPI cable, and wrote Windows software in C# to talk to the modified tester. Both the C and C# applications use the same flipchip test vector files.
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
The C source code for the tester software for the parallel port version of Warren's tester is on Vince's SVN site. Since parallel ports are getting rare I modified mine to use a USB-SPI cable, and wrote Windows software in C# to talk to the modified tester. Both the C and C# applications use the same flipchip test vector files.

Oh very nice! I will check it out! Does it also run on Windows 10?

And I could use a few flip chips. So if anyone have these on spare...

1x M216 (flip flops)
2x M906 (terminator)

In the meanwhile I've made a 220-115V transformer. I've got an old toroidal transformer
from a scrap device. I had a case for it, but it just didn't fit in. So I removed all the secondary windings.
Then it fitted into the box including the soft start circuit. On the primary side it was tapped at
0-100-115-220-240V. So I could easily use the 0-115 for the output. And still have the voltage
selector for the other primary voltages. I can even set it at 240 if necessary in the future...

PDP8L - 36.jpg PDP8L - 37.jpg PDP8L - 38.jpg

Regards, Roland
 

Roland Huisman

Veteran Member
Joined
Mar 24, 2011
Messages
1,317
Location
The Netherlands
In the meanwhile I've cleaned all circuit boards. Some chips are heavily corroded, others are shiny gold.
I cleaned the rusty pins with a small wire brush but I expect some troubles with these chips...

PDP8L - 39.jpg PDP8L - 40.jpg

And the diode board on the core stack is affected by the decayed foam which was pushing against it...
PDP8L - 41.jpg

I've fixed the deposit switch which was missing its pins. I drilled a little hole in it and used a little metal pin.
PDP8L - 42.jpg

For now I've put everything back into the machine and slowly powered it up again. No fireworks...
But I can't read or write anything into memory. Loading an address works. Depositing something
into memory shows up into the lights. But after reading back that address it reads zero on all addresses.
When I put the PDP into RUN mode it runs endless NOP operations. To be honest, the machine does a
lot more then I expected. But there is probably still a lot to do...
PDP8L - 43.jpg

Before I even start fault finding I want to test the flip chips of the machine.

I'm expecting 5 bare circuit boards this week for the Flip Chip tester. This was originally designed by Warren Stearns.
Vince made a PCB design for it. (I ordered 5 of them and I will have 3 boards left which can go to other people.
I think 5 Dollar plus shipping for a board is fair, but you have to get your own components. PM me if you are interested.)

http://so-much-stuff.com/pdp8/repair/fc-tester/assembly.php

Regards, Roland
 

anders_bzn

Experienced Member
Joined
Jan 27, 2016
Messages
232
Location
Sweden
I can use a set of Warrens boards. And one of those nice crowbars as well, if you have spares.

I looked for the flipchips that you wanted, but could find any spares of those. But I found other spare components that you might be interested in. I have lots of 2N2904, 2N3725 transistors and many 1N4149 diodes which replaces the diodes on the diode boards (core stack) just perfectly. Just let me now if you want any of those.
 
Top