• Please review our updated Terms and Rules here

Vectrex suddenly having faulty vectors


Experienced Member
Sep 18, 2019
Dresden, Germany

I hope one of the Vectrex experts here can help me with my odd Vectrex issue. I am Denis from Germany and maybe some of you remember me regarding my Commodore PET restauration 3 years ago. I remember very well the help I got from Dwight, the 2 Dave´s (daver_m & daver2) and others from this nice VCFED Forum and I can tell today my Pet is still working fine. :)Over time I have learned a lot in electronics and bought also some helpful equipment (logic probe, DVMM, scope, de- soldering iron, etc..) which allowed me to fix also some other nice retro computers so far. A few months ago I found my Vectrex and got the "Vec Fever".

It was running fine until I decided to change out all electrolytic and polystyrene caps. The reason for this - I was not quite happy with the geometriy of the vectors. Since then I am in trouble with my Vetrex. Something went wrong. I overseen that during the recap I bended C324 in such way that it got contact with the 5 VDC leg on the J204 connector when I put the plug on. I stupidly overseen it. So there was a short between +5VDC at the connector and the GND side of the capacitor. When I tried to start up the vectrex the first time after the recap it did not start at all. Then I found that shortcut at J204 and fixed that. Maybe that caused my issue - I dont really know. But maybe not. Because since then the Unit always starts up and I can hear the sound from Mine Storm. But I did not always get a picture. I figured that the -13 VDC was missing when there was no picture. Changed out C12, C121, C122 without any improvement. Something prevented to establish the -13VDC. What helped me in the recent weeks was to start the unit while having the J204 disconnected - power down and re- connect J204. Then the Vectrex was always good to go for 1-2 days or so. Then after that time the screen failed again so I repeated that workaround which used to help for weeks. In the meantime I was trying to understand what can cause that problem and finally I replaced all diodes in the -13VDC circuit (D106, D107, DZ102). It did not help to start the screen in the first place so I needed to repeat my work around. You can imagine that I am getting crazy overtime. But I dont give up yet.

Unfortunately it now became worse. Since saturday the vectors are completely faulty. The game is playing fine though. I can hear the sound and control the game but the vectors are far off. Today I realized a strange thing. When pushing the joystick all the way left and to the bottom the screen looks almost ok. Not really ok but I can read the text and the geometry of the vectors are improving.

Does anybody know what could be broken on my Vectrex? I have attached some photos:

1.) Minestorm without pushing the joystick
2.) Minestorm with Joystick left/down
3.) Test Cart V4, first screen without pushing the joystick
4.) Test Cart V4, first screen with Joystick left/down

This is what I also already did and checked:

- I cleaned the switch (perfect continuity between the poles) and there is ca. 10VAC at EP104 and EP106
- I measured the -9V and +9V at T401
- I can measure -4,98VDC, +4,92VDC and -13,65VDC
- I changed the VIA 6522 and tried 3 different chips - there is no change on the symptoms
- I checked with my logic probe the digital inputs at the DAC chip IC301 - pulses on all pins
- I changed out IC301 - no change
- I have checked continuity of the X,Y,Z Axis signals between the digital and analog board
- I measured VDC for the X,Y, Z Axis at the analog board and get between some mV and 1,x VDC which is changing when I move the joystick. Not sure whether thats normal?

One more thing. I was on a business trip since monday and when I turned on the vectrex today the screen went immediately on. So this is already an little improvement...

best regards


  • ieHG9GKCTiGNNVxVtZ09rQ.jpg
    1.1 MB · Views: 23
  • Lw3oj3qHT7aN7doBEwUwYQ.jpg
    1 MB · Views: 23
  • rsvcB2RoSYi5fWrvv84NRw.jpg
    1.2 MB · Views: 18
  • L7EBxA7oQqCT3sRTNchGVA.jpg
    1.1 MB · Views: 21
The first thing I would do is to check all of the pins of all of the connectors where they are soldered to the Printed Circuit Boards (PCBs). Check with a bright light (preferably daylight) and look for signs of cracked solder making a bad connection.

If the problem keeps coming and going then it is clearly intermittent - so a faulty connector may account for it.

If that turns out to not be the problem, we need to delve further into the logic of the beast.

First question: do you have an oscilloscope?

Trying to fault find on the Vectrex output stage would be much easier if you did...

If you have one (or access to one) I can tell you what to look at.

If not, I am going to go on a hunch and go for IC302 (CD4052) analogue multiplexer. This drives the X, Y and Z circuits of the monitor (and has an output for sound under certain circumstances). I can see aberrations in all of the X, Y and Z circuits - so IC301 (DAC), IC304 (LF353), IC302 (4052B) could be implicated.

Since you have swapped out IC301 - that probably rules that out.

There are a couple of different PCB assemblies for the Vectrex, I am not sure whether I have the schematic diagram matching your particular machine.

Hi Dave, thanks for your quick replay. The current problem is not intermittent and I have already looked for a cracked solder joined and measured continuity. Also wiggled on the connectors while powered on. And cleaned them with IPA. It is rock stable faulty :mad:

And yes I got a Scope (Hitachi V212). Would love to follow your advice and dig inside the electronics on the weekend😊

My Vectrex Board is a 3GE

I will post a few things tomorrow for you to look at over the weekend as your starter-for-ten.

If it is rock stable faulty now, could you post a screen photograph with the cross-hatch screen from the test cartridge displayed (if that is possible)?

If you download the following document and display the cross-hatch screen, the oscilloscope traces on the last page should be observed at the specified points?

If you find anything different, can you post a photograph of the discrepancies?

The tables give details of the oscilloscope settings.

It might also be worth working your way through the tables to see if there are any discrepancies with your particular faulty board.

Let's use the existing fault finding documentation first and then work from there. How does that sound?

Last edited:
Hi Dave. I posted this exactly screenshot in my very first post. One with the joystick moved left/down and one without touching the joystick. The change between both screenshots is very interesting and maybe points to a possible root cause?

By the way - I just downloaded the schematic for my 3GE version from here: https://github.com/Guimli/Vectrex-Schematic
I also got the one from the service manual from console5.com but i am not sure whether that´s the right one for my version?

Best regards
Did you see the edit I made to my last post regarding the oscilloscope traces in the manual I linked you to?

Now you have a 'permanent fault' I would suggest starting again from square one regarding the diagnostic process.

Now I read it. It probably overlapped when I replied to you. Yes - it makes totally sense to me to scope the X,Y and Z waveforms first. I am gonna set this up on the weekend and will reply with some screenshots here. Looking forward for the hunt with you ;)

i can now show off some results. I strictly followed the scope settings in the Table as Dave suggested. In photo #1 you can see my scope with the setting for the very first test (wafeforms X, Y, Z). I understood the EXT.SYNC means my external trigger in, right? So I put my first probe there and connected to GND / Pin9 of IC302. Then I probed X, Y, Z at J301 (connector Digital Board) and I also measured at the various points at the Analog Board where the blue (Y), the red (X) and yellow(Z) wires are ending. The wafeforms I got were identical at the Analog and Digital board. Therefore I only post the pictures taken from J301. X and Y (#2, #3) looks quite ok to me. Z (#4) is a bit off..
All measurements are taken with the Test Cart Rev. 4 running with the cross-hatch screen.

Next I probed at Pin 7 (#5) and Pin 8 (#6) at IC401 following the scope setting advised in the table and running Test 4 and only when DAC OFFSET displayed. These waves are looking a little bit off, right?

Next I measured the voltages at the CRT PCB (#7):
EP505 (black wire) 42,8 VDC
EP502 (blue wire) 5,00 VDC
EP503 (grey wire) -0,07 mVDC
EP504 (green wire) -0,6 VDC
EP501 (brown wire) 133,6 VDC

Lastly I tried to get the waveform of EP505 (#8). Not sure how to trigger that one. I followed the Scope setting advise from the table but the wave looks odd. Tried to find a better setting without success.


  • GiUjRHEeRFyL0EsJBS1b3g.jpg
    2.1 MB · Views: 12
  • dXcrgV1STRKNPu4z4ufgng.jpg
    1.6 MB · Views: 10
  • fullsizeoutput_2524.jpeg
    1.1 MB · Views: 10
  • fullsizeoutput_2528.jpeg
    467 KB · Views: 10
  • oSxyMqZzT%SheihSDGnX8g.jpg
    2.4 MB · Views: 11
  • Fn%lsfbvSxOIo9TXcfUwcA.jpg
    2.4 MB · Views: 11
  • o1nsjoeBTkut0nprr1gMtg.jpg
    2.4 MB · Views: 11
  • fullsizeoutput_251f.jpeg
    1.5 MB · Views: 11
Yes, a good lunch...

I suspect something has scrambled the order of the photographs - but there is definitely something wrong isn't there. Next time you post any photographs, can I suggest you change the filenames to incorporate some means of referencing them from the text?

Here is how I would tackle the problem:

1. Check the +5V ANA and -5V ANA power supplies to the pins of the ICs where they are used (303, 304 and 305) - you will find the pin numbers on the schematic. Also, where these power supplies are used within the analogue circuitry. Again, check the schematic and tick each off as you proceede. I don't expect a problem here, but let's rule it out to start with shall we...

Next, I would use your oscilloscope looking at the following points with the test cartridge crosshatch pattern displayed:

1. IC302 pin 13 for both positive and negative voltage swings (DAC voltage output into MUX and X).

2. IC302 pins 9 and 10 for activity (SEL0 and SEL1).

3. IC303 pin 7 for both positive and negative voltage swings (Y).

4. IC303 pins 10 and 8 for activity (Z).

Let's see how far that gets us shall we?

Thanks Dave. Sounds like a good plan.I will look into that later today or tomorrow.
Sorry about the photos out of the right order. Did not expect that :(
Hi Dave, hereby my results:

I measured analog +5VDC and -5VDC on IC301,302,303,304,305 - all ok. I also measured at the 10k pot´s 333 and 335 - all good. I did this exercise already before and never found a faulty voltage yet - apart from the sometimes missing -13VDC (see my notes in my first post). But since a week I dont lose the -13VDC anymore. Like one isue went away and another one replaced it....:(

Attached the screenshots from the scope measurements. I still used IC302/9 as external trigger and set my scope to 0,1ms/DIV and 0,2 V/DIV. At IC302/9 I got no waveform at all (also removed my trigger there) - just a flatline thus there is no photo.

So IC303-8 and IC303-10 are probably not looking like expected, right? Because IC302 is not getting good signals through SEL0 and SEL1 from the 6522? Does my conclusion make sense?


  • IC302-10.jpg
    2.4 MB · Views: 6
  • IC302-13.jpg
    2.4 MB · Views: 6
  • IC303-7.jpg
    2.5 MB · Views: 5
  • IC303-8.jpg
    2.4 MB · Views: 3
  • IC303-10.jpg
    2.4 MB · Views: 4
before you ask - just measured continuity IC207-11 (VIA 6522) with IC302-10 and IC207-12 with IC302-9.
All ok! That would be too easy, right?
IC302/13 is good (the output from the DAC via the I/V converter). It has a good positive and negative voltage swing.

IC302/10 (SEL0) also looks good.

IC302/9 (SEL1) not so good!

This may account for the lack of a Z signal.

I would have thought that IC303/7 (Y) should have swung both positive and negative. I assume (from the photograph) that it is swinging between 0V and positive? Can you confirm that for me please?

Can you go back to the VIA IC207 and scope pins 11 (SEL0) and 12 (SEL1). You have already tested for continuity... Well anticipated!

Let's see if we can find out where SEL1 has gone. Try adjusting the oscilloscope timebase to see if there is anything at all on IC207 pin 12 (SEL1)...

Dave, regarding IC303/7 - there is indeed only a positive swung. I did set my scope to 0,0 V

I will move on tommorow. I am depended on daylight as my work place is in our garden house and the electrical light there is not suffiient.

This was already very interesting today. Thank you very much for great support:)