• Please review our updated Terms and Rules here

Vectrex with really hair pulling strange -13v problem..

kbjunkie

New Member
Joined
Dec 11, 2023
Messages
3
Hi all,

I've been repairing a Vectrex that I bought and I have come across a strange issue.

Background:

When I got it, it had sound but no picture apart from a white dot in the centre of the screen. I thought maybe the main switch had an issue. I tested it and both poles appeared to switch correctly and had continuity, but I took it off the board, took it apart, cleaned the poles and run some deoxit into it and reassembled. The switch works like a charm and both poles read about 1R when the switch is operated.

I put it back in and.. same issue. Sound but no picture.

Checked that the AC inputs to the power board were reaching it when turned on - all good - around 10.8vAC from each red to the white CT wire.

All other voltages at the power plug on the logic board are there - +5,-5 but no -13v. Found that D107 was shorted and the 13v zener was dead too. Replaced those and still no -13v. Checked the other diodes in that circuit and all appear good.

At this point I decided to go mad and replace all electrolytic caps and the integrator caps. So far so good. -13V back and the Vectrex was working.

So, forward in time a few days. Powered the Vectrex back up, no -13v!

Checked around the -13v circuit and nothing. The 7805/7905 regs are working fine and outputting the correct voltages.

This is where it gets weird. I turn the vectrex on, get sound (can hear the built in game sound) but have no picture. I check -13v on the power connector on the logic board and again, all voltages are good except the -13v. I decided to pull the plug off the board (with the vectrex turned on) and measure the -13v at the plug to see if it came back and maybe I had an issue with the DAC chip shorting or something and the -13v was still missing......

I plugged the connector back into the power board - and the -13v came back!!? I switched it on and off a few times and the vectrex starts normally.... WTF!?

I leave it unplugged for an hour or so, and switch it back on. NO -13v!! I unplug the power cable from the logic board again and connect it back whilst the vectrex is switched on, -13V comes back!

I should also say that I made up a new molex connector and replaced the 4 wire cable from the power board and the plug end and replaced the socket on the logic board just in case I had a damaged wire / dirty plug/socket.

Can anyone at all make sense of this?

Thanks in advance!
 
Could it be a bad solder joint? My guess is probably somewhere that you haven't soldered yet since those joints are fresh. Ive never owned a Vectrex tho so idk if this is a common issue or something.
 
Could it be a bad solder joint? My guess is probably somewhere that you haven't soldered yet since those joints are fresh. Ive never owned a Vectrex tho so idk if this is a common issue or something.
I have gone over every joint on both the power and logic boards with a microscope and resoldered any that looked even a little bad. It's not that - thanks for the suggestion though. It's a weird problem that I can't get my head around.

Bad solder joints and bad vias/through hole plating are a problem on the Vectrex PCB's but I've made sure that when I replaced the caps, I soldered both sides of the board (left the caps a little up off the board and got a fine tipped soldering iron underneath them).

It's altogether very frustrating as the machine will work fine as long as I power it up, unplug the power connector between the power and login boards and plug it back in.
 
So you only get -13 if you let the unit warm up? Could it be a thermal failure of the regulator?
Hi NeXT,

No. From cold, the Vectrex when switched on will not deliver the -13 supply - it's just completely missing in action from the power board. -9v regulator is fine though. If I then leave the switch in the ON position and remove J204 (the power connector from the power board to the logic board) and then put it back on again, the -13v supply starts up and the Vectrex is good. If I then switch the Vectrex on and off with the main switch, all remains good. If I then leave the Vectrex for some time (say 30mins to an hour) switched off, the same thing will happen again on switch on - no -13v until I pull and replace J204.

I mean, it sounds like it's cap related - but I've replaced all electrolytic caps including the integrator caps (but not the couple of Tants inside come to think about it), and it doesn't appear to be thermal either. Nothing gets over warm at all. I've also socketed and replaced the DAC chip and the LF347 as the sockets that were in the board were single wipe and quite corroded looking.

I have replaced the Zener with a 500mW 13v Zener - I did wonder if this was somehow the issue. Maybe the old type Zener diode in these Vectrex machines had different characteristics than those today? The schematic in the service manual doesn't give a part number, it just says 13v+/-1V @10mA 400mw Zener. I'm not sure about the 10mA spec - any idea? Is this the current that the Zener 'adds' to the circuit?

Apart from that, the PCB's in the Vectrex are really clean..

NO idea what to do - it's got me a little stumped to be honest.
 
That -13v generation is a simple circuit. If you are unplugging J204 and you are getting no voltage from -13 there's only seven discrete components that make up the entire -13v supply.
D107 and D108 are doing your rectification from AC to DC, albeit half-wave. If one of those go open the circuit opens. The Zener I think is being used to keep the voltage around -13v. If it shorted something spiked and it sacrificed itself, but C120 would prevent a dead short going back to the AC supply and blowing the fuse.
I'd suspect D106 or D107 might be thermally failing after some sort of a previous failure event. R106 could also be intermittent. C122 is to filter out ripple. Replace those two diodes as a pair and see what changes.

vct_PSU.png
 
You might want to go over the traces with a magnifier--a hairline-cracked trace can drive you up the wall.
The 10 ma is the amount of current that the diode is rated to pass. Usually, this means that the diode appears as nothing more than a reference for a regulator circuit. So you have unregulated voltage->resistor->diode->ground typically. If the unregulated voltage is too high, you can exceed the current rating of the diode. Clearly, if it's under the zener voltage, you'll have issues as well. If the resistor is open, you'll also have issues.
 
Last edited:
We did have a thread where we had exactly this behaviour on the -13V rail.

I can't remember exactly how we fixed it, but I think we had a few concurrent problems.

The switch could have gone faulty. It is a dual pole switch.

Yep, bad solder joint or cabke connection - especially around EP106.

C120 could also be faulty.

As you say, it could be any of the components, and you just have to work the problem through.

I would suggest trying to track down our other thread.

Dave
 
Looking at the schematic, the 13V zener appears to be on the output of a regular voltage-doubler circuit. That is C120 is charged through D107 on one half-cycle of the AC input; on the other AC half-cycle, D106 charges C121 with the AC superimposed on the DC level that C120 has been charged to (D107 is not conducting) , providing 2x the input voltage on C120.
 
Hi kbjunkie, David is remembering right, I got this missing -13V issues now in 2x Vectrex and on both it was caused by multiple issues:

1. marginally working or dead diodes in that circuit, I replaced all 3: D106, D107, DZ102
2. Bad contacts in that circuit, like I found between EP106 and C120, visually ok but I found bad contact with multimeter in continuity mode: make sure these components are soldered from both sides. That’s a general issue with the Vectrex caused by poor vias
3. Maybe bad capacitors: I replaced C120, C121 and C122

Good luck!

Denis
 
Back
Top