• Please review our updated Terms and Rules here

Xt 286

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
Hello everyone!

I am new here, and I am only 17, with practically no knowledge about Vintage Computers. I found a IBM XT 286 in my basement that my dad had turned a monitor over on top of and had been using the top as a sort of table for his mouse. Upon giving him an actual table to use, he let me take the computer. Now, I obviously knew that there was a reason it was not being used, but I tried it anyways. When it starts, it says:

00640 KB OK
162-System Options Not Set-(Run SETUP)

CompatiCard IV BIOS Version 1.04

Copyright 1989-1990 by MicroSolutions, Inc.

Card address: B, BIOS address: CE00:0000h
DMA Channel: 2, Interrupt Level: 6

Drive B1 -> 3.5 inch 1.4 MB
(Resume = "F1" KEY)


Upon pressing the f1 key, it goes to BASIC.

The IBM Personal Computer Basic
Version C1.10 Copyright IBM Corp 1981
62940 Bytes free
OK

How can I get DOS to run?

Thanks!
 
Last edited:

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
39,424
Location
Pacific Northwest, USA
I'm assuming that the A: drive is a 5.25" unit. If so, all you really have to do is to put a DOS boot disk in the drive and reboot. You'll need to do that anyway to run the SETUP program. My suspicion is that the machine has a dead battery for the CMOS settings chip.
 

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
I believe you are right about the 5.25" unit being A:. This is the only computer in my house with a 5.25" unit, so I can't just make a boot disk for DOS. I tried making one for the 3.5", but that did nothing. How do you suggest I acquire a 5.25" boot disk for this?
 

Stone

10k Member
Joined
Nov 3, 2009
Messages
12,814
Location
South Jersey, USA
1) You can try reversing the ribbon cable positions internally and see if that works and swaps A and B.

2) You can remove the 5¼" drive, put it in the other machine and make a 5¼" disk there.

You've probably got a 20MB hard drive in there so once you get it to boot you can run gsetup.exe to set the configuration for the drive and other stuff.
 

dpatten

Experienced Member
Joined
Mar 30, 2006
Messages
285
Location
Melbourne, FL
Hello everyone!

I am new here, and I am only 17, with practically no knowledge about Vintage Computers. I found a IBM XT 286 in my basement that my dad had turned a monitor over on top of and had been using the top as a sort of table for his mouse. Upon giving him an actual table to use, he let me take the computer. Now, I obviously knew that there was a reason it was not being used, but I tried it anyways. When it starts, it says:

00640 KB OK
162-System Options Not Set-(Run SETUP)

CompatiCard IV BIOS Version 1.04

Copyright 1989-1990 by MicroSolutions, Inc.

Card address: B, BIOS address: CE00:0000h
DMA Channel: 2, Interrupt Level: 6

Drive B1 -> 3.5 inch 1.4 MB
(Resume = "F1" KEY)


Upon pressing the f1 key, it goes to BASIC.

The IBM Personal Computer Basic
Version C1.10 Copyright IBM Corp 1981
62940 Bytes free
OK

How can I get DOS to run?

Thanks!

Where are you located?
 

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
"1) You can try reversing the ribbon cable positions internally and see if that works and swaps A and B."

I will definitely try this; gimme a couple minutes.
 

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
I already switched the drive anyways. When I boot it, however, nothing different happens. Do I have the wrong boot disk DOS version? I made one for Dos 3.3.
 

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
West Virginia. I am afraid to tell you that because I am just adding to the prejudices that already come with being a West Virginian!
 

orion24

Experienced Member
Joined
Oct 19, 2011
Messages
249
Location
Greece
More likely the CMOS battery is dead and this means that the settings are reset to default.

If this is the case, then you need to enter the CMOS SETUP and change some settings. When the PC starts it must say somewhere what "key" you need to press in order to enter the CMOS SETUP (Usually it the the "DEL" key, the CTRL+ALT+ESC combo, or an F1-F12 key).
- If you do enter the setup, you must find and set DRIVE A: to 1,44MB or 720KB, depending on what your system has (that is assuming you want to boot from a 3,5 inch disk. If you want to boot from a 5,25 you set that drive as drive A)
- If the PC has a hard drive, in order for it to work, you must define the CYLINDERS, HEADS and SECTORS the drive has in the CMOS SETUP. These values are written on the hard drive (you need to open the case and look at it).
- In the CMOS SETUP there might be an option saying BOOT FROM (or something like that) and then A,C or C,A. If you want to boot from the floppy, this must be set to A,C

You SAVE the settings and exit setup. The CMOS settings will remain only while the PC is powered on, then they will reset again, unless you fix the batter problem.
After doing these, you need to make sure that the drive you defined as A: in the BIOS SETUP, is the one that is connected to the standard I/O controller with the connector that is at the "EDGE" (the one in the middle is for DRIVE B). Then it should boot
 

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
It only says the stuff I said it says; nothing else. Nothing about how to enter CMOS. I tried all the keys you suggested and none worked.
 

dpatten

Experienced Member
Joined
Mar 30, 2006
Messages
285
Location
Melbourne, FL
More likely the CMOS battery is dead and this means that the settings are reset to default.

If this is the case, then you need to enter the CMOS SETUP and change some settings. When the PC starts it must say somewhere what "key" you need to press in order to enter the CMOS SETUP (Usually it the the "DEL" key, the CTRL+ALT+ESC combo, or an F1-F12 key).
- If you do enter the setup, you must find and set DRIVE A: to 1,44MB or 720KB, depending on what your system has (that is assuming you want to boot from a 3,5 inch disk. If you want to boot from a 5,25 you set that drive as drive A)
- If the PC has a hard drive, in order for it to work, you must define the CYLINDERS, HEADS and SECTORS the drive has in the CMOS SETUP. These values are written on the hard drive (you need to open the case and look at it).
- In the CMOS SETUP there might be an option saying BOOT FROM (or something like that) and then A,C or C,A. If you want to boot from the floppy, this must be set to A,C

You SAVE the settings and exit setup. The CMOS settings will remain only while the PC is powered on, then they will reset again, unless you fix the batter problem.
After doing these, you need to make sure that the drive you defined as A: in the BIOS SETUP, is the one that is connected to the standard I/O controller with the connector that is at the "EDGE" (the one in the middle is for DRIVE B). Then it should boot


This is an XT not an AT.
 

per

Veteran Member
Joined
Jan 21, 2008
Messages
3,006
Location
Western Norway
More likely the CMOS battery is dead and this means that the settings are reset to default.

If this is the case, then you need to enter the CMOS SETUP and change some settings. When the PC starts it must say somewhere what "key" you need to press in order to enter the CMOS SETUP (Usually it the the "DEL" key, the CTRL+ALT+ESC combo, or an F1-F12 key).
- If you do enter the setup, you must find and set DRIVE A: to 1,44MB or 720KB, depending on what your system has (that is assuming you want to boot from a 3,5 inch disk. If you want to boot from a 5,25 you set that drive as drive A)
- If the PC has a hard drive, in order for it to work, you must define the CYLINDERS, HEADS and SECTORS the drive has in the CMOS SETUP. These values are written on the hard drive (you need to open the case and look at it).
- In the CMOS SETUP there might be an option saying BOOT FROM (or something like that) and then A,C or C,A. If you want to boot from the floppy, this must be set to A,C

You SAVE the settings and exit setup. The CMOS settings will remain only while the PC is powered on, then they will reset again, unless you fix the batter problem.
After doing these, you need to make sure that the drive you defined as A: in the BIOS SETUP, is the one that is connected to the standard I/O controller with the connector that is at the "EDGE" (the one in the middle is for DRIVE B). Then it should boot

The XT-286, as with the IBM PC/AT, does not come with a CMOS setup program in ROM. Because of this, you must run a setup program from disk. The IBM AT Diagnostics disk contains such a setup program, but there are alternative programs like GSetup.

The XT-286 does not contain a setting for custom HDD parameters either, so you may want to figure what type the HDD is (it is typically labeled quite obviously). The 20MB drives in the XT-286 machines were mostly either Type 2 (Segate ST-225) or Type 13 (Western Digital WD-25). It's also impossible to set the boot order in the XT-286.

So in order to get the machine running, you will either need an IBM PC/AT Diagnostics disk or a boot disk with something like GSetup on it.
 
Last edited:

Stone

10k Member
Joined
Nov 3, 2009
Messages
12,814
Location
South Jersey, USA
It only says the stuff I said it says; nothing else. Nothing about how to enter CMOS. I tried all the keys you suggested and none worked.
You apparently didn't read through some of the tips left in a few of the earlier posts. It's not too late to read them now.

This is an XT not an AT.
And orion24 didn't read any of the thread before posting. :)
 

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
I have read all of the posts and I have skimmed through the pdf for this card, but between these things called "jumpers" and other technical names, I have no clue what anything is talking about. All I know is that that card is delusional, because there is no floppy drives connected to it; I have only the 3.5" disk plugged in, and it is not plugged into the compaticard, it is plugged into the original controller for the computer. More Info: I have a Type 2 drive, a Plus Hardcard 40, a Compaticard IV, and an HCT Video 200. The original controller has the one and only one 3.5" drive plugged into J1, and two other things are plugged into j3 and j5, but they are NOT other floppy drives.
 

orion24

Experienced Member
Joined
Oct 19, 2011
Messages
249
Location
Greece
The XT-286, as with the IBM PC/AT, does not come with a CMOS setup program in ROM. Because of this, you must run a setup program from disk. The IBM AT Diagnostics disk contains such a setup program, but there are alternative programs like GSetup.

The XT-286 does not contain a setting for custom HDD parameters either, so you may want to figure what type the HDD is (it is typically labeled quite obviously). The 20MB drives in the XT-286 machines were mostly either Type 2 (Segate ST-225) or Type 13 (Western Digital WD-25). It's also impossible to set the boot order in the XT-286.

So in order to get the machine running, you will either need an IBM PC/AT Diagnostics disk or a boot disk with something like GSetup on it.

Run the CMOS setup from disk? You've got me now; I was not aware of the absence of a CMOS setup program in ROM in these machines. All my PCs, including the 286, have one. I guess I'll start messing with a just-arrived IBM-5150 board to familiarize myself with pre-AT PCs (that is after I change some capacitors and fix some staff on it).
 

per

Veteran Member
Joined
Jan 21, 2008
Messages
3,006
Location
Western Norway
Run the CMOS setup from disk? You've got me now; I was not aware of the absence of a CMOS setup program in ROM in these machines. All my PCs, including the 286, have one. I guess I'll start messing with a just-arrived IBM-5150 board to familiarize myself with pre-AT PCs (that is after I change some capacitors and fix some staff on it).

This is off-topic here, but the 5150 PC and 5160 XT does not have CMOS settings at all, and they uses a set of DIP-switches on the motherboard to set the configuration. The 5162 XT-286, despite being called an "XT", is in fact really a fully featured AT in an XT form-factor. As for CMOS setup programs, I guess AMI might have been the first company to include one in ROM. IBM kept it on disk even for their PS/2 line of PCs all the way untill 1992 or so.

Back on topic. since the compaticard isn't connected to anything, you may try to boot the computer without it. I don't exactly remember how this worked (maybe you needed a more recent FDD controller), but try booting with genuine 720KB media. This may make the FDD act like a 720KB drive, which will make the BIOS think of it as a 360KB drive. This works, even though the BIOS theoretically don't know about the other half of the disk's contnent. If you can get DOS to boot this way, then DOS will use it's own drivers which can see the entire 720KB.

The XT-286 came standard with a 1.2MB 5.25" drive as drive A.

The two other connections on the FDD/HDD controller card is for the HDD, and you don't need to worry about those.
 
Last edited:

lunchmeat

Member
Joined
Mar 10, 2012
Messages
32
Back on topic. since the compaticard isn't connected to anything, you may try to boot the computer without it. I don't exactly remember how this worked (maybe you needed a more recent FDD controller), but try booting with genuine 720KB media. This may make the FDD act like a 720KB drive, which will make the BIOS think of it as a 360KB drive. This works, even though the BIOS theoretically don't know about the other half of the disk's contnent. If you can get DOS to boot this way, then DOS will use it's own drivers which can see the entire 720KB.

I have removed the compaticard.

Now it says
00640 KB OK
161-System Options Not Set-(Run SETUP)

(RESUME = "F1" KEY)

Once again, upon pressing F1, It goes straight into BASIC.

What is genuine 720KB media? Does that mean I should use other disks than 1.44 MB HD 3.5" floppys?
 
Top